Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC Issues, Lag, Stuttering, Freezing, Etc

CamIndigo1
 Share

Ok, here is the issue:

In any game I play, I lag extremely bad. Were talking freezing, stuttering, etc. For example in PUBG, my game will be fine just running around and looting, but if I get in a gun fight it starts to freeze and stutter. I will drop to around 5-7 fps and not be able to do anything. I have the most updated drivers, and have reinstalled games on both my SSD and HDD/switched from one to the other.

PC Build- https://pcpartpicker.com/list/KRjtpG

Here are screenshots of HWMonitor- https://imgur.com/gallery/hdXrQYj (had to stitch screenshots together to see everything, sorry if look weird)

Not sure if those tell anything.

Another thing I noticed in many games is that my CPU will be at 100% and my gpu will only be about 50-60%

Had this PC for around 3 years, upgraded to 1070 around 6month ago, issue started around 1 month ago

Also, in Hwmonitor it says that Intel Graphics is running along side my gpu at the same time? Could this be a problem?

Thanks so much!

Link to comment
Share on other sites

Link to post
Share on other sites

21 minutes ago, CamIndigo1 said:

Ok, here is the issue:

In any game I play, I lag extremely bad. Were talking freezing, stuttering, etc. For example in PUBG, my game will be fine just running around and looting, but if I get in a gun fight it starts to freeze and stutter. I will drop to around 5-7 fps and not be able to do anything. I have the most updated drivers, and have reinstalled games on both my SSD and HDD/switched from one to the other.

PC Build- https://pcpartpicker.com/list/KRjtpG

Here are screenshots of HWMonitor- https://imgur.com/gallery/hdXrQYj (had to stitch screenshots together to see everything, sorry if look weird)

Not sure if those tell anything.

Another thing I noticed in many games is that my CPU will be at 100% and my gpu will only be about 50-60%

Had this PC for around 3 years, upgraded to 1070 around 6month ago, issue started around 1 month ago

Also, in Hwmonitor it says that Intel Graphics is running along side my gpu at the same time? Could this be a problem?

Thanks so much!

Check your Nvidia Control Panel, if the preferred graphics processor is on auto-select try to change that to High-performance Nvidia processor. It might be using your intel integrated graphics.

Link to comment
Share on other sites

Link to post
Share on other sites

56 minutes ago, CamIndigo1 said:

Ok, here is the issue:

In any game I play, I lag extremely bad. Were talking freezing, stuttering, etc. For example in PUBG, my game will be fine just running around and looting, but if I get in a gun fight it starts to freeze and stutter. I will drop to around 5-7 fps and not be able to do anything. I have the most updated drivers, and have reinstalled games on both my SSD and HDD/switched from one to the other.

PC Build- https://pcpartpicker.com/list/KRjtpG

Here are screenshots of HWMonitor- https://imgur.com/gallery/hdXrQYj (had to stitch screenshots together to see everything, sorry if look weird)

Not sure if those tell anything.

Another thing I noticed in many games is that my CPU will be at 100% and my gpu will only be about 50-60%

Had this PC for around 3 years, upgraded to 1070 around 6month ago, issue started around 1 month ago

Also, in Hwmonitor it says that Intel Graphics is running along side my gpu at the same time? Could this be a problem?

Thanks so much!

Scan your computer with malwarebytes with rootkit detection enabled. I wrote a guide on how to troubleshoot malware.

 

 

If its not that, do a CLEAN install of the newest drivers without GFE. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×