Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

KSP capping at 21FPS when alt tabing out

Kd4lif3
 Share

Go to solution Solved by ShredBird,
On 11/5/2018 at 9:33 PM, Kd4lif3 said:

This is an issue I have only had in Kerbal space program. The issue happens when I load into the game and alt tab to access another window. I fixed it once by turning full screen off then on again. It can be fixed by relaunching the game. I have a 1070, 6600k, 8gb ram. I have a gsync monitor at 144 hz and a secondary monitor which is at 60hz. I updated my graphics drivers after the issue started. Not much else to be said, thanks.

This is a bug with the Unity game engine, it doesn't use an exclusive fullscreen mode and sometimes when you alt-tab out it doesn't kick back into full performance mode the way it should.  However, you can fix it by adding this to your launch options to Steam (if you have it on Steam, you can add it to a shortcut if not):

-window-mode exclusive

The game acts a little weird in this mode, sometimes the window will drop out briefly for moment and then come back when you start the game, and alt-tabbing will get little more unreliable but should still work.  No FPS drops this way though.

This is an issue I have only had in Kerbal space program. The issue happens when I load into the game and alt tab to access another window. I fixed it once by turning full screen off then on again. It can be fixed by relaunching the game. I have a 1070, 6600k, 8gb ram. I have a gsync monitor at 144 hz and a secondary monitor which is at 60hz. I updated my graphics drivers after the issue started. Not much else to be said, thanks.

Link to comment
Share on other sites

Link to post
Share on other sites

On 11/5/2018 at 9:33 PM, Kd4lif3 said:

This is an issue I have only had in Kerbal space program. The issue happens when I load into the game and alt tab to access another window. I fixed it once by turning full screen off then on again. It can be fixed by relaunching the game. I have a 1070, 6600k, 8gb ram. I have a gsync monitor at 144 hz and a secondary monitor which is at 60hz. I updated my graphics drivers after the issue started. Not much else to be said, thanks.

This is a bug with the Unity game engine, it doesn't use an exclusive fullscreen mode and sometimes when you alt-tab out it doesn't kick back into full performance mode the way it should.  However, you can fix it by adding this to your launch options to Steam (if you have it on Steam, you can add it to a shortcut if not):

-window-mode exclusive

The game acts a little weird in this mode, sometimes the window will drop out briefly for moment and then come back when you start the game, and alt-tabbing will get little more unreliable but should still work.  No FPS drops this way though.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×