Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Games look blurry with DSR

Od1sseas
 Share

Using NVIDIA's DSR (Dynamic Super Resolution), when i increase the resolution in any game they look blurry! Only 4K DSR looks perfect, why other resolutions look blurry!?

Link to comment
Share on other sites

Link to post
Share on other sites

You've really gotta play with the smoothness factor for resolutions that aren't even multiples of your native res (or whatever it's called, it's been awhile since I've really used an Nvidia card). That was definitely my biggest gripe with DSR (my second biggest was that the cursor didn't scale along with the resolution, though maybe that's been fixed since I used it).

Main rig on profile

Zephyrus - Windows 7 side rig

Spoiler

AMD Phenom II X6 1055T (undervolted to 1.26v w/ CM 212 EVO), 1x8GB ADATA XPG V1.0 (1600MHz CL9), Asus M4A77TD, 240GB Kingston UV400, 1TB Toshiba 2.5", EVGA GTX 960 SC, Enthoo Pro, Corsair CX750M, Windows 7 Ultimate 64-bit

Mac Mini (Late 2014)

Spoiler

Intel Core i5 4278U, 8GB RAM, 250GB Samsung 840 EVO, macOS Monterey, using it with a ViewSonic VX2748

Consoles: Softmodded 1.4 Xbox w/ 500GB HDD, Xbox 360 Elite 120GB Falcon, XB1X 1TB, PS1 1001, PS2 Slim 70000 w/ FreeMcBoot, PS4 Pro 7015B 2TB

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, emosun said:

if you monitor has a weird subpixel layout then only its native res will look ok

4K DSR actually looks perfect, all other DSR res look blurry

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, flibberdipper said:

You've really gotta play with the smoothness factor for resolutions that aren't even multiples of your native res (or whatever it's called, it's been awhile since I've really used an Nvidia card). That was definitely my biggest gripe with DSR (my second biggest was that the cursor didn't scale along with the resolution, though maybe that's been fixed since I used it).

Correct me if i'm wrong but highter smoothness makes the image blurrier, that's why i set it to 0%

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Od1sseas said:

Correct me if i'm wrong but highter smoothness makes the image blurrier, that's why i set it to 0%

From what I remember that's right. IIRC the sweet spot for 1440p on a 1080p monitor (for me) was like 13 or 14%. It's really odd. (just gonna say it but AMD's VSR is a lot nicer IMO)

Main rig on profile

Zephyrus - Windows 7 side rig

Spoiler

AMD Phenom II X6 1055T (undervolted to 1.26v w/ CM 212 EVO), 1x8GB ADATA XPG V1.0 (1600MHz CL9), Asus M4A77TD, 240GB Kingston UV400, 1TB Toshiba 2.5", EVGA GTX 960 SC, Enthoo Pro, Corsair CX750M, Windows 7 Ultimate 64-bit

Mac Mini (Late 2014)

Spoiler

Intel Core i5 4278U, 8GB RAM, 250GB Samsung 840 EVO, macOS Monterey, using it with a ViewSonic VX2748

Consoles: Softmodded 1.4 Xbox w/ 500GB HDD, Xbox 360 Elite 120GB Falcon, XB1X 1TB, PS1 1001, PS2 Slim 70000 w/ FreeMcBoot, PS4 Pro 7015B 2TB

Link to comment
Share on other sites

Link to post
Share on other sites

7 minutes ago, Od1sseas said:

4K DSR actually looks perfect, all other DSR res look blurry

I'm guessing you're using a 1080p or similar display as opposed to 1440p? UHD "4K"  is a a factor of 4x higher than 1080p which means there isn't any smoothing needed for pixels to line up for supersampling.

 

Moved to Graphics Cards.

If you ever need help with a build, read the following before posting: http://linustechtips.com/main/topic/3061-build-plan-thread-recommendations-please-read-before-posting/
Also, make sure to quote a post or tag a member when replying or else they won't get a notification that you replied to them.

Link to comment
Share on other sites

Link to post
Share on other sites

29 minutes ago, flibberdipper said:

 (my second biggest was that the cursor didn't scale along with the resolution, though maybe that's been fixed since I used it).

You have to enable software cursors if the app supports it. Otherwise by default the cursor is rendered last and overlayed on top.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, M.Yurizaki said:

You have to enable software cursors if the app supports it. Otherwise by default the cursor is rendered last and overlayed on top.

I used it on the desktop primarily so software cursors weren't really a thing.

Main rig on profile

Zephyrus - Windows 7 side rig

Spoiler

AMD Phenom II X6 1055T (undervolted to 1.26v w/ CM 212 EVO), 1x8GB ADATA XPG V1.0 (1600MHz CL9), Asus M4A77TD, 240GB Kingston UV400, 1TB Toshiba 2.5", EVGA GTX 960 SC, Enthoo Pro, Corsair CX750M, Windows 7 Ultimate 64-bit

Mac Mini (Late 2014)

Spoiler

Intel Core i5 4278U, 8GB RAM, 250GB Samsung 840 EVO, macOS Monterey, using it with a ViewSonic VX2748

Consoles: Softmodded 1.4 Xbox w/ 500GB HDD, Xbox 360 Elite 120GB Falcon, XB1X 1TB, PS1 1001, PS2 Slim 70000 w/ FreeMcBoot, PS4 Pro 7015B 2TB

Link to comment
Share on other sites

Link to post
Share on other sites

It could be your opinion. I've been using DSR since I knew about it and in some games that doesn't has any AA in-game like NFS HP2010 and GTAIV, I enable 4K DSR, which of course gives a very clear image and smoothness is kept stock, 33%. And in heavy games like GTAV, using 1440p, also much better than 1080p. You should play with smoothness. If I set it at 36%, it doesn't look nicer. So ye, 33% IMO.

DAC/AMPs:

Klipsch Heritage Headphone Amplifier

Lake People G103-S (Currently not in use)

Headphones: Klipsch Heritage HP-3 Walnut, Beyerdynamic Amiron Home, Amiron Wireless Copper, T5p.2, Tygr 300R, DT880 600ohm Manufaktur, Fidelio X2HR, Meze 99 Classics Walnut/Gold

Earphones: Airpods 2019, Sony WF1000XM3, Sony MDR-E818LP

CPU: Intel 4770, GPU: Gigabyte Aorus GTX1080Ti, Mobo: MSI Z87-G45, RAM: DDR3 16GB G.Skill, PC Case: Fractal Design R4 Black non-iglass, Monitor: BenQ GW2280.

Link to comment
Share on other sites

Link to post
Share on other sites

I messed around with it for ages 

only 4x resolution is worth it

set smoothness to 0

x1.5 is ok if u add a back in ingame 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×