Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

so near to 5.2ghz

Hi my 7700k is stable at 5.17ghz @1.42v, i'd like to get that to 5.2ghz, but 5.2 isnt even stable at 1.44v!!

I've tried a 52x multiplier and also a 50x and 51x multiplier with the bclk changed, but neither made it stable :(

 

Anyone got some ideas to eek out just a tiny bit more stability without upping the voltage?

 

Thanks!

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

not without spending money, buy a better cpu :P 

Rig Specs:

AMD Threadripper 5990WX@4.8Ghz

Asus Zenith III Extreme

Asrock OC Formula 7970XTX Quadfire

G.Skill Ripheartout X OC 7000Mhz C28 DDR5 4X16GB  

Super Flower Power Leadex 2000W Psu's X2

Harrynowl's 775/771 OC and mod guide: http://linustechtips.com/main/topic/232325-lga775-core2duo-core2quad-overclocking-guide/ http://linustechtips.com/main/topic/365998-mod-lga771-to-lga775-cpu-modification-tutorial/

ProKoN haswell/DC OC guide: http://linustechtips.com/main/topic/41234-intel-haswell-4670k-4770k-overclocking-guide/

 

"desperate for just a bit more money to watercool, the titan x would be thankful" Carter -2016

Link to comment
Share on other sites

Link to post
Share on other sites

drop the temperature further, or get a board that's actually good

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

... no not really. You can mess with system agent voltage and cache voltage (if that’s separate from CPU). As mentioned above, cooler temps will be more stable. You can also delid. That’s about it

My Build, v2.1 --- CPU: i7-8700K @ 5.2GHz/1.288v || MoBo: Asus ROG STRIX Z390-E Gaming || RAM: 4x4GB G.SKILL Ripjaws 4 2666 14-14-14-33 || Cooler: Custom Loop || GPU: EVGA GTX 1080 Ti SC Black, on water || PSU: EVGA G2 850W || Case: Corsair 450D || SSD: 850 Evo 250GB, Intel 660p 2TB || Storage: WD Blue 2TB || G502 & Glorious PCGR Fully Custom 80% Keyboard || MX34VQ, PG278Q, PB278Q

Audio --- Headphones: Massdrop x Sennheiser HD 6XX || Amp: Schiit Audio Magni 3 || DAC: Schiit Audio Modi 3 || Mic: Blue Yeti

 

[Under Construction]

 

My Truck --- 2002 F-350 7.3 Powerstroke || 6-speed

My Car --- 2006 Mustang GT || 5-speed || BBK LTs, O/R X, MBRP Cat-back || BBK Lowering Springs, LCAs || 2007 GT500 wheels w/ 245s/285s

 

The Experiment --- CPU: i5-3570K @ 4.0 GHz || MoBo: Asus P8Z77-V LK || RAM: 16GB Corsair 1600 4x4 || Cooler: CM Hyper 212 Evo || GPUs: Asus GTX 750 Ti, || PSU: Corsair TX750M Gold || Case: Thermaltake Core G21 TG || SSD: 840 Pro 128GB || HDD: Seagate Barracuda 2TB

 

R.I.P. Asus X99-A motherboard, April 2016 - October 2018, may you rest in peace. 5820K, if I ever buy you a new board, it'll be a good one.

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Brooksie359 said:

Honestly I would keep it as is and be ok with it because it's still quite fast even for an overclocked 7700k. 

Will the extra hertz get you a few extra fps while gaming or is it just a hobby to get highest hertz, if so just buy and sell cpu's but be sure you got a good mobo. Sooner or later silicone will say hello and give you 5.2

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Firewrath9 said:

Ram timing edits?

How could this help?

1 hour ago, Jumper118 said:

not without spending money, buy a better cpu :P 

ow, hurts

1 hour ago, Cereal5 said:

... no not really. You can mess with system agent voltage and cache voltage (if that’s separate from CPU). As mentioned above, cooler temps will be more stable. You can also delid. That’s about it

i already delidded! thats what got the 5.1 stable in the first place :(

1 hour ago, Jurrunio said:

drop the temperature further, or get a board that's actually good

I have a z270f that i got basically for free behind me. Would that be better? Other than that i can't justify the price of a high end mobo :(

 

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

Use better TIM lol or LM if you didnt. What’s your cooler?

My Build, v2.1 --- CPU: i7-8700K @ 5.2GHz/1.288v || MoBo: Asus ROG STRIX Z390-E Gaming || RAM: 4x4GB G.SKILL Ripjaws 4 2666 14-14-14-33 || Cooler: Custom Loop || GPU: EVGA GTX 1080 Ti SC Black, on water || PSU: EVGA G2 850W || Case: Corsair 450D || SSD: 850 Evo 250GB, Intel 660p 2TB || Storage: WD Blue 2TB || G502 & Glorious PCGR Fully Custom 80% Keyboard || MX34VQ, PG278Q, PB278Q

Audio --- Headphones: Massdrop x Sennheiser HD 6XX || Amp: Schiit Audio Magni 3 || DAC: Schiit Audio Modi 3 || Mic: Blue Yeti

 

[Under Construction]

 

My Truck --- 2002 F-350 7.3 Powerstroke || 6-speed

My Car --- 2006 Mustang GT || 5-speed || BBK LTs, O/R X, MBRP Cat-back || BBK Lowering Springs, LCAs || 2007 GT500 wheels w/ 245s/285s

 

The Experiment --- CPU: i5-3570K @ 4.0 GHz || MoBo: Asus P8Z77-V LK || RAM: 16GB Corsair 1600 4x4 || Cooler: CM Hyper 212 Evo || GPUs: Asus GTX 750 Ti, || PSU: Corsair TX750M Gold || Case: Thermaltake Core G21 TG || SSD: 840 Pro 128GB || HDD: Seagate Barracuda 2TB

 

R.I.P. Asus X99-A motherboard, April 2016 - October 2018, may you rest in peace. 5820K, if I ever buy you a new board, it'll be a good one.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, rfcokilljoy said:

I have a z270f that i got basically for free behind me. Would that be better? Other than that i can't justify the price of a high end mobo :(

Z270-F is better, though I'm more inclined to say 'suck less'

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, Cereal5 said:

Use better TIM lol or LM if you didnt. What’s your cooler?

im using LM and mx4 on top with a coolermaster 240mm, temps under Aida64 with FPU/CPU/everything else except drives reaches about 75 degrees after an hour @1.42v

4 minutes ago, Jurrunio said:

Z270-F is better, though I'm more inclined to say 'suck less'

Yeah i assumed it wouldn't be much better, although i can't find info on if its a fake 4 phase or an actual 8 phase. Would be cool if you know! also what would you class as a "Good" overclocking mobo on z270? (not an amazing one, just good)

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, rfcokilljoy said:

im using LM and mx4 on top with a coolermaster 240mm, temps under Aida64 with FPU/CPU/everything else except drives reaches about 75 degrees after an hour @1.42v

Yeah i assumed it wouldn't be much better, although i can't find info on if its a fake 4 phase or an actual 8 phase. Would be cool if you know! also what would you class as a "Good" overclocking mobo on z270? (not an amazing one, just good)

Hm some of CMs rads aren’t the best. Your temps are pretty good but.. yeah guess it’s just a mediocre overclocker

My Build, v2.1 --- CPU: i7-8700K @ 5.2GHz/1.288v || MoBo: Asus ROG STRIX Z390-E Gaming || RAM: 4x4GB G.SKILL Ripjaws 4 2666 14-14-14-33 || Cooler: Custom Loop || GPU: EVGA GTX 1080 Ti SC Black, on water || PSU: EVGA G2 850W || Case: Corsair 450D || SSD: 850 Evo 250GB, Intel 660p 2TB || Storage: WD Blue 2TB || G502 & Glorious PCGR Fully Custom 80% Keyboard || MX34VQ, PG278Q, PB278Q

Audio --- Headphones: Massdrop x Sennheiser HD 6XX || Amp: Schiit Audio Magni 3 || DAC: Schiit Audio Modi 3 || Mic: Blue Yeti

 

[Under Construction]

 

My Truck --- 2002 F-350 7.3 Powerstroke || 6-speed

My Car --- 2006 Mustang GT || 5-speed || BBK LTs, O/R X, MBRP Cat-back || BBK Lowering Springs, LCAs || 2007 GT500 wheels w/ 245s/285s

 

The Experiment --- CPU: i5-3570K @ 4.0 GHz || MoBo: Asus P8Z77-V LK || RAM: 16GB Corsair 1600 4x4 || Cooler: CM Hyper 212 Evo || GPUs: Asus GTX 750 Ti, || PSU: Corsair TX750M Gold || Case: Thermaltake Core G21 TG || SSD: 840 Pro 128GB || HDD: Seagate Barracuda 2TB

 

R.I.P. Asus X99-A motherboard, April 2016 - October 2018, may you rest in peace. 5820K, if I ever buy you a new board, it'll be a good one.

Link to comment
Share on other sites

Link to post
Share on other sites

you are pushing 5.2.. you have 5.1, and i am just sitting here with a Celeron 2.16 ? you mind splitting some ghz with me? ?

✧・゚: *✧・゚:*  Quote for a reply  *:・゚✧*:・゚✧

 

✧・゚: *✧・゚:*   Ask for discord   *:・゚✧*:・゚✧

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, Cereal5 said:

Hm some of CMs rads aren’t the best. Your temps are pretty good but.. yeah guess it’s just a mediocre overclocker

i got it for £155 so im surprised it even hits 4.6 all core lmao... but i guess i'll have to just leave my cpu at 1.47v for 5.2 ?

5 minutes ago, iLostMyXbox21 said:

you are pushing 5.2.. you have 5.1, and i am just sitting here with a Celeron 2.16 ? you mind splitting some ghz with me? ?

I'd give you all the ghz if i could! although i heard (dont tell anyone this) putting your cpu in "High Performance Mode" will make your cpu run at 6ghz shhhhhhh

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, rfcokilljoy said:

coolermaster 240mm

ML240? A good AIO can also help then. EVGA CLC280's a good option for lower budgets

 

4 minutes ago, rfcokilljoy said:

Yeah i assumed it wouldn't be much better, although i can't find info on if its a fake 4 phase or an actual 8 phase. Would be cool if you know! also what would you class as a "Good" overclocking mobo on z270? (not an amazing one, just good)

Z270-H is true 4 phase, Z270-F is fake 8 phase. Basically means Z270-F has twice the max current output, but only marginally better voltage spike suppression.

 

Good OC board? Boards like the MSI Gaming Pro Carbon, Asrock SuperCarrier, Taichi are 'good', but I myself would do 5ghz+ attempts only on the top boards like the Maximus 9, Gaming 9, Professional Gaming i7, Xpower etc. 

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, Jurrunio said:

but I myself would do 5ghz+ attempts only on the top boards like the Maximus 9, Gaming 9, Professional Gaming i7, Xpower etc.

Why's that?

 

Also thanks for the info on the boards!! i also had a feeling that it was a fake 8 phase but couldn't find the info anywhere hehe.

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, rfcokilljoy said:

Why's that?

I assume you mean why the ML240 suck? Because it just is, according to reviews.

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

27 minutes ago, rfcokilljoy said:

i got it for £155 so im surprised it even hits 4.6 all core lmao... but i guess i'll have to just leave my cpu at 1.47v for 5.2 ?

I'd give you all the ghz if i could! although i heard (dont tell anyone this) putting your cpu in "High Performance Mode" will make your cpu run at 6ghz shhhhhhh

woaahhhh, i wont tell anyone??

✧・゚: *✧・゚:*  Quote for a reply  *:・゚✧*:・゚✧

 

✧・゚: *✧・゚:*   Ask for discord   *:・゚✧*:・゚✧

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Jurrunio said:

I assume you mean why the ML240 suck? Because it just is, according to reviews.

No sorry i meant why would you only use a top board for 5ghz+?

i5 7600k @5.2ghz 1.39v i7 7700k @5.1ghz 1.39v / Strix z270h / 16gb Trident z RGB 3200mhz CL16 1.35v (2400mhz CL15 kit overclocked) / GTX 1070ti sli both with Arctic Accelero Xtreme iv coolers / EVGA 750w Gold PSU

Samsung cf791 3440x1440 100hz Quantum Dot

 

Haven't broken something with an OC yet... YET.

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, rfcokilljoy said:

No sorry i meant why would you only use a top board for 5ghz+?

because top boards allow using less voltage to run any frequency, which means I don't wear out the CPU as fast?

CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×