Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Blue snowball in 2.0 ports but pc detected it as 3.0 port

Okay so I bought a blue snowball ice mic which is a plug and play mic but when I plugged it into my pc and set it as default device, It CAN'T pick up any audio? I tried uninstalling and reinstalling the snowball drivers and remove the snowball from my pc and plugged it back in, still didn't work. When I troubleshoot the hardware it says usb composite device can't work properly with usb 3.0 port but it's already plugged into a usb 2.0 port but it still SAYS THE SAME THING!!!

Link to comment
Share on other sites

Link to post
Share on other sites

Wow, questions usually don't go unanswered here for more than 5 minutes never mind 5 hours...

 

Have you had any issues with other devices in that port?  Have you tried the snowball on another PC?

Solve your own audio issues  |  First Steps with RPi 3  |  Humidity & Condensation  |  Sleep & Hibernation  |  Overclocking RAM  |  Making Backups  |  Displays  |  4K / 8K / 16K / etc.  |  Do I need 80+ Platinum?

If you can read this you're using the wrong theme.  You can change it at the bottom.

Link to comment
Share on other sites

Link to post
Share on other sites

I have a hyperX cloud 2 headphones and it works when I plug it into the usb port... I also bought a usb 2.0 hub and it still doesnt work. My snowball mic cant pick up any audio although it is getting detected by my pc. 

Link to comment
Share on other sites

Link to post
Share on other sites

16 hours ago, Bennie Hing said:

I have a hyperX cloud 2 headphones and it works when I plug it into the usb port... I also bought a usb 2.0 hub and it still doesnt work. My snowball mic cant pick up any audio although it is getting detected by my pc. 

So it shows under recording devices in audio settings but doesn't pick anything up or only in device manager as a non-functional device?

Main PC: Corsair 900D | Designare TRX40 | AMD 3960X | RTX 3090, GTX 1050 TI | Trident Z (4x16GB) | 1TB 980 Pro, 2TB Sabrent Rocket 4+, 2TB 980 Pro, 1TB Sabrent Rocket | HX1200i

Media / Render PC: Corsair 900D (shared) | ASRock X399M | 2970WX | GTX 1660 TI | Trident Z (2x16GB) | 2TB Samsung 970 Evo | HX850

Capture PC: CR1080 | ASRock X399 | 2950X | RTX 2080 TI , GTX 1080 | Trident Z (4x16GB) | 2TB 970 Evo Plus, 1TB 970 Evo Plus | Dual HDMI 4K Plus LT, 2xElgato 4K 60 Pro, HX750
Full Room Watercooling: EK X3 400 | 2xKoolance PMP-500 | 4xEK SE560 | 16x Phanteks PH-F140MP  | EVGA 450 B3

Peripherals: 2xLogitech G502 Wireless | System76 Launch (Box Royals) | Xbox Elite Controller Series 2 | Logitech MX Master 3 | Logitech MX Keys

Displays: Asus XG35VQ | 2xLG 24UD58-B | LG 65UH6030 | Asus VH242H | BenQ GW2480 | HP 22CWA | Kenowa CNC-1080P | Asus VC39H

Audio: RME Fireface UFX+, Scarlett 18i20, RME HDSPe RayDAT, RME HDSPe MADI FX, RME ADI-648, RME ADI-192 DD | 2xYamaha HS5 & Yamaha HS8s | Sennheiser IE 500 Pro, Ultimate Ears RR CIEMs

Full setup - PC Part Picker / Pics: https://pcpartpicker.com/b/ZrWD4D | https://imgur.com/gallery/ZinwYhttps://imgur.com/gallery/yLcZ3 (Needs updating)

Link to comment
Share on other sites

Link to post
Share on other sites

48 minutes ago, TheAgnda said:

So it shows under recording devices in audio settings but doesn't pick anything up or only in device manager as a non-functional device?

Yea it gets detected by my pc so under sound>recordings I can find my blue snowball but the snowball doesn't pick up any audio at all so when I talk to it literally nothing happens but when I troubleshoot it says Device is not composite device can't work properly with 3.0 port but it's already plugged into a 2.0 port and I even bought a cheap usb 2.0 hub and it still can't pick up any audio

Link to comment
Share on other sites

Link to post
Share on other sites

29 minutes ago, Bennie Hing said:

Yea it gets detected by my pc so under sound>recordings I can find my blue snowball but the snowball doesn't pick up any audio at all so when I talk to it literally nothing happens but when I troubleshoot it says Device is not composite device can't work properly with 3.0 port but it's already plugged into a 2.0 port and I even bought a cheap usb 2.0 hub and it still can't pick up any audio

Is the recording level turned up?

Control Panel > Hardware and Sound > Sound > Recording > Properties > Levels
image.png

Main PC: Corsair 900D | Designare TRX40 | AMD 3960X | RTX 3090, GTX 1050 TI | Trident Z (4x16GB) | 1TB 980 Pro, 2TB Sabrent Rocket 4+, 2TB 980 Pro, 1TB Sabrent Rocket | HX1200i

Media / Render PC: Corsair 900D (shared) | ASRock X399M | 2970WX | GTX 1660 TI | Trident Z (2x16GB) | 2TB Samsung 970 Evo | HX850

Capture PC: CR1080 | ASRock X399 | 2950X | RTX 2080 TI , GTX 1080 | Trident Z (4x16GB) | 2TB 970 Evo Plus, 1TB 970 Evo Plus | Dual HDMI 4K Plus LT, 2xElgato 4K 60 Pro, HX750
Full Room Watercooling: EK X3 400 | 2xKoolance PMP-500 | 4xEK SE560 | 16x Phanteks PH-F140MP  | EVGA 450 B3

Peripherals: 2xLogitech G502 Wireless | System76 Launch (Box Royals) | Xbox Elite Controller Series 2 | Logitech MX Master 3 | Logitech MX Keys

Displays: Asus XG35VQ | 2xLG 24UD58-B | LG 65UH6030 | Asus VH242H | BenQ GW2480 | HP 22CWA | Kenowa CNC-1080P | Asus VC39H

Audio: RME Fireface UFX+, Scarlett 18i20, RME HDSPe RayDAT, RME HDSPe MADI FX, RME ADI-648, RME ADI-192 DD | 2xYamaha HS5 & Yamaha HS8s | Sennheiser IE 500 Pro, Ultimate Ears RR CIEMs

Full setup - PC Part Picker / Pics: https://pcpartpicker.com/b/ZrWD4D | https://imgur.com/gallery/ZinwYhttps://imgur.com/gallery/yLcZ3 (Needs updating)

Link to comment
Share on other sites

Link to post
Share on other sites

12 hours ago, TheAgnda said:

Is the recording level turned up?

Control Panel > Hardware and Sound > Sound > Recording > Properties > Levels
image.png

Yes... I'm running on windows 8.1 tho... Don't know if that has anything to do with this

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, Bennie Hing said:

Yes... I'm running on windows 8.1 tho... Don't know if that has anything to do with this

Do you have another PC or know someone else with another PC that you could plug the mic into to rule out a defective mic? Trying a different cable should also be something to consider.

Additionally, you could try enabling "USB Legacy Support" in your BIOS.

Main PC: Corsair 900D | Designare TRX40 | AMD 3960X | RTX 3090, GTX 1050 TI | Trident Z (4x16GB) | 1TB 980 Pro, 2TB Sabrent Rocket 4+, 2TB 980 Pro, 1TB Sabrent Rocket | HX1200i

Media / Render PC: Corsair 900D (shared) | ASRock X399M | 2970WX | GTX 1660 TI | Trident Z (2x16GB) | 2TB Samsung 970 Evo | HX850

Capture PC: CR1080 | ASRock X399 | 2950X | RTX 2080 TI , GTX 1080 | Trident Z (4x16GB) | 2TB 970 Evo Plus, 1TB 970 Evo Plus | Dual HDMI 4K Plus LT, 2xElgato 4K 60 Pro, HX750
Full Room Watercooling: EK X3 400 | 2xKoolance PMP-500 | 4xEK SE560 | 16x Phanteks PH-F140MP  | EVGA 450 B3

Peripherals: 2xLogitech G502 Wireless | System76 Launch (Box Royals) | Xbox Elite Controller Series 2 | Logitech MX Master 3 | Logitech MX Keys

Displays: Asus XG35VQ | 2xLG 24UD58-B | LG 65UH6030 | Asus VH242H | BenQ GW2480 | HP 22CWA | Kenowa CNC-1080P | Asus VC39H

Audio: RME Fireface UFX+, Scarlett 18i20, RME HDSPe RayDAT, RME HDSPe MADI FX, RME ADI-648, RME ADI-192 DD | 2xYamaha HS5 & Yamaha HS8s | Sennheiser IE 500 Pro, Ultimate Ears RR CIEMs

Full setup - PC Part Picker / Pics: https://pcpartpicker.com/b/ZrWD4D | https://imgur.com/gallery/ZinwYhttps://imgur.com/gallery/yLcZ3 (Needs updating)

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, TheAgnda said:

Do you have another PC or know someone else with another PC that you could plug the mic into to rule out a defective mic? Trying a different cable should also be something to consider.

Additionally, you could try enabling "USB Legacy Support" in your BIOS.

I troubleshoot the mic and it says that device is working... I can try using another cable but how to enable usb legacy support and what does it do?... Sorry I'm a noob at all this?

Link to comment
Share on other sites

Link to post
Share on other sites

20 minutes ago, Bennie Hing said:

I troubleshoot the mic and it says that device is working... I can try using another cable but how to enable usb legacy support and what does it do?... Sorry I'm a noob at all this?

I understand that it may seem odd but testing with another computer is a sure way to diagnose if the problem is the mic / cable or your PC.

Enabling USB legacy support varies depending on your motherboard but has been known to fix issues like this, kinda just does what the name implies, raises compatibility for older USB devices.

Main PC: Corsair 900D | Designare TRX40 | AMD 3960X | RTX 3090, GTX 1050 TI | Trident Z (4x16GB) | 1TB 980 Pro, 2TB Sabrent Rocket 4+, 2TB 980 Pro, 1TB Sabrent Rocket | HX1200i

Media / Render PC: Corsair 900D (shared) | ASRock X399M | 2970WX | GTX 1660 TI | Trident Z (2x16GB) | 2TB Samsung 970 Evo | HX850

Capture PC: CR1080 | ASRock X399 | 2950X | RTX 2080 TI , GTX 1080 | Trident Z (4x16GB) | 2TB 970 Evo Plus, 1TB 970 Evo Plus | Dual HDMI 4K Plus LT, 2xElgato 4K 60 Pro, HX750
Full Room Watercooling: EK X3 400 | 2xKoolance PMP-500 | 4xEK SE560 | 16x Phanteks PH-F140MP  | EVGA 450 B3

Peripherals: 2xLogitech G502 Wireless | System76 Launch (Box Royals) | Xbox Elite Controller Series 2 | Logitech MX Master 3 | Logitech MX Keys

Displays: Asus XG35VQ | 2xLG 24UD58-B | LG 65UH6030 | Asus VH242H | BenQ GW2480 | HP 22CWA | Kenowa CNC-1080P | Asus VC39H

Audio: RME Fireface UFX+, Scarlett 18i20, RME HDSPe RayDAT, RME HDSPe MADI FX, RME ADI-648, RME ADI-192 DD | 2xYamaha HS5 & Yamaha HS8s | Sennheiser IE 500 Pro, Ultimate Ears RR CIEMs

Full setup - PC Part Picker / Pics: https://pcpartpicker.com/b/ZrWD4D | https://imgur.com/gallery/ZinwYhttps://imgur.com/gallery/yLcZ3 (Needs updating)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×