Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Witcher 3 Hairworks

WeedIsMySin
 Share

Go to solution Solved by Paul Rudd,
2 hours ago, WeedIsMySin said:

The response time(6ms) of your monitor could be the culprit. However, you can try playing in 1080p with all settings the same and see if the freezing you speak of still exists.

 

Hairworks at 1440p in TW3 is pretty taxing, 15-20 fps or so. In 1080p, it's a little less than that. If the pausing disappears in 1080p(make sure you play a good 15-30 minutes), then all you'd need to do is go back into 1440p and lower a couple other individual graphic settings to make up for that 15-20 fps HairWorks will be pushing. I recommend setting Foliage Visibility Range to a maximum of High instead of Ultra. This alone will give you around 11 fps. Medium will give you another 4 fps but imo High looks better than Medium when viewing the entire world from great distances. The difference between Ultra and High is hardly noticeable but from Ultra to Medium, it is. At great distances that is.

 

Let me know how all this goes. If the freezing still exists in 1080p, we can move on to other steps to fixing this issue if lowering the Foliage Visibility Range doesn't work either.

So when i max the wither 3 out at 1440p, with hairworks on. It runs at about 50-60fps. However, when i have hairworks on ( I dont have Hairworks AA on 8 or anything just the reccomended for the ultra preset) The game sometimes stutters, It's not like i get 20fps or something but rather the screen just freezes for about half a second, But the lowest its dropped to on my fps counter is 49. How is that possible?

 

When i turn hairworks off i dont have this problem, but i would like to play with hairworks on. So is there a fix for this?

 

SPECS: i7-8700K 1070TI 16GB DDR4

Link to comment
Share on other sites

Link to post
Share on other sites

As far as I know, hairworks is an abandoned thing. But anyways, try tuning it down till you find a setting that works for you.

As for the FPS, if something render 60 frame in 1/2 second, then stops for 1/2 second, it's still 60FPS, just not continuous. That's why frame time(how long it takes to render one frame) is also important, but most games don't show it.

Link to comment
Share on other sites

Link to post
Share on other sites

15 hours ago, WeedIsMySin said:

So when i max the wither 3 out at 1440p, with hairworks on. It runs at about 50-60fps. However, when i have hairworks on ( I dont have Hairworks AA on 8 or anything just the reccomended for the ultra preset) The game sometimes stutters, It's not like i get 20fps or something but rather the screen just freezes for about half a second, But the lowest its dropped to on my fps counter is 49. How is that possible?

 

When i turn hairworks off i dont have this problem, but i would like to play with hairworks on. So is there a fix for this?

 

SPECS: i7-8700K 1070TI 16GB DDR4

Because FPS is not a good way to look at performance, you need to check frame times. 

You can render 48 frames in 0.5s and 1 frame in the other 0.5s which will definitely stutter. 

But you still rendered 49 frames in one second so the counter will report 49FPS.

 

Anyway, HairWorks is not worth it above 1080p in W3. I don't like how Geralds hair looks with it enabled and there is no time to gush about wolves fur during combat. 

 

Furthermore, HairWorks at 1440p in W3 made my 1080ti cry in the corner, you have a 1070ti.

Link to comment
Share on other sites

Link to post
Share on other sites

Don't bother with hiarworks, useless feature that tanks frame rate and adds nothing but shite hair physics. Keep it off, ultra everything else and enjoy glorious visuals with high frame rate.

 Motherboard  ROG Strix B350-F Gaming | CPU Ryzen 5 1600 | GPU Sapphire Radeon RX 480 Nitro+ OC  | RAM Corsair Vengeance DDR4 3000MHz 2x8Gb | OS Drive  Crucial MX300 525Gb M.2 | WiFi Card  ASUS PCE-AC68 | Case Switch 810 Gunmetal Grey SE | Storage WD 1.5tb, SanDisk Ultra 3D 500Gb, Samsung 840 EVO 120Gb | NAS Solution Synology 413j 8TB (6TB with 2TB redundancy using Synology Hybrid RAID) | Keyboard SteelSeries APEX | Mouse Razer Naga MMO Edition Green | Fan Controller Sentry LXE | Screens Sony 43" TV | Sound Logitech 5.1 X530

Link to comment
Share on other sites

Link to post
Share on other sites

If your FPS is over 60 most of the time, enable Vsync + frame cap.  

| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to comment
Share on other sites

Link to post
Share on other sites

On 10/22/2018 at 10:15 AM, WeedIsMySin said:

So is there a fix for this?

What monitor are you using? Brand and model number.

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, WeedIsMySin said:

The response time(6ms) of your monitor could be the culprit. However, you can try playing in 1080p with all settings the same and see if the freezing you speak of still exists.

 

Hairworks at 1440p in TW3 is pretty taxing, 15-20 fps or so. In 1080p, it's a little less than that. If the pausing disappears in 1080p(make sure you play a good 15-30 minutes), then all you'd need to do is go back into 1440p and lower a couple other individual graphic settings to make up for that 15-20 fps HairWorks will be pushing. I recommend setting Foliage Visibility Range to a maximum of High instead of Ultra. This alone will give you around 11 fps. Medium will give you another 4 fps but imo High looks better than Medium when viewing the entire world from great distances. The difference between Ultra and High is hardly noticeable but from Ultra to Medium, it is. At great distances that is.

 

Let me know how all this goes. If the freezing still exists in 1080p, we can move on to other steps to fixing this issue if lowering the Foliage Visibility Range doesn't work either.

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, A Random Dude said:

The response time(6ms) of your monitor could be the culprit. However, you can try playing in 1080p with all settings the same and see if the freezing you speak of still exists.

 

Hairworks at 1440p in TW3 is pretty taxing, 15-20 fps or so. In 1080p, it's a little less than that. If the pausing disappears in 1080p(make sure you play a good 15-30 minutes), then all you'd need to do is go back into 1440p and lower a couple other individual graphic settings to make up for that 15-20 fps HairWorks will be pushing. I recommend setting Foliage Visibility Range to a maximum of High instead of Ultra. This alone will give you around 11 fps. Medium will give you another 4 fps but imo High looks better than Medium when viewing the entire world from great distances. The difference between Ultra and High is hardly noticeable but from Ultra to Medium, it is. At great distances that is.

 

Let me know how all this goes. If the freezing still exists in 1080p, we can move on to other steps to fixing this issue if lowering the Foliage Visibility Range doesn't work either.

I´ll try that, thanks

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×