Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Dell XPS15 9560 battery 'deactivated'?

SilentBob
 Share

During a recent accident with my Dell XPS15 9560, one of the battery pins on the main board snapped off (its a 12pin connector from the battery). After much effort I managed to get a makeshift pin reattached (looks a bit hacky but hey :))

 

In windows (and Bios) the battery level of 80% is shown however it also complains the battery must be replaced and does not charge..The laptop does not power on without the AC adaptor (and dies if i remove it)

 

My suspicion is that the battery is actually OK, i cant imagine why the battery would actually have a problem.. Further to this i suspect the laptop itself has disabled the battery (due to the missing pin it probably panicked and told the battery to shut itself off).. I ran the laptop for a couple of weeks in this state (missing pin but battery connected)

 

Anyways, is such a scenario possible (battery ok but disabled)? If so is there any way to reactive the battery? Unfortunately damage is not covered by the warranty meaning i would need to probably buy a new battery, but ideally would like to confirm this before i do.

 

Thanks for any ideas/thoughts on this.

 

Merely for reference i found a post with photos showing the connectors on the main board and the battery:

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Batteries like this that have many pins on then are not smart batteries, they have little to no circuitry in them. The connector you see is a type of balance charger and it needs all pins for it to work. Otherwise the charger(the device in the laptop, not the AC adaptor) thinks one of the cells is dead. If you get a new battery connector it could work. 

My Folding Stats - Join the fight against COVID-19 with FOLDING! - If someone has helped you out on the forum don't forget to give them a reaction to say thank you!

 

The only true wisdom is in knowing you know nothing. - Socrates
 

Please put as much effort into your question as you expect me to put into answering it. 

 

  • CPU
    Ryzen 7 1700 3GHz 8-Core Processor @ 4Ghz
  • Motherboard
    GA-AX370-GAMING 5
  • RAM
    DOMINATOR Platinum 16GB (2 x 8GB) @ 3400mhz
  • GPU
    Aorus GTX 1080 Waterforce
  • Case
    Cooler Master - MasterCase H500P
  • Storage
    Western Digital Black 250GB, Seagate BarraCuda 1TB x2
  • PSU
    EVGA Supernova 1000w 
  • Display(s)
    BenQ - XL2430(144hz), Dell 24" portrait
  • Cooling
    MasterLiquid Lite 240
Link to comment
Share on other sites

Link to post
Share on other sites

merely an update.. In the end I replaced the battery and the problem is resolved. However I am still not convinced that the old battery is defective, but rather software disabled... 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×