Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[HELP] New BenQ XL2546 Dead Pixel (Purchased 3 Days Ago)

ajgamer1
 Share

Hello, I have purchased BenQ XL2546 from Amazon 3 days ago and I did some Pixel Tests. I found a Dead Pixel on the Monitor.

 

Please help me with the troubleshooting, fixed and any other tests which are to be done to check if something else is wrong with the monitor or not?

 

I am attaching the Photo below:

 

Screenshot_154.png.df5f21f1cb13ec9aebd2674e7aa2cf41.png

 

Thanks.

There are no secrets to success. It is the result of preparation, hard work, and learning from failure.


Link to comment
Share on other sites

Link to post
Share on other sites

If it's dead it's dead. Nothing you can do but RMA it ASAP. 

Gaming HTPC:

R7 1700X - Scythe Big Shuriken 3 - Asus ROG B350-i - Asus GTX 1080 Strix - 16gb G.Skill Ripjaws V 3333mhz - Silverstone SX500-LG - 500gb 960 EVO - Fractal Design Node 202 - Samsung 60KS7090 - Logitech G502 - Thrustmaster T500RS - Noblechairs Icon


Desktop PC:
R9 3900X - H100i GTX - Asus Prime X570 Pro - EVGA RTX2060KO - 32gb LPX 3200mhz - EVGA 750G2 - 250gb 970 Evo - 6TB WD My Book Duo (Reds) - Inwin 103 White - Dell U3415W - Qpad MK-85 Brown - Logitech MX518 Legendary - Blue Yeti Platinum - Noblechairs Icon 


Boss-NAS [Build Log]:
R5 2400G - Noctua NH-D14 - Asus Prime X370-Pro - 16gb G.Skill Aegis 3000mhz - Seasonic Focus Platinum 550W - Fractal Design R5 - 
250gb 970 Evo (OS) - 2x500gb 860 Evo (Raid0) - 6x4TB WD Red (RaidZ2)

 

Audio Gear:

Hifiman HE-400i - Kennerton Magister - Beyerdynamic DT880 250Ohm - AKG K7XX - Fostex TH-X00 - O2 Amp/DAC Combo - 
Klipsch RP280F - Klipsch RP160M - Klipsch RP440C - Yamaha RX-V479

 

Reviews and Stuff:

GTX 780 DCU2 // 8600GTS // Hifiman HE-400i // Kennerton Magister
Folding all the Proteins! // Boincerino

Useful Links:
Do you need an AMP/DAC? // Recommended Audio Gear // PSU Tier List 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, FloRolf said:

If it's dead it's dead. Nothing you can do but RMA it ASAP. 

Well, I am not knowledgeable in this. But I'm not sure if it's a stuck pixel or a dead pixel.

 

It's Green in Color on Black Background, I can see on every color except for the Green Background.

There are no secrets to success. It is the result of preparation, hard work, and learning from failure.


Link to comment
Share on other sites

Link to post
Share on other sites

honestly not worth having issues over. if there is a problem with the pixel its somewhat likely that it will become a problem again. so just return it

CPU AMD 5800x_____Asus Crosshair VIII_____Asus Strix LC 360_____RAM Corsair Dominator Pro 2x8Gb 3600mhz_____ASUS RTX 3080 Strix

PSU Corsair HX1000w_____CASE Lian Li 011 Dynamic (original choice right? w/9 UNI Fans)_____Keyboard Razer BlackWidow Chroma_____Mouse Razer Deathadder Chroma_____Headphones Bose QC25_____Monitor (1) Acer Predator XB1 144hz G-Sync  (2) Benq 144hz G-Sync

Microphone Blue Yeti Black

Razer Blade 14

Also an XBOX one s.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, MrFriendism said:

Well, I am not knowledgeable in this. But I'm not sure if it's a stuck pixel or a dead pixel.

 

It's Green in Color on Black Background, I can see on every color except for the Green Background.

If it doesn't dissappear after turning the display on/off and/or using a different source then rma it. Amazon has pretty dope support so it won't be a problem  at all. 

Gaming HTPC:

R7 1700X - Scythe Big Shuriken 3 - Asus ROG B350-i - Asus GTX 1080 Strix - 16gb G.Skill Ripjaws V 3333mhz - Silverstone SX500-LG - 500gb 960 EVO - Fractal Design Node 202 - Samsung 60KS7090 - Logitech G502 - Thrustmaster T500RS - Noblechairs Icon


Desktop PC:
R9 3900X - H100i GTX - Asus Prime X570 Pro - EVGA RTX2060KO - 32gb LPX 3200mhz - EVGA 750G2 - 250gb 970 Evo - 6TB WD My Book Duo (Reds) - Inwin 103 White - Dell U3415W - Qpad MK-85 Brown - Logitech MX518 Legendary - Blue Yeti Platinum - Noblechairs Icon 


Boss-NAS [Build Log]:
R5 2400G - Noctua NH-D14 - Asus Prime X370-Pro - 16gb G.Skill Aegis 3000mhz - Seasonic Focus Platinum 550W - Fractal Design R5 - 
250gb 970 Evo (OS) - 2x500gb 860 Evo (Raid0) - 6x4TB WD Red (RaidZ2)

 

Audio Gear:

Hifiman HE-400i - Kennerton Magister - Beyerdynamic DT880 250Ohm - AKG K7XX - Fostex TH-X00 - O2 Amp/DAC Combo - 
Klipsch RP280F - Klipsch RP160M - Klipsch RP440C - Yamaha RX-V479

 

Reviews and Stuff:

GTX 780 DCU2 // 8600GTS // Hifiman HE-400i // Kennerton Magister
Folding all the Proteins! // Boincerino

Useful Links:
Do you need an AMP/DAC? // Recommended Audio Gear // PSU Tier List 

Link to comment
Share on other sites

Link to post
Share on other sites

6 minutes ago, MrFriendism said:

Well, I am not knowledgeable in this. But I'm not sure if it's a stuck pixel or a dead pixel.

 

It's Green in Color on Black Background, I can see on every color except for the Green Background.

I have a dead pixel that is invisible on white backgrounds and green on everything else. I tried methods that fix stuck pixels and this one is definitely dead.

So it is possible to have a dead pixel like this.

PC: CPU: Intel i7-4790 MB: Gigabyte B85N RAM: Adata 4GB + Kingston 8GB SSD: Samsung 850 EVO 500GB GPU: XFX GTR RX 480 8GB Case: Advantech IPC-510 PSU: Corsair RM1000i KB: Drevo Gramr modded to ortholinear with Cherry MX Blues Mouse: Logitech G305 Mousepad: LTT Deskpad Headphones: AKG K240 Sextett
Phone: Samsung Galaxy S7
Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, DJ46 said:

I have a dead pixel that is invisible on white backgrounds and green on everything else. I tried methods that fix stuck pixels and this one is definitely dead.

So it is possible to have a dead pixel like this.

What kind of methods did you try?

 

Thanks.

There are no secrets to success. It is the result of preparation, hard work, and learning from failure.


Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, MrFriendism said:

What kind of methods did you try?

 

Thanks.

I believe Linus has a video on stuck and dead pixels. You can play a video that goes through the different colour on that part of the screen, tap it with an eraser and things like that. The video goes into more detail and associated risks.

PC: CPU: Intel i7-4790 MB: Gigabyte B85N RAM: Adata 4GB + Kingston 8GB SSD: Samsung 850 EVO 500GB GPU: XFX GTR RX 480 8GB Case: Advantech IPC-510 PSU: Corsair RM1000i KB: Drevo Gramr modded to ortholinear with Cherry MX Blues Mouse: Logitech G305 Mousepad: LTT Deskpad Headphones: AKG K240 Sextett
Phone: Samsung Galaxy S7
Link to comment
Share on other sites

Link to post
Share on other sites

If you have any sort of out of box issues, return it immediately. New and working is better than not new and fixed. My monitor is an acer and I had a stuck pixel for a day and it fixed itself, but it is the second one I’ve had because the first had a dead pixel.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×