Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Headset doesnt stay as the default sound device

AlarmGoesDIng
 Share

Go to solution Solved by ChrisRK,

I have experienced similar issues with displays that has an audio output and they "reconnect" when Windows starts up. Disabling the audio devices for the screen solved the issue for me.

 

If you got the latest Windows feature update you have to go to Settings > System > Sound, and on the right side open the Sound Control Panel and form there disable the unwanted audio devices.

 

If you want to do it via a batch file on startup, you can use NirCmd and run it with the arguments <setdefaultsounddevice "name of device">. You will have to rename your default playback device to something other than "Speakers" as NirCmd goes by playback device name.

Since yesterday, Ive been having a problem where when I start my PC, my headphones don't work when they're plugged in. I managed to find the reason; I have to open my audio devices in control panel and then make my headphones the default device. The only problem is that when I shut down my computer they are removed from being my default device, and my monitor speakers are the new default.

 

Is there any way to keep them as the default device? Or is it possible for me to write a script that does that automatically?

 

I have an Acer XF240h monitor if that's the problem.

 

EDIT: Thanks for helping me solve the problem. My monitor was sort of refusing to being rejected as a sound device but eventually it worked.

Link to comment
Share on other sites

Link to post
Share on other sites

I have experienced similar issues with displays that has an audio output and they "reconnect" when Windows starts up. Disabling the audio devices for the screen solved the issue for me.

 

If you got the latest Windows feature update you have to go to Settings > System > Sound, and on the right side open the Sound Control Panel and form there disable the unwanted audio devices.

 

If you want to do it via a batch file on startup, you can use NirCmd and run it with the arguments <setdefaultsounddevice "name of device">. You will have to rename your default playback device to something other than "Speakers" as NirCmd goes by playback device name.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×