Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

840M core clock dropping and makes fps drop

Hi, so I have a ASUS X550LN laptop with 840M. And a random problem appeared as you can say from the title.

Things I tried :

  • Playing around with power options in Windows settings and NVIDIA CP,

  • Reinstalling my GPU drivers

  • Running AIDA64 to check if there's no thermal throttle just to be sure, and there wasn't any.

Temperatures are good, about 60-70 on GPU and about 70-75 on CPU. I think the problem might be because it's hitting the power limit but I don't know what to do about it, one guy suggested limit fps but I already get about only 30-40fps on most games and I can't undervolt the GPU either, it's locked. I tried undervolting the CPU (I just thought maybe that would help), and I did about -0.060V and the result is still the same. So do you have any suggestions?

 

Might that be because of my unoriginal charger?

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×