Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Small lag spikes after vacuuming near computer

Lartsa
 Share

So today we had our weekly cleaners vacuum my room. Nothing special. I was home and warned her not to vacuum too near my computer but still she got kinda near into it. After that i logged in to play some fortnite and noticed something was REALLY off. Rebooted made sure everythings properly. After that it seemed normal but i still seem to get those really fast lag spikes, never had them before though. Should i be worried and what should i do? I did a userbenchmark and everything else was in a good condition expect my GPU was 64 (has been that before). Everything in the benchmark seemed normal, but i still cant help the feeling that somethings off. Can this be a placebo or should i do something?

My system

CPU: i7-8700k

GPU: 1060 3b

MEMORY: 16gb 3200 ripjaws v

SSD: Samsung 860 500gb

PSU: 650w Corsair CX 

Operating system: Windows 10 64-bit

Link to comment
Share on other sites

Link to post
Share on other sites

4 minutes ago, jah118 said:

is your case grounded,(power supply)?

 

What does that actually mean. I mean i somehow know what grounding means but grounding a psu. Never heard of that before?

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, Lartsa said:

What does that actually mean. I mean i somehow know what grounding means but grounding a psu. Never heard of that before?

does cable for your Psu(power supply) have a 3 Pin on the Power Cord?

 

lrgscaleUS-KettleLead.gif

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×