Jump to content

PC Stuck on BIOS Boot Screen

I recently refurbished an old Alienware X51 R2.


I threw in a new 1 TB HDD with Windows 10 installed. Everything worked just fine. Brand new hard drive and OS.


Today I tried to boot up the PC and the computer gets stuck at the boot screen.

It shows the Alienware logo and the F2 and F12 options for Boot Setup/BIOS etc. and the loading bar but it never proceeds past this point. I cannot press F2 or F12.


It will not proceed past this point no matter resets, power cycles, removing all devices from the PC... but last night it restarted multiple times with zero issues.


I have had issues with this computer for years and years and years, but I was hoping this reset would fix that. Seems like it just brought about new issues.


NOTE: I need to update the BIOS. Could that be the cause? If so, how can I update it while it is stuck at this screen?




Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now