Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Games keep crashing/freezing

Hey forums,

 

I got a used GTX 680 that works fine, benchmarks fine on Heaven, and has the newest drivers installed. I even stress tested my CPU, and that is working fine too. However, all of my games work for a bit and then freeze, but completely are still running, with the exception of Fortnite which just crashes. I was just playing Dota 2 for about 50 minutes and it was working fine until I went back to the menu and it froze. I've tried older drivers, clean install of windows, etc. What else can I tr

Link to post
Share on other sites
24 minutes ago, Savant82 said:

Hey forums,

 

I got a used GTX 680 that works fine, benchmarks fine on Heaven, and has the newest drivers installed. I even stress tested my CPU, and that is working fine too. However, all of my games work for a bit and then freeze, but completely are still running, with the exception of Fortnite which just crashes. I was just playing Dota 2 for about 50 minutes and it was working fine until I went back to the menu and it froze. I've tried older drivers, clean install of windows, etc. What else can I tr

If it's blue screen of death, try using bluscreen viewer application and see what cause the blue screen,

 

you can try another hard drive / ssd too

CPU: Intel i7 6700K 4.5 ghz / CPU Cooler: Corsair H100i V2 / Board: Asus Z170-A / GPU: Asus Rog Strix GTX 1070 8GB / RAM: Corsair Vengeance LPX 16GB DDR4 3000 mhz / SSD: Samsung 850 Evo 500 GB / PSU: Corsair RMx 850w / Case: Fractal Design Define S / Keyboard: Corsair MX Silent / Mouse: Logitech G403 / Monitor: Dell 27" TN 1ms 1440p/144hz Gsync

Link to post
Share on other sites
1 minute ago, gbergeron said:

If it's blue screen of death, try using bluscreen viewer application and see what cause the blue screen,

 

you can try another hard drive / ssd too

No blue screen

Link to post
Share on other sites
11 minutes ago, Savant82 said:

No blue screen

is the cpu/gpu overclocked or all default

CPU: Intel i7 6700K 4.5 ghz / CPU Cooler: Corsair H100i V2 / Board: Asus Z170-A / GPU: Asus Rog Strix GTX 1070 8GB / RAM: Corsair Vengeance LPX 16GB DDR4 3000 mhz / SSD: Samsung 850 Evo 500 GB / PSU: Corsair RMx 850w / Case: Fractal Design Define S / Keyboard: Corsair MX Silent / Mouse: Logitech G403 / Monitor: Dell 27" TN 1ms 1440p/144hz Gsync

Link to post
Share on other sites
13 hours ago, gbergeron said:

is the cpu/gpu overclocked or all default

All default.

Link to post
Share on other sites
5 hours ago, Savant82 said:

All default.

Try a new hard drive or SSD with clean installation

 

If you still experience same thing, flash the bios,

 

If same thing... im running out of ideas

CPU: Intel i7 6700K 4.5 ghz / CPU Cooler: Corsair H100i V2 / Board: Asus Z170-A / GPU: Asus Rog Strix GTX 1070 8GB / RAM: Corsair Vengeance LPX 16GB DDR4 3000 mhz / SSD: Samsung 850 Evo 500 GB / PSU: Corsair RMx 850w / Case: Fractal Design Define S / Keyboard: Corsair MX Silent / Mouse: Logitech G403 / Monitor: Dell 27" TN 1ms 1440p/144hz Gsync

Link to post
Share on other sites

maybe at that point try to run a memtest86 for 24 hours see if you have any error codes

 

CPU: Intel i7 6700K 4.5 ghz / CPU Cooler: Corsair H100i V2 / Board: Asus Z170-A / GPU: Asus Rog Strix GTX 1070 8GB / RAM: Corsair Vengeance LPX 16GB DDR4 3000 mhz / SSD: Samsung 850 Evo 500 GB / PSU: Corsair RMx 850w / Case: Fractal Design Define S / Keyboard: Corsair MX Silent / Mouse: Logitech G403 / Monitor: Dell 27" TN 1ms 1440p/144hz Gsync

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×