Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Significant FPS drop

Go to solution Solved by BurblingBarbacoa,
3 hours ago, wojtepanik said:

-snip-

ok so after all that I realise that multicore rendering disabled itself. Fucking cs go. Fixed. Cheers anyway. 

Hey forum

 

In the last few days CS:GO has been running at around 100-140, dropping as low as 60 from time to time. This pretty much makes the game unplayable, especially on a 144hz monitor. I've tried verifying the game files, reinstalling, I've checked that my cpu isn't throttling or anything, I've made sure nothing is eating up my CPU or memory. I've also made sure that I have all the standard launch options for CS to make the most of my pc. All I really know is that it's not a GPU issue. I usually run 4:3 stretched at low settings and when I put that to high and 1080p I had pretty much the same FPS. One thing I have noticed is that when I restart and change my resolution the game sits at pretty normal FPS (190-400) for a couple minutes but then slowly goes back down to 100ish. I thought this was a sign of the CPU getting hot and throttling but it doesn't seem to be getting hot and is hitting boost clocks fine. For reference I'm using a 380x and i5 6500. PLz halp.

I'm here to help people and have fun. Feel free to chat! 

 

 

i5 6500

Asus Z170-AR 

Saphhire Nitro 380X

 Hyper X Fury Black 16gb (2x8gb) 2133

 

Link to post
Share on other sites

drivers update + reinstall cs go,find a map benchmark in workshop and do it. check for drops there

Link to post
Share on other sites
6 minutes ago, wojtepanik said:

drivers update + reinstall cs go,find a map benchmark in workshop and do it. check for drops there

made sure all my drivers are up to date and even went back to previous ones. I have reinstalled cs. Nothing happened. I have a couple benchmark maps but what exactly would running them do?

I'm here to help people and have fun. Feel free to chat! 

 

 

i5 6500

Asus Z170-AR 

Saphhire Nitro 380X

 Hyper X Fury Black 16gb (2x8gb) 2133

 

Link to post
Share on other sites

it would help pin point the bottleneck that is causing drops, run benchmark with task manager or some hardware monitor and check when the frames are dropping and what is the usage of resources in that exact moment, maybe format system ? sometimes it's the fastest way of "repairing" cs go

 

Link to post
Share on other sites
3 hours ago, wojtepanik said:

it would help pin point the bottleneck that is causing drops, run benchmark with task manager or some hardware monitor and check when the frames are dropping and what is the usage of resources in that exact moment, maybe format system ? sometimes it's the fastest way of "repairing" cs go

 

Ok. Ran benchmarks. Sorry for the late reply. Ran the Crashz benchmark. I got around 100 avg popping up to 230ish when looking at skybox or ground and around 40 in a smoke. Heres the console message I received: # FPS Benchmark v1.01 - 01:42:765
==========================================================================
- Test Results Below:
 
Average framerate: 119.34
No one can buy!!
ERROR!: Can't create physics object for models/weapons/w_rif_ak47.mdl
ERROR!: Can't create physics object for models/weapons/w_rif_ak47.mdl
CSoundEmitterSystemBase::GetParametersForSound:  No such sound Error
CSoundEmitterSystemBase::GetParametersForSound:  No such sound Error
SignalXWriteOpportunity(3)

 

Ran at high settings 1080p and at my normal stretched resolution at low settings and nothing changed. So its not a GPU issue. I also ran with no launch options and with -high and -threads 4 and saw no difference. I also tried running with vibranceGUI on and off. Still no difference. The only thing I noticed was that my cpu bounced between 49-51 utilization when in cs go. If I use a cpu benchmark, render something or launch another game (I tried gta5 and CS:source, so its not a source engine problem, its a problem with csgo) the cpu utilization is fine with maxing out but for whatever reason whenever I open cs it just locks itself to 50%. 

I'm here to help people and have fun. Feel free to chat! 

 

 

i5 6500

Asus Z170-AR 

Saphhire Nitro 380X

 Hyper X Fury Black 16gb (2x8gb) 2133

 

Link to post
Share on other sites
3 hours ago, wojtepanik said:

-snip-

ok so after all that I realise that multicore rendering disabled itself. Fucking cs go. Fixed. Cheers anyway. 

I'm here to help people and have fun. Feel free to chat! 

 

 

i5 6500

Asus Z170-AR 

Saphhire Nitro 380X

 Hyper X Fury Black 16gb (2x8gb) 2133

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×