Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

So the problem started when something short circuted in my room and my pc shut off. i powered up my pc and no signal to my monitor eventhough gpu fan spins, i was like ok maybe it was a monitor issuse and it tried it with other monitors and even my TV nothing. I bough a new card, and i posted the bios got up and when it was booting the signal went away. I noticed that i get shocked everytime i touch my vga cable and or my pc case. I cant be my cpu or ram since it tested it with other ones. The only thing that can be wrong is my MOBO or PSU, or maybe its my windows? Please help im stuck on an amd apu with integrated graphics. Thanks!

Link to post
Share on other sites

Getting shocked everytime you touch the case sounds like a grounding issue. I would try another PSU first.

Crystal: CPU: i7 7700K | Motherboard: Asus ROG Strix Z270F | RAM: GSkill 16 GB@3200MHz | GPU: Nvidia GTX 1080 Ti FE | Case: Corsair Crystal 570X (black) | Storage: 250 GB Crucial BX100 SSD + 2 TB Seagate HDD + 1TB WD Green + 3TB WD Red | PSU: EVGA Supernova G2 1000W | Monitor: Asus VG248QE 24"

Laptop: Dell XPS 13 9360 | CPU: i5 7200U | RAM: 8 GB

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×