Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

My razer mamba is causing me problems with tracking...

Splat_Node
 Share

Ok well my razer mouse seems to be having issues with smooth movement and when trying to draw a spiral it does >>this<< and have no idea what to do, 

 

I'm running on

Windows 10 x64

GTX 970

I74790k

my PC also always gives me issues whenever i'm doing things and I find it hard to keep everything clean and make sure there are not any programs that I do not want.

and not sure what to do about fixing this issue. 

 

PLEASE could someone help me as i play a lot of fps hitscan games and i cant play them properly at the moment. 

 

Also should this happen, as my keyboard is showing up in the mouse drivers on windows >>> My Ornata Chroma Keyboard 

Link to comment
Share on other sites

Link to post
Share on other sites

2 minutes ago, Splat_Node said:

Ok well my razer mouse seems to be having issues with smooth movement and when trying to draw a spiral it does >>this<< and have no idea what to do, 

Welcome to the LTT forum! :) does it do this when you use it wired or only on wireless? what surface is the mouse on? There might be another device that disrupts the wireless signal. other than that there might be some dirt in the sensor, try blowing into it, fixed my naga epic chroma a long time ago ;) 

 

4 minutes ago, Splat_Node said:

my PC also always gives me issues whenever i'm doing things and I find it hard to keep everything clean and make sure there are not any programs that I do not want.

Im not entirely sure what you mean by this. But you should always read the text when installing a new app, they often install another program if you dont remove the checkmark from them. if you mean viruses, what antivirus you have? I recommend Avast/AVG, and malwarebytes.

 

Winning an argument with a woman step by step

step one - talk to her

step two - fight with her for 2 hours even if you are really right

step three - admit that she is right for the sake of your safety

step four - realize that you have accomplished nothing and she still thinks you were wrong and now she thinks you are even more stupid

GTX1080ti, I5-4690k, ASUS Z97 PRO-GAMER, 8GB DDR3 1600mhz, Hyper 212 EVO, Tt view 31 RGB.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, henkka_scorpio said:

Welcome to the LTT forum! :) does it do this when you use it wired or only on wireless? what surface is the mouse on? There might be another device that disrupts the wireless signal. other than that there might be some dirt in the sensor, try blowing into it, fixed my naga epic chroma a long time ago ;) 

 

Im not entirely sure what you mean by this. But you should always read the text when installing a new app, they often install another program if you dont remove the checkmark from them. if you mean viruses, what antivirus you have? I recommend Avast/AVG, and malwarebytes.

I just tried blowing on it and it does not work.I also have the Tournament edition so wired. 

I also have avg, cc cleaner and defraggler installled and run them at least 3 times a month, cc cleaner a lot more tho. At least once a day. 

i did find this post tho 

 but i only have a Mamba mouse so would not help me to install death adder drivers 

Link to comment
Share on other sites

Link to post
Share on other sites

15 minutes ago, Splat_Node said:

 but i only have a Mamba mouse so would not help me to install death adder drivers 

I've heard of people with razer driver problems before, you could try uninstalling and reinstalling the razer synapse software, or just using the mouse without it if that is the problem. and you can try plugging  it into another USB port, in case it were faulty.

 

Winning an argument with a woman step by step

step one - talk to her

step two - fight with her for 2 hours even if you are really right

step three - admit that she is right for the sake of your safety

step four - realize that you have accomplished nothing and she still thinks you were wrong and now she thinks you are even more stupid

GTX1080ti, I5-4690k, ASUS Z97 PRO-GAMER, 8GB DDR3 1600mhz, Hyper 212 EVO, Tt view 31 RGB.

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, henkka_scorpio said:

I've heard of people with razer driver problems before, you could try uninstalling and reinstalling the razer synapse software, or just using the mouse without it if that is the problem. and you can try plugging  it into another USB port, in case it were faulty.

ok ill do that and see what happens

Link to comment
Share on other sites

Link to post
Share on other sites

well i think i fixed it... it was the mouse mat after managing to recalibrate it now mooves smoothly but i will keep you updated for later tonight to see what happens

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×