Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Loss of sound with 2 monitors when gaming

Hi,

 

This is more than the usual loss of sound issue from plugging in an additional monitor and I can't seem to find any help. 

 

I have a Sennheiser GSX 1000 external sound doohickey (love it BTW). Normally it functions well but there are two options for playing sound through them depending on the device selected, If I select the GSX 1000 main sound option in the Windows sound menu I get great sound, If i select Headset Earphone GSX 1000 communication I get terrible sound (I'm assuming that it just bypasses the external soundcard or something). Not an issue until today.

 

I plugged in an extra monitor for productivity, went to play a game and no sound. I played around with settings and the only way I can get it to play sound in game is by using the awful sound option. Not only is the sound bad but I can't use any of the options on my external sound card (7.1, sound stage etc). Fair enough, maybe unplugging the second monitor will help. Nope. Permanent. Nothing I can do seems to give me my decent sound options in games, works fine in Window but in games it defaults to only wanting to use the bad sound. 

 

PLEASE, any help would be appreciated. The main reason I have this GSX1000 is for better quality gaming sound. 

Link to post
Share on other sites

Have you tried the basics? Like reinstalling sound drivers, etc?

"May your frame rates be high and your temperatures low"

I misread titles/posts way too often--correct me if I don't.

 

Link to post
Share on other sites

The problem might be the common one.

 

Set the output to your soundcard instead HDMI.

9ab883b81f.png

Link to post
Share on other sites

No, sadly the GSX 1000 is a USB external and so doesn't go through the sound card AFAIK, either way this doesn't work. No sound comes out in game or in Windows this way. 

 

Sound drivers have been reinstalled. 

Link to post
Share on other sites
2 minutes ago, Blebekblebek said:

The problem might be the common one.

 

Set the output to your soundcard instead HDMI.

 

This @Zebedeeboing. If you want to ensure all your sound gets piped to one audio device, the most reasonable thing to do is simply disable all the other sound devices. 

 

Remember that every time you update your video card drivers you'll probably have to disable the video card audio devices again, it's super annoying (especially for NVidia drivers; they reinstall the audio drivers even when they are deselected in the installer.)

Link to post
Share on other sites
1 minute ago, Zebedeeboing said:

No, sadly the GSX 1000 is a USB external and so doesn't go through the sound card AFAIK, either way this doesn't work. No sound comes out in game or in Windows this way. 

 

Sound drivers have been reinstalled. 

It shouldn't matter if it's a USB sound device or not mate, it's still an audio device. The bus it's connected to has no impact on how Windows treats it. If you disable all outputs you don't want to use, there's only one sink for audio to be sent to.

Link to post
Share on other sites

Well either way, whether it can use the internal sound card or not it doesn't output sound at all when I set it as the default device. 

Link to post
Share on other sites
Just now, Zebedeeboing said:

No sorry, this doesn't work (see above) :( 

Take a screenshot of your sound options please, the same one @Blebekblebek posted above

Link to post
Share on other sites

I get all sound through Headset Earphone.

I get Windows only, no game sounds from Speakers (GSX 1000 main audio) - which is the good quality sound one. 

Nothing from Realtek 

Bose I get both

Link to post
Share on other sites
7 minutes ago, Zebedeeboing said:

There is also Rift audio below that

Disable all the audio devices you *don't* want to use, then restart any applications you want to hear audio from. Any applications that use ASIO or WASAPI usually don't have the ability to switch audio streams when devices change.

 

To disable devices, right click on them on that control panel applet and click disable. Don't disable the device entirely in device manager, as it'll turn off every output.

 

Edit: see screenshot for how it should look. Your problem is that you have multiple ACTIVE audio sinks. If you have only one active audio sink, your applications can only sink to one device.

 

audio.png.5fe91ff8a0fec55837961b781f7de525.png

Link to post
Share on other sites

I didn't say it was, but it is the better one. Not really the time or place for sniping about quality of gear mate. 

Link to post
Share on other sites

You also need to adjust which output your software/games is going to use, just because you set it by default (now) the software/games might be still using the older output set.

 

67e5781d11.png

Link to post
Share on other sites

The make it easier, just delete any outputs that you don't need, and reinstall it again after you fix the problem.

 

The settings are on individual software, I'm using windows 10, that just an example for Viber (video call software)

Link to post
Share on other sites

Gotta go out to take my missus out for 30th meal but wll try that when I get back. I've already tried something similar to no effect though :( 

Link to post
Share on other sites
3 minutes ago, Zebedeeboing said:

I didn't say it was, but it is the better one. Not really the time or place for sniping about quality of gear mate. 

Wasn't trying to, you just said it was better than onboard which I doubt. The onboard likely has a higher output performance for your headphones, since the GSX1000 barely puses 1vrms. So if this whole ordeal is to get the GSX1000 to work, just unplug it. And you can't "bypass the onboard (by which i'm assuming you mean passthrough)" via USB. So i'd say start by addressing how you phsyically connected everything.

 

By the way, just to negate some confusion. By monitor you mean panel right? Not a studio monitor IE speaker?

Link to post
Share on other sites

Apologies, it came across that way and unhelpful at the time. 

 

The GSX really is better than my onboard sound and the little tweaks really do make gaming/voice better and easier than alternatives. 

 

I have literally tried as much as I can think of. I have stripped out all drivers and reinstalled them. I tried to roll back my system to a restore point but sadly there is some BS about not being able to do it due to anti-virus that cannot be overcome no matter how much I stamp my feet and disable it. 

 

I really think that it has something to do with NVIDIA HDMI audio drivers as they were not in my audio tray before (I deleted them before the screen cap above) but again, I have tried removing them to no avail. I just cannot get sound to come back through my GSX, I've sent a support request through to Sennheiser but I seriously doubt that their tech support would be able to figure it out, even after a zillion 'please try XYZ' emails. 

 

 

Link to post
Share on other sites

OMFG. I am just the turdiest idiot in the world. I don't think you would believe me if I told you what was wrong so I will allow you to post your theories below and then click on the spoiler... 

 

Spoiler

Apparently I had muted PUBG in volume mixer. Sadly this muting of one game also carries across to ANY game launched so it didn't matter which game it was (hence why I thought it was not an individual game issue) and this muting also carries across after uninstalling all sound drivers and reinstalling hardware. Such a moron. Overcomplicating the issue due to previous issues with the GSX and it happening immediately after installing an extra monitor..... 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×