Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PSA: Synergy 2.0 is terrible!

On 12/27/2017 at 10:59 AM, Kryptyx said:

I discovered Synergy, a program by Symless, through one of the ad spots on the LTT videos. It worked great, exactly as advertised and well worth the purchase. However, they've recently released a 2.0 version which removes a lot of functionality and even becomes completely unusable when their "auto-config" service is down - which happens very often. I have reached out to their support forums and found many other users complaining about this newer version as well. To make it worse, there is a $49 upgrade fee to go from 1.0 Pro to 2.0 Pro. The 1.0 version allowed you to configure hotkeys, remap keybinds, setup dead zones, start and stop the service and so much more while the new 2.0 version has literally zero options. The only way to stop the 2.0 program is to go into Window services and stop it. On a Mac, you need to run a shell command as root. I wouldn't have a problem if this was labeled as beta or if the upgrade was free but that isn't the case. To make it worse, there are many times when the new version cannot connect to their "auto-config" service which makes the program completely useless.

I know LMG takes its advertisers serious and I hope this will draw a little attention and save people money/hassle involved with the newer version. Stay away from the 2.0 and stick with 1.8.

i actually got more mad about 2.0 when they gutted ALL the GUI source from the repo. i compile the project myself and follow the same attitude of i will just keep using the older version.

Link to post
Share on other sites
On 1/8/2018 at 8:45 PM, Kryptyx said:

This is exactly what I'm talking about. The auto-config service goes down randomly and just leaves the program completely useless... There are no configuration options. I don't know why LMG continues to push this...

@nicklmg

for money? 

well this is enlightening, I'll stay clear of this synergthing and to move a post to "ranting"!? man that's past rude, that's insulting

Link to post
Share on other sites
  • 2 weeks later...

I already requested a refund. The software is complete shit with major bugs & the UI is broken on some systems. Glad this thread was made since I don't support hackforums-grade software sold as a final product without notifying the userbase. Honestly, shame on you symless. Even though I paid 15 bucks - it all adds up.

 

Easier to buy trackpads & slap my dick on them a few times than push the only broken button on synergy 2 to try and connect systems.

blackshades on

 

 

Link to post
Share on other sites

I'm still trying to get ver. 1.8 to even work at all! I've tried to instal it 5 times now, and not once have I been able to get this thing to work. I one time I did manage to get my mouse to move to the second machine, it was soooo laggy and slow, it was virtually unusable... as a result, I have removed it from my system and gone back to MouseWithoutBorders from Microsoft Garage. It only works on windows machines, but damn! It is so easy to setup up and works like a damn doing all the things synergy offers...  Gonna try to get a refund now...

Link to post
Share on other sites
  • 3 weeks later...

I want to also add some little note about this. Around 2012 their company had a program where you could buy votes (10$ per vote) and vote up issues you deemed important.

 

I felt I want to support them and I felt I really want to get my bug fixed (a bug that only very few users would hit), so I bought around 10 votes or so and voted it up.

 

It was written that the voted issues would be worked on in order of votes, but no matter how many votes they would be worked on eventually. After some time my issue had about 11 votes. I don't remember the exact placing in the tops but I think it was in the top 10. Not that it would matter too much, I had patients. 

 

However, time went by and it was never worked on. At some point I even dug into the code myself and gathered helpful information to help fixing the issue. Still, no update other than my own comments.

 

To this day, nothing had been done on this at least 100$ worth issue. Nil. Nada. It was even closed in the mean time as "obsolete" and only reopened after I complained (with the claim that it was put on priority now). Of course nothing happened again.

Additionally, any information about the votes and how many it had is of course gone.

 

The issue can be found here: https://github.com/symless/synergy-core/issues/3259

 

I am okay with things taking their time, especially for small companies. But 6 years for an issue where you said "we work on it eventually" and for which people paid +100$ for to get it fixed.. I just feel really disappointed.

Link to post
Share on other sites
3 hours ago, Marenz said:

 Around 2012 their company had a program where you could buy votes (10$ per vote) and vote up issues you deemed important.

That sounds like a truly terrible system (and a money grab to be perfectly honest -- especially since it was never dealt with).

PSU Tier List | CoC

Gaming Build | FreeNAS Server

Spoiler

i5-4690k || Seidon 240m || GTX780 ACX || MSI Z97s SLI Plus || 8GB 2400mhz || 250GB 840 Evo || 1TB WD Blue || H440 (Black/Blue) || Windows 10 Pro || Dell P2414H & BenQ XL2411Z || Ducky Shine Mini || Logitech G502 Proteus Core

Spoiler

FreeNAS 9.3 - Stable || Xeon E3 1230v2 || Supermicro X9SCM-F || 32GB Crucial ECC DDR3 || 3x4TB WD Red (JBOD) || SYBA SI-PEX40064 sata controller || Corsair CX500m || NZXT Source 210.

Link to post
Share on other sites

To be fair, I think it was a nice idea.. if they would have actually done what they said.

Link to post
Share on other sites

@Marenz Thanks for your $100 donation! Back in 2012 when we were a donations-only open source project, this value of donation was incredibly vital. We really appreciate your contribution. We're of course happy to help you out with a refund, would you mind getting in touch with us directly? Thanks!

Link to post
Share on other sites
1 hour ago, Nick Bolton said:

Being a tiny software company, this means that we can't work on every single issue that's reported (even if they were reported years ago and even if people voted for them).

That's perfectly acceptable, however you really shouldn't give customers the ability to pay to have an issue fixed sooner if there is no physical way for it to be done (assuming it was actually that and not just misconstrued).

PSU Tier List | CoC

Gaming Build | FreeNAS Server

Spoiler

i5-4690k || Seidon 240m || GTX780 ACX || MSI Z97s SLI Plus || 8GB 2400mhz || 250GB 840 Evo || 1TB WD Blue || H440 (Black/Blue) || Windows 10 Pro || Dell P2414H & BenQ XL2411Z || Ducky Shine Mini || Logitech G502 Proteus Core

Spoiler

FreeNAS 9.3 - Stable || Xeon E3 1230v2 || Supermicro X9SCM-F || 32GB Crucial ECC DDR3 || 3x4TB WD Red (JBOD) || SYBA SI-PEX40064 sata controller || Corsair CX500m || NZXT Source 210.

Link to post
Share on other sites
On 3/1/2018 at 11:28 PM, djdwosk97 said:

you really shouldn't give customers the ability to pay to have an issue fixed sooner if there is no physical way for it to be done

@79wjd You're right, we removed the voting feature about 4 years ago, so it's surprising to see people still talking about it. We prioritize fixes depending on customer demand, and we're more than happy to refund people if they're not happy. Would you like to contact us directly so we can help you one-to-one?

Link to post
Share on other sites
On 3/1/2018 at 10:40 PM, Nick Bolton said:

Ah, you mean the legacy label? That's simply to show it was imported from the old issue tracker. I'll remove it, since it seems to be causing some confusion. It's still a valid issue, don't worry. Being a tiny software company, this means that we can't work on every single issue that's reported (even if they were reported years ago and even if people voted for them). Sorry for the delay in replying to that issue, I'll have a meeting with the development team on Monday to reassess the priority of the neo layout issue.

 

Also, thanks for your $100 donation back in 2012 when we were a donations-only open source project! That's very cool of you, and we really appreciate your contribution. It made a big difference to our tiny project! If you've decided that you now regret donating as your issue didn't get fixed, I'm more than happy to send your $100 back. How would you like me to do this? Do you have a PayPal address I can send it to?

No, I mean literally the obsolete label:

nbolton added the obsolete label on Dec 17, 2014

which was rectified after I responded to it ;)

 

I get why the priority of the issue is low. The amount of users hit by it is rather small, I wouldn't prioritise this myself as a developer. However, when you introduced the voting system I saw a way for me to push this issue up despite that by using money. The system suggested that the voted issues get some priority because of the votes. Sadly, that wasn't the case.

 

No, I don't want the money back. I don't regret donating. I am just disappointed how the reality differed a lot from my expectation and also how the system was removed without any way to look up in the old data what issues had which votes. That basically invalidated any votes people had before, votes people paid money for.

 

I understand you are a small company, I understand things take time. But the way this was handled was just unprofessional in my opinion. I mean, you even at some point closed the issue.. which indicates to me that you don't even have an internal database of issues that received votes. You can't uphold your statement "issues with votes will get worked on eventually" if you don't even know which issues received votes. 

Link to post
Share on other sites

Thank you Linus for getting us an ON/OFF button (hopefully soon). I'm so happy to support your channel because you really care about us. Greetings from Switzerland! @LinusTech

Link to post
Share on other sites
  • 4 weeks later...
On 1/8/2018 at 9:15 PM, Kryptyx said:

...
For anyone thinking I'm just one angry customer ranting, please feel free to sign up for an account on their forums at https://symless.com/forums/ and see for yourself. Notice how the "off-topic" section requires membership to view and is filled with customer complaints regarding 2.0. The owner moves the threads here so they are no longer public...

I created an account just to reply to this thread.

 

Nick is now purging any criticism of Synergy 2 from the forums. I've been trying to get it to work for months, and it finally (sort of) works as of 2.0.6.

 

Toady I got a notification that someone had responded to a synergy forum thread I was following, and when I went to view it, the thread was gone. The off-topic forum no longer exists, even to members. I'm thinking there's a bankruptcy filing in the offing, so I'm now requesting a refund. I'm done paying for the privilege of beta testing what is supposedly release-quality software.

 

For anyone who needs the cross-platform capabilities, another dissatisfied customer has taken matters into his own hands, and forked the abandoned public domain 1.8 version of Synergy. https://github.com/debauchee/barrier

 

 

 

Link to post
Share on other sites
  • 2 weeks later...

@CatPasswd Thanks for asking about our forums, and thanks for using Synergy. If a post is from a new user appears to be antisocial and unconstructive, our volunteer moderators do tend to remove it. Perhaps you'd like to contact us directly? That way we can provide one-to-one support. Thanks!

Link to post
Share on other sites

Does Synergy 2 still have the auto-config issue? That was the whole reason I was thinking of upgrading. On version 1.9 I still have to deal with the IP address changing regularly, so I've still got 2 mice and an external keyboard on my work desk, in addition to my laptop (the server). Simplifying this was the main point!

 

Also, with Synergy 1 I get crazy text swaps when I copy & paste from Mac to Windows (& vice versa), especially with punctuation. It adds in a string of alternate text so frequently that it's usually faster to just email the text to myself instead, again completely negating one of the functions of the program - the function that costs an extra $10 to have, no less! Is this still an issue with 2?

Link to post
Share on other sites
5 hours ago, Cthulhu Calamari said:

Does Synergy 2 still have the auto-config issue? That was the whole reason I was thinking of upgrading. On version 1.9 I still have to deal with the IP address changing regularly, so I've still got 2 mice and an external keyboard on my work desk, in addition to my laptop (the server). Simplifying this was the main point!

Why not just assign your devices static IPs?

PSU Tier List | CoC

Gaming Build | FreeNAS Server

Spoiler

i5-4690k || Seidon 240m || GTX780 ACX || MSI Z97s SLI Plus || 8GB 2400mhz || 250GB 840 Evo || 1TB WD Blue || H440 (Black/Blue) || Windows 10 Pro || Dell P2414H & BenQ XL2411Z || Ducky Shine Mini || Logitech G502 Proteus Core

Spoiler

FreeNAS 9.3 - Stable || Xeon E3 1230v2 || Supermicro X9SCM-F || 32GB Crucial ECC DDR3 || 3x4TB WD Red (JBOD) || SYBA SI-PEX40064 sata controller || Corsair CX500m || NZXT Source 210.

Link to post
Share on other sites

@Nick Bolton 

Still waiting for a proper reply from Synergy via their support page about the issues this program has, opened a ticket on the 8th and the only replies I have received seem like they are pretty generic 'please download this update' every time they release a new version, not any actual help for the issue. Asked for a refund now as this is just terrible support and I will just move to Mouse without Borders. Synergy barley works, mouse clicks aren't registering, moving the mouse to the client PC won't work, it gets stuck on the side flashing, and over the last few days when moving the mouse on the host PC, it will become supper slow and start glitching around the screen. 

Link to post
Share on other sites
  • 1 month later...

I purchased Synergy solely off the implied reputation of the product from LMG advertising it. I have to say that it is one of the jankiest pieces of software I've used in 30 years of computing.

 

Synergy 2 which I initially installed was buggy as all hell. So then I downgraded to Synergy 1 (thanks to LMG for at least sorting that out), and it at least stays up for a while. But getting it installed on Debian was a nightmare of broken dependencies.

 

What makes it even worse is that the support system is abysmal. There appears to be ZERO documentation, even for version 1! You search the forums for resolutions and they helpfully link to a Knowledge Base. Great, except that to access it you need a password which you can only get by emailing their Support which then takes a few days to get back to you. WTF!?! Why are you increasing the burden on your support staff just so I can access the supposed "self-support" option?

 

I have a degree in computer science - if I can't make this crap work, I shudder to think how frustrating it is for less technical users.

Link to post
Share on other sites
  • 1 month later...

I am an owner of a small software company and an IT Consultant so I understand the perils of startup and growth...

 

I have checked out the forums and I see Nick has been pretty good at owning up to these bugs and mistakes which gives me hope for them! Nick, as soon as LMG starts advertising you guys again when the issues are fixed, I'll be one of the 1st to buy the Pro version. Please fix these and get back on LMG so I can be confident to purchase.

 

Best of luck and I look forward to the working product!

Link to post
Share on other sites
  • 3 weeks later...
On 7/16/2018 at 7:21 PM, servicefly said:

when the issues are fixed

Hey @servicefly, thanks for visiting our forums. We try our best to be as responsive and helpful as possible to Synergy customers. Would you mind contacting us directly so we can help one-to-one?

Link to post
Share on other sites
  • 2 weeks later...

Synergy 1 is much better but not without glaring problems (reconnect issues, keyboard disable till reboot on server, etc) but synergy 2 is one of the worst pieces of software I've experienced in a while.

 

Take everything good about synergy 1, break it, cut down features, and hold your hand out expecting cash.

 

Utter garbage.

 

On 8/1/2018 at 6:38 AM, Nick Bolton said:

Hey @servicefly, thanks for visiting our forums. I try my best to be as responsive and helpful as possible to Synergy customers. Could I ask, what bugs in particular are you waiting on to be fixed?

 

Have you used the software? None of us get paid to do your QA for you. 

 

Once you start handing me cash, I will, sure. But there are many evident issues if you use synergy 2 for more than 10 minutes. 

 

Link to post
Share on other sites

@Delvien Thank you for your candid feedback and thanks for testing Synergy 2 Beta, we really appreciate it. Remember, you can get a refund, even with the early access beta. We do appreciate that the beta version isn't for everyone, and we have identified some design flaws. We're re-designing Synergy 2 from the ground up so that it'll be way more configurable and much more reliable.

Link to post
Share on other sites

honestly i still use the free pre-commercial version from before they started making cash on it and it works perfectly for me.

"I know its stupidly overdone and unreasonably unneccesary but wouldnt it be awesome if ..."

 

CPU: Delidded i7 7700k (watercooled) Cooling: 3x 360 rads by Alphacool  MB: ASUS z270i  RAM: G.Skill Trident Z RGB 16GB  GPU: MSI GTX1080 Ti Aero @ 2 GHz (watercooled)  DISPLAY: LG 34UC88-B 21:9 1440p SSD(OS): Samsung 960 EVO 250GB SSD(Games): Corsair MP510 960GB SSD(Applikations): Samsung 850 EVO 500GB  HDD(Scratch): WD Blue 500GB HDD(Downloads): WD Blue 320GB HDD(Long-term): WD Green 2TB (external)   PSU: Corsair SF750 Case: Lian Li PC-O11 D Mouse: Logitech MX Master Keyboard: Logitech G513 Carbon

 

Link to post
Share on other sites
  • 4 weeks later...
On 8/13/2018 at 5:37 AM, cluelessgenius said:

honestly i still use the free pre-commercial version from before they started making cash on it and it works perfectly for me.

I had to switch to a hardware solution because it was so unstable. I did more troubleshooting with it than I should have to. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×