Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Is there a way I can make make it so I can hear my own voice through my headset without any delay?

DSprite
 Share

Years ago I had Turtle Beach X12s and now I have Sennheiser G4ME ZEROs. On the TB headset I could hear my own voice clearly and without any delay when I spoke through the mic. I have done it via the method in the playback/recording microphone options in Windows however there is a 2 second delay. 

 

 

Cheers.

Link to comment
Share on other sites

Link to post
Share on other sites

Steam voice test 

If you want to argue with me, and you probably will please PM me, no need to ruin threads becase you dont like how I am.

 

Ask me how I made 100k selling illegal narcotics!

Spoiler

and you think im joking, Did a lot of wrong to get my money right.

I look up to Larry Hoover.

Your homies loyal 'til the one time you tell 'em no

 

Link to comment
Share on other sites

Link to post
Share on other sites

I have the cloud core and I just went into playback devices, speakers, properties, levels and increased  Rear Black in. That worked for me dont know about you, gl though!

Link to comment
Share on other sites

Link to post
Share on other sites

If your mobo has Realtek drivers, Realtek HD audio manager has a microphone playback option. I find it very quiet, but it's better than a huge delay through windows.

Link to comment
Share on other sites

Link to post
Share on other sites

On 11/1/2017 at 8:12 PM, matt0725 said:

If your mobo has Realtek drivers, Realtek HD audio manager has a microphone playback option. I find it very quiet, but it's better than a huge delay through windows.

I did this, but I can hear a static noise through my headset in the background. Any fix?

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, DSprite said:

I did this, but I can hear a static noise through my headset in the background. Any fix?

I get that as well. I think it is because the feedback is so quiet( at least for me) I crank the volume and then just have static. I only have my headset on with friends while gaming so there's always audio louder than the static so i ignore it. There is a noise suppression option which cuts it down slightly, but it isn't perfect. That's all I've got

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×