Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Performance teknique ICBM Disco powers off

so two days ago I was jamming to my music on a Performance teknique ICBM Disco right and then the audio dies off and the thing no longer turns on, the back was hot, let it cool a day later then today (10/31/17) it wont power on anymore,

I tried google searching the Performance teknique ICBM Disco but no luck on manual or troubleshooting.

 

any ideas to what caused it, i have a feeling it was a heat issue but that always runs hot, or a fuse?

Link to comment
Share on other sites

Link to post
Share on other sites

i had a amp die similarly to that, too much heat can kill amps, what died could be a bunch of things, but probably a mosfet/transistor or a resistor if you are ok with opening it up normally its easy to see/smell what broke, follow the smell and look for fire damage like discoloring 

Link to comment
Share on other sites

Link to post
Share on other sites

  • 3 weeks later...
On 10/31/2017 at 8:39 PM, cj09beira said:

i had a amp die similarly to that, too much heat can kill amps, what died could be a bunch of things, but probably a mosfet/transistor or a resistor if you are ok with opening it up normally its easy to see/smell what broke, follow the smell and look for fire damage like discoloring 

I took it apart and saw some flux and underneath the board was a lot of discoloration, some of the PCB holding the transistor broke off out of nowhere. (sorry for the late reply!, been really busy with school lately)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×