Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows 10 only outputs stereo to AVR

FlyingTexan
 Share

I have the Intel Skull Canyon that is connected to my Marantz NR 1607 AVR via HDMI. The Marantz is connected to my Vizio 60" m60-c3 TV and a 3.1 setup surrounding it. 

 

I cannot for the life of me figure out how to get windows to output 3.1. I right click the speaker icon and go to speaker setup and select 3.1 from the options. Running the speaker test produces no results. If I allow windows to try and detect the issue, lol, it reverts it back to stereo.  My receiver info shows that the stream is coming in Stereo mode as well and it does show my 3.1 speaker setup as being detected. If I click on any videos it usually takes a second or two for the audio to start. Sometimes it ends up dropping here and there during the video. 

 

I've reformatted and installed windows 10 again today with all updates. I also installed all the latest drivers for the Skull Canyon. I've checked the Marantz and it shows that it has the latest firmware. The Marantz is selected as my default audio option, actually my only one, and I have no idea how to get my center channel and sub working again. 

Link to comment
Share on other sites

Link to post
Share on other sites

Right click the volume icon. Playback Devices. Click your device for output. Click configure. Set stereo options.Hit ok a bunch.

Lets play connect the dots!

::::::::::

::::::::::

::::::::::

Link to comment
Share on other sites

Link to post
Share on other sites

Has the AVR the right hdmi port selected ? The one the pc is conected too ?

Let's agree to disagree

Link to comment
Share on other sites

Link to post
Share on other sites

Ok, missed that section of the post. If this is traversing via HDMI, would you need to check your video card settings to see if that is where the audio handoff is happening?

Lets play connect the dots!

::::::::::

::::::::::

::::::::::

Link to comment
Share on other sites

Link to post
Share on other sites

Ok, i found another spot, Nvidia control panel, Display, Setup digital audio, and then go through it that way. Then adjust the hdmi audio out via the sound panel.

Lets play connect the dots!

::::::::::

::::::::::

::::::::::

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, AGrider said:

Ok, i found another spot, Nvidia control panel, Display, Setup digital audio, and then go through it that way. Then adjust the hdmi audio out via the sound panel.

My toughts also ...

It should be Nvidia High definition Audio since the pc is conected to the AVR trough the GPU

Let's agree to disagree

Link to comment
Share on other sites

Link to post
Share on other sites

Unless the tv is down mixing the audio signal to stereo via ARC. How is this cabled? GPU-TV-AVR? or direct GPU-AVR? 

Lets play connect the dots!

::::::::::

::::::::::

::::::::::

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, AGrider said:

Unless the tv is down mixing the audio signal to stereo via ARC. How is this cabled? GPU-TV-AVR? or direct GPU-AVR? 

Done correctly it should be GPU -> AVR splits sound to 3.1 speakers and video to tv 

Let's agree to disagree

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×