Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Can't switch my Intel HD to my Nvidia GPU on my MSI laptop

Hello guys, 

 

I need some help! I recently bought a new laptop from MSI (MSI GL62QF)

Specs:

- GeForce GTX 960M

- Intel Core i7 6700HQ 

- 8 GB Memory

- 1 TB HDD

 

But i have a problem. The laptop runs completely on my Intel HD 530 graphics and i can't change them to my Nvidia GTX960m GPU. 

If i want to play games they'll run on my iGPU and the performance of the laptop is shit. After a week searching on the internet i couldn't find anything that helped me a step further to succes.

In the Nvidia Control Panel 3D Settings i've put the graphics processor to: Powerful Nvidia Processor but it didn't help me any step. 

 

If there are people who can help me that would be great!

 

Thanks anyways,

Marwin

 

(Sorry for my bad English.)

Link to comment
Share on other sites

Link to post
Share on other sites

For how long are you having this issue? Ever since you had you laptop? Or did this start happening after you reinstalled it or something?

Anyway it sounds like a driver problem to me.. Is the Nvidia software installed?

 

Check if you can enable your GPU in the Bios and / or in the Nvidia software.

 

If that does not work there is something more experimental you could try.

Downloading a custom Nvidia driver. They make these for reasons like this exact issue. for laptops like my old Acer with a dedicated GT130m.

 

Anyway good luck man. If you provide us with more details and your results I would be glad to come with some other suggestions for you to try :) 

Link to comment
Share on other sites

Link to post
Share on other sites

29 minutes ago, jeff.proto-_- said:

Have you tried using the bios to switch the graphics settings?

The bios is so basic that there aren't any options to change the graphics settings.

There isn't a graphics setting.

Link to comment
Share on other sites

Link to post
Share on other sites

19 minutes ago, Ansuex said:

For how long are you having this issue? Ever since you had you laptop? Or did this start happening after you reinstalled it or something?

Anyway it sounds like a driver problem to me.. Is the Nvidia software installed?

 

Check if you can enable your GPU in the Bios and / or in the Nvidia software.

 

If that does not work there is something more experimental you could try.

Downloading a custom Nvidia driver. They make these for reasons like this exact issue. for laptops like my old Acer with a dedicated GT130m.

 

Anyway good luck man. If you provide us with more details and your results I would be glad to come with some other suggestions for you to try :) 

I have this issue since i bought the laptop. I sent it back to where i bought it but they couldn't find anything. I've searched many times on google for more information about the BIOS but with no results. It looks like there isn't any graphics settings in the BIOS to change anything. 

 

Maybe a custom NVIDIA driver could help? I'll take a look!

 

Thanks for your answer,

Marwin

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, jeff.proto-_- said:

Oh, have you tried enabling the GPU from the device manager?

 

The Intel HD 530 and the NVIDIA GTX 960M are both enabled.

Maybe that's the problem?

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, jeff.proto-_- said:

Disable the HD 530 and reboot

Will it give any problems to me, because the monitor adapter is running on the Intel HD 530.

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, jeff.proto-_- said:

Is there a switch on your laptop to switch graphics modes?

As far as i know it hasn't. 

Link to comment
Share on other sites

Link to post
Share on other sites

Go to the NVidia control panel and go to 3D settings. Click global setttings and change to the GTX 960m. 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, jeff.proto-_- said:

Go to the NVidia control panel and go to 3D settings. Click global setttings and change to the GTX 960m. 

That's one of the first things i did. It doesn't affect anything.

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, jeff.proto-_- said:

Oh, you may have a faulty laptop

Probably? There are many other people with the same problem. 

Do you think if i disable the Intel HD 530 in the device manager the problem is solved?

Link to comment
Share on other sites

Link to post
Share on other sites

That might help but i'm also a little afraid you will end up with a black screen.

If that happens you might have to boot in safe mode and enable the Intel HD530 again.

 

Also you could try and connect a monitor to your laptop and see if that forces your GTX960m to do something.

 

Hope it helps :)

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×