Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

I've been having trouble with Microsoft Office for Education.


I initially had Office 365 and no longer need it, because I can get Office for Education for free. I installed Office for Education while I had 365 installed and that seemed to cause confusion between the two programs. I tried uninstalling them from Programs and Features then tried just installing the EDU version. That didn't work because NO PROGRAMS showed up as shown in the video. There were Office files, but no programs. I even tried using the EasyFix utility to remove both the programs and that didn't seem to resolve the issue either.


If anyone has any idea as to what I can do to fix this, please respond, I have school work I need to do and don't want to do it all in school.





P.S. I describe the problem a bit in this video...


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now