Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

HDD not detected?

My bios sata info shows a western digital drive but windows won't show it under "my PC". Why?

Link to post
Share on other sites

What version of Windows are you using?

Could be because the Harddrive has no partition, it needs one before windows shows it.

 

Try searching for disk management, and see if you can see it in there.

Link to post
Share on other sites
5 minutes ago, zcnelson52 said:

My bios sata info shows a western digital drive but windows won't show it under "my PC". Why?

In search type Disk Management. You'll be able to do some voodoo to make it readable there if it's not already. I had to do that with a western digital cloud/mycloud/whatever since it apparently only worked with Macs out of the box.

 
Link to post
Share on other sites

I had a bios corruption twice on my old mobo, and so I went to the configurations in the bios and had to switch it back to register legacy drives. I don't know how I did it. lel

Link to post
Share on other sites

Mak sure that its formatted in disk management and that windows has the right drivers for it. 

Have you tried turning it off and on again?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Newegg

×