Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Please excuse my inexperience.

 

I just built a new system with an i7 7700k and an asus gtx 1080 strix. And after watching several benchmarks and reviews I was very hyped to play the witcher 3 on maxed settings at insane frame rates. A little background info that might help in diagnosis. I had windows 10 and several apps and games downloaded onto my ssd and hdd prior to switching hardware, so all i did when i built my new system was just booted with the preinstalled windows 10 pro on ssd, i dont know if this helps at all.

K now to the real problem so after running windows i downloaded the most recent chipset and Nvidia drivers then downloaded the witcher 3, set all settings to max disabled vsync and set frame limit to unlimited and began playing. And to my dismay I was only reaching 40fps at 1080p. Bare in mind this is stock 4.2GHz on 7700k. If someone could help me figure out why my computer is underperforming so badly would be much appreciated. 

 

Specs

I7 7700k stock

Asus z270g strix mobo

Asus gtx 1080 strix

Corsair lpx 16gb 3200

Corsair h100i v2

Evga supernova 850w p2

Link to post
Share on other sites
5 hours ago, Shimejii said:

How about not doing max settings.... a lot of the time added settings going to the max is what kills your performance lol... 

On geforce experience the max settings are the optimal ones and i looked up benchmarks for my exact config and they are getting a lot better results. With gtx 1080 with i7 7700k at 1080p should be getting around 100fps, not 40. 

Link to post
Share on other sites
5 hours ago, Ethocreeper said:

lol i can do much better than my 1070

lol ya if things were working correctly i would be doing much better with my 1080. 

Link to post
Share on other sites
47 minutes ago, Joshannex said:

On geforce experience the max settings are the optimal ones and i looked up benchmarks for my exact config and they are getting a lot better results. With gtx 1080 with i7 7700k at 1080p should be getting around 100fps, not 40. 

Geforce Experience is very hit or miss when it comes to what is "optimal" for games.

 

Try this - (keep in mind I do not play W3 so I don't know the exact locations of all settings) load up your Witcher 3, go in the options and change your graphics a little bit. I would look for things like anti-aliasing, bloom, etc. I would tweek these a little bit. Turn them down or off (i usually have bloom off because that is my personal pref). These will definitely affect your performance. It may not look as pretty as you want, but the gameplay will be better. 

 

Also, and someone will probably come in here all in a rage after reading this, but I would try turning on Vsync. If your monitor is only a 1080 screen, I am willing to bet it won't push more than 60 FPS anyway (even if the counter says it is). That is obviously up to you, as I don't have vsync enabled in all my games either, but it helps in some.

--Corsair 230T Orange - MSI X99 Gaming 7 - i7 5820K - 16GB G.Skill Ripjaws 4 DDR4 2400 - EVGA GTX1080Ti FTW3 Hybrid  - EVGA SuperNOVA 750 80+ Gold - Corsair K70 MK.2 SE - Logitech G502 Hero--

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×