Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Hi, I've been helping my friend to build his pc, which didn't boot. When I was going through the lists of things that you should do for troubleshooting, I've tried to test the power supply with some fans attarched . When I've jump started the power supply, the fans spun for a short while and stopped spinning with some smoke coming out. And when I want to re test it again, nothing happened. Could I have killed the power supply?

 

TLDR: Jump started the power supply, smoke came out of fan that's connected to the power supply, power supply dead?

 

System Specs:
CPU: Ryzen 1600

Mobo: Asrock Fatality AB350 Gaming K4

RAM: Hyperx Fury

GPU: Gigabyte RX 580

Power Supply CX650M

 

Update:
I've reconnected everything, the cpu fan is spinning for some reason and the mobo is lit. However, the case fans are not spinning and I can't get it to shut down, is it the mobo's problem?

Link to post
Share on other sites

If there was smoke, then it is probably dead.

I hope that the PSU was not connected to anything while you jump started it.

Link to post
Share on other sites

PSU probably surely dead/fried,unsure if any other component was destroyed.Probably nothing more than the motherboard if it were to kill the Computer

   

PC Specs:Custom Built PC

CPU:AMD Ryzen 3 1200 GPU:Zotac GeForce GTX 1050 TI Mini RAM:Corsair Vengence 2400 MHz DDR4 Motherboard:ASUS Prime B350M-A AM4 Motherboard Case:Corsair 100R PSU:Corsair VS450 

Laptop Specs:Acer TravelMate 8472

CPU:Intel Core i5 560M Memory:2GB DDR3 CPU:Intel HD Graphics Case:Its a Laptop Motherboard:Laptop Motherboard

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×