Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Computer starts up but doesn't load windows

Hi, as the title states, my computer starts up but doesn't load windows. 

I've never done any tinkering with the BIOS or anything like that ever, so i have no idea how to work with it. 

What happens is that when i click the power button, everything starts up, the "gigabyte" message is displayed on the screen. After that the windows logo shows but then the screen goes black. I'm positive that my monitor works properly, and suspect the bios may be out of date. Don't know what bios version im using, or how to update/find which version i have. I have restarted the computer fully several times and get the same result. Also my computer has been refusing to turn on sometimes lately, which i solved by unplugging and replugging the power supply to the pc. 

Specs are as follows:

CPU: intel i5 6500

GPU: amd rx470 xfx triple x

MOBO: gigabyte z170 gaming K3

RAM: 2x4gb ballisitix sport

PSU: EVGA 750W 80+ Bronze

Also a 240gb ssd and a 1tb hdd


Answers appreciated! 

Link to post
Share on other sites

It gets to Windows so likely nothing to do with BIOS.  Tried safe mode?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now