Jump to content

ASRock X370 Gaming K4 and G.Skill Trident-Z 3200 WON'T POST

Hi all, I have an ASRock X370 Gaming K4 and G.Skill Trident-Z 3200 MHz CL14 RAM.

 

Whole system:

AMD Ryzen R5 1600 X || Scythe Mugen 5 || AsRock X370 Gaming K4 || PowerColor RX580 Red Devil || G.Skill Trident-Z 3200 C14 || Samsung 960 EVO M2 NVMe || Corsair RM550x

 

At first. I installed the pair of 8GB G.Skill Trident-Z 3200 MHz CL14 and got a long line of error codes, halting at 0d. Boot loop, no screen. Error code is 3E (then some numbers: 14 15 17; all very fast, so I'm not 100% sure) F9 C0 d0 0d. "0d" stays until restart.

 

These RAM should be the same as the Flare-X by G.Skill (Samsung B-Dies) and thus designed for AM4 systems. However, they seem to be incompatible, at least at the moment. Even the latest BIOS (2.50 w/ AGESA 1006!) does not get them to run.

Trying a Voltage of 1.35 does not help.

Increasing the timings does not work.

DDR_SoC voltage fixed to 1.2 V doesn't solve it either...

I even tried "overwriting" the XMP settings of the G.Skills. To no effect.

 

I bought the cheapest RAM on the "officially supported RAM list" (in this case: crucial 2133 MHz CL15 at 1.2 V) and it works!

Could even put in one of the G.Skills with it so at least I have 16 GB of RAM (at 2133MHz CL 15, crucial is DR, G.Skill SR).

 

The G.Skill RAM was manufactured in March 2017 and called F4-3200C14D-16GTZ (two modules of 8GB).

 

When individually combined with the 2133 MHz crucial stick they both work on 2133 MHz.

 

The crucial stick works fine up to 2667 MHz when used by itself.

 

Whenever I try to increase MHz (starting at 2400 MHz, not 3200), errors occur, system won't POST. So I can not enter BIOS.

Putting 3 modules on the MB --> error, no pOST ;)

 

It's my first build in eight years so I had to be expecting some difficulties... ?

 

Now, I welcome all of you to give me some input/suggestions.

 

Thank you very much!

CPU-Z validation.jpg

crucial.jpg

gskill.jpg

Link to comment
Share on other sites

Link to post
Share on other sites

I did write something about this in another post, but here I go again =) 

 

First, you need to keep in mind, AMD's Ryzen is still fresh with some birthing troubles. EG Ram problems.

 

Then ram manufacturers often tweak "standards" of the DDR3 DDR4 specification to achieve the speeds and specs their modules are advertised for,

If you have a motherboard that is a little picky, those modules won't work, because the boards needs DDR4 Rams that keep the specifications. With that I'm not speaking only about the speed. 

 

To make it short, getting ram that isn't on the compatibility list is just pure luck mostly, except you know that the modules you are getting are keeping true to the specifications that are given in the DDR4 Ram standards.

 

(small hint ADATA does usually no blinki blinki then but working stable ram) 

 

A little Edit:

 

The modules are running at certain speeds because on lower speeds the specifications have a spare % to work in. The faster it gets, the smaller the % of leniency gets.

Main System:

Anghammarad : Asrock Taichi x570, AMD Ryzen 7 5800X @4900 MHz. 32 GB DDR4 3600, some NVME SSDs, Gainward Phoenix RTX 3070TI

 

System 2 "Igluna" AsRock Fatal1ty Z77 Pro, Core I5 3570k @4300, 16 GB Ram DDR3 2133, some SSD, and a 2 TB HDD each, Gainward Phantom 760GTX.

System 3 "Inskah" AsRock Fatal1ty Z77 Pro, Core I5 3570k @4300, 16 GB Ram DDR3 2133, some SSD, and a 2 TB HDD each, Gainward Phantom 760GTX.

 

On the Road: Acer Aspire 5 Model A515-51G-54FD, Intel Core i5 7200U, 8 GB DDR4 Ram, 120 GB SSD, 1 TB SSD, Intel CPU GFX and Nvidia MX 150, Full HD IPS display

 

Media System "Vio": Aorus Elite AX V2, Ryzen 7 5700X, 64 GB Ram DDR4 3200 Mushkin, 1 275 GB Crucial MX SSD, 1 tb Crucial MX500 SSD. IBM 5015 Megaraid, 4 Seagate Ironwolf 4TB HDD in raid 5, 4 WD RED 4 tb in another Raid 5, Gainward Phoenix GTX 1060

 

(Abit Fatal1ty FP9 IN SLI, C2Duo E8400, 6 GB Ram DDR2 800, far too less diskspace, Gainward Phantom 560 GTX broken need fixing)

 

Nostalgia: Amiga 1200, Tower Build, CPU/FPU/MMU 68EC020, 68030, 68882 @50 Mhz, 10 MByte ram (2 MB Chip, 8 MB Fast), Fast SCSI II, 2 CDRoms, 2 1 GB SCSI II IBM Harddrives, 512 MB Quantum Lightning HDD, self soldered Sync changer to attach VGA displays, WLAN

Link to comment
Share on other sites

Link to post
Share on other sites

Thank you for the reply and for your advice. All the evidence speaks for you. Yet, I still find it illogical that some RAM does not seem to work properly inside the parameters of the JEDEC standards. I think that would be the least one should be able to expect ("standard"!). I'm not expecting 3200 MHz to work on this new platform, not booting at all however...

 

I did contact asrock technical support and will wait what they can tell me about the issue.

 

If there is no perspective of getting the RAM operational, I will have to sell this perfectly good RAM and go for another. 

 

To bad, that ADATA is not really available here, so I will have to cross reference available RAM with the list ASRock provides.

 

Any more advice?

Link to comment
Share on other sites

Link to post
Share on other sites

  • 3 weeks later...

I'm having this exact same issue, i'll keep coming back to check if this is solved. i'm about to buy new ram, i would like to know which one is compatible.

Link to comment
Share on other sites

Link to post
Share on other sites

  • 4 months later...

I know this is old thread... I just want to put this out here for other people considering buying this board. (Don't)

 

I have K4, 1700 and Corsair Vengeance LPX 3600 cl 18 memory. I have spent days trying to get 3200 stable. No matter of loosening the timings and tweaking voltages I can't get it stable. 3066 works fine at cl13 (overnight prime95) but 3200 won't be stable xmp cl18.

 

There has been rumors floating around that Asrock EOL the K4 because there was problem with the internal layout, and K4 got replaced by Gaming X. I am starting to believe them based on my own experience with the board, and on K4's website they only quote 2933 and on Gaming X they quote up to 3200.

 

Here is reddit post discussing the topic.

 

I have had bad experience with Asrock years ago and this time around I decided to give them one more chance.... Yes I should have confirmed that it can run 3200 before buying but at the launch memory stability was huge problem for all boards, so you couldn't exactly do that. Even most b350 boards can do 3200 now but this board can't. I feel I really got the short end of the stick here, and for sure won't be buying anything from asrock anytime soon. Should have stuck with Asus like I have done before....

 

TLDR: this board won't do 3200, and was allegedly EOL'ed by asrock because of internal layout problems. Don't buy it.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×