Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Keyboard won't work on BIOS and Startup after BIOS update

I have an Asus Maximus VIII Hero mobo, I updated from version 1903 to 3401, I updated through a flash drive through the menus (as opposed to the physical button).

 

When it stated that the update completed and reboot, nothing showed up on my screen. I cleared the cmos and I got to the american megatrends screen and it woudn't let me press F1 to continue on my Logitech g150s. I got a different keyboard and it worked fine. When I loaded the bios my mouse was fine, but my logitech keyboard wouldn't work.

 

What can I do to get my logitech keyboard to work like it did on bios 1903?

Link to post
Share on other sites

Can you get into the bios? or is it just an issue in windows safe mode options?

Have you tried turning it off and on again?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×