Jump to content

Guide to P State (Variable Frequency) Overclocking on the Crosshair vi Hero

One more thing to try?  In Digi Power screen set the phase control to Auto or Optimized.  I think if you have them on anything else it tries to hold a voltage, not sure.  Might play around with that myself.  I have mine (CPU and SOC phase control) on Optimized.

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks for the tip.  I have changed the CPU and SOC power phases to optimized with no change in my results.  I tried changing the power setting to Power Saving which does allow my idle voltage to decrease to around ~1.0v, but it causes my system to hang at random times.

Link to comment
Share on other sites

Link to post
Share on other sites

Okay, next thing to try since you're getting voltage changes now.  Use the Windows "High Performance" power plan, but go into the advanced settings and make the processor minimum state "20%".  That's what I'm using with no hangs.  I'm not sure about the power saving mode in the BIOS but setting the OS to properly throttle the processor is apparently key.

 

I had some minor problems with the Ryzen Balanced plan with the game "No Man's Sky" and it was weird -- it caused to audio to drop out and sometimes the game would hang but the computer was not halted.  I could get out of the game and kill the game and the computer was still running.  I changed to the Windows High Performance plan with the lowered minimum setting and have  had zero issues.

 

Link to comment
Share on other sites

Link to post
Share on other sites

I'm using manual voltage rather than offset. Would that break it?

I will try offset tonight and report back. 

Otherwise, we have the same settings except I leave my SOC voltage at auto.

 

EDIT; sorry to post so late in the conversation, didn't notice there was a page 2. faded haha

was in response to you, @entropic remnants :)

Edited by AlexKelly
Link to comment
Share on other sites

Link to post
Share on other sites

Ha ha! No worries.  Yes, you must use offset mode for voltage to work from what I'm reading -- and that's how I set mine up.

 

Tom describes in the first post how to get the number you need for the offset using that voltage in the P0 state.  I think 1.35 for you, right?  So whatever your desired voltage is subtract 1.35 from it and enter it as an offset in Extreme Tweaker for core voltage.  The calculation didn't work exactly and I trimmed it but it's close.  I'm also using load line 4 for the core in the Digi Power options but your system may not need anything that stiff to keep the voltage constant.  I think most folks seem to favor 2 or 3 for that.

 

EDIT: Looking back at your previous posts it looks like you already know the offset number you need so I think you just need to put core voltage in offset mode in Extreme Tweaker and enter that fractional voltage you posted and give it a whirl.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Thanks @entropic remnants, I cleared my CMOS and applied the same settings but using offset voltage. 

And yes, my voltage is now ramping down along with the frequency. Thanks!!

Link to comment
Share on other sites

Link to post
Share on other sites

7 hours ago, AlexKelly said:

Thanks @entropic remnants, I cleared my CMOS and applied the same settings but using offset voltage. 

And yes, my voltage is now ramping down along with the frequency. Thanks!!

Excellent!  Thanks to Tom also since this is his thread and I'm just acting as a surrogate, lol.

 

Link to comment
Share on other sites

Link to post
Share on other sites

On 5/18/2017 at 8:32 PM, entropic remnants said:

Okay, next thing to try since you're getting voltage changes now.  Use the Windows "High Performance" power plan, but go into the advanced settings and make the processor minimum state "20%".  That's what I'm using with no hangs.  I'm not sure about the power saving mode in the BIOS but setting the OS to properly throttle the processor is apparently key.

 

I had some minor problems with the Ryzen Balanced plan with the game "No Man's Sky" and it was weird -- it caused to audio to drop out and sometimes the game would hang but the computer was not halted.  I could get out of the game and kill the game and the computer was still running.  I changed to the Windows High Performance plan with the lowered minimum setting and have  had zero issues.

 

I've done as you mentioned but if I change any of the power plans to anything other than Power Saving, then the voltage reverts back to being constant.  This still occurs when I change the minimum processor state to 20% or lower.

Link to comment
Share on other sites

Link to post
Share on other sites

13 hours ago, AlexKelly said:

Thanks @entropic remnants, I cleared my CMOS and applied the same settings but using offset voltage. 

And yes, my voltage is now ramping down along with the frequency. Thanks!!

Sorry for the delay. Manual forces a set voltage at all times this is why offset fixed it for you.

6 hours ago, entropic remnants said:

Excellent!  Thanks to Tom also since this is his thread and I'm just acting as a surrogate, lol.

 

Thanks for helping others 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, randomlamer said:

I've done as you mentioned but if I change any of the power plans to anything other than Power Saving, then the voltage reverts back to being constant.  This still occurs when I change the minimum processor state to 20% or lower.

Voltage stays constant but clock speed varies? If so double check you are using offset and not manual. Copy my bios screenshots exactly. Load optimised defaults to have a "clean slate" then apply the guide above. It's fiddley and you must follow the guide exactly to the letter.

Link to comment
Share on other sites

Link to post
Share on other sites

Hi, so I went back and loaded optimized defaults, and changed all settings as per your guide with the exception of disabling core performance boost and leaving line load calibration to auto.

Spoiler

170520134507.jpg.913a85f3245a0481efd21261ad354d4e.jpg170520134516.jpg.3e0282c7f67e2432a75ad637cfafd221.jpg170520134539.jpg.f30ec255d97347c653820cdf19cfa4d8.jpg170520134554.jpg.5dce4854c35a6dc3cd0494aad9feefad.jpgUntitled.thumb.jpg.3bb3b827ffa878161aacb3168c96e60b.jpgUntitled2.jpg.3913952f0221de68ab33b2a3eda11bbf.jpg

 

Link to comment
Share on other sites

Link to post
Share on other sites

40 minutes ago, randomlamer said:

Hi, so I went back and loaded optimized defaults, and changed all settings as per your guide with the exception of disabling core performance boost and leaving line load calibration to auto.

  Hide contents

170520134507.jpg.913a85f3245a0481efd21261ad354d4e.jpg170520134516.jpg.3e0282c7f67e2432a75ad637cfafd221.jpg170520134539.jpg.f30ec255d97347c653820cdf19cfa4d8.jpg170520134554.jpg.5dce4854c35a6dc3cd0494aad9feefad.jpgUntitled.thumb.jpg.3bb3b827ffa878161aacb3168c96e60b.jpgUntitled2.jpg.3913952f0221de68ab33b2a3eda11bbf.jpg

 

Strange, it's good that clocks are varying but strange that voltage is not.

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

I wanted to ask... Is this worth it? Pstate OC?

Main PC:

CPU: Intel Core i9 13900KS (Awaiting release date)

CPU Voltage: N/A

Cooled by: Supercool Direct Die

Motherboard: Z790 ASUS Maximus Apex

RAM: GSkill TridentZ 2x16GB DDR5 8000Mhz CL38 or TeamGroup Delta 7600Mhz CL36

GPU: RTX MSI 4090 Suprim X with EKWB waterblock

Case: My own case fabricated out of aluminium and wood

Storage: 2x 2TB Sarbent Rocket Plus Gen 4.0 NVMe, 1x 1TB Samsung NVMe 4.0, 1x External 2TB Seagate Barracuda (Backup)

WiFi: AX211 WiFi 6 Tri-Band card module

PSU: Corsair AX1600i with custom black and red cables with Corsair 5V+ Load Balancer

Display: Samsung Oddysey G9 240Hz Ver. 5120x1440 with G-Sync and Freesync Premium Pro 1008 Firmware Ver, and 1x Electriq USB C 1080p 15'8 inch IPS portable display for temperature and stats, MSI 23'8 144Hz G-Sync

Fan Controllers: 6x AquaComputer Octo with 5 temperature sensors

Cooling: Three Custom Loops:

1st Loop: 5x 480mm XE CoolStream radiators with 1x Revo D5 RGB pump and 1x Rajintek Antila D5 Evo RGB pump for GPU only cooling with 2x Koolance QDC3, red coolant

2nd Loop: 5x 480mm XE CoolStream radiators with 1x Revo D5 RGB pump and 1x Rajintek Antila D5 Evo RGB pump for CPU only cooling with 2x Koolance QDC3, purple coolant

3rd Loop: 1x 240mm PE CoolStream radiator with 1x EKWB Revo D5 pump (RAM ONLY)

Total: 5x pumps and 13x radiators 50x 3000RPM Noctua Industrial fans

Keyboard: Razer BlackWidow V3 RGB - Green switches

Sound: Logitech Z680 5.1 THX Certified 505W Speakers

Mouse: Razer Basilisk Ultimate Wireless with charging dock

Piano: Yamaha P155

Phone: Oppo Find X5 Pro

Camera: Logitech Brio Pro 4K

VR: Oculus Rift S

External SSD: 256GB Overclocking OS

Laptop: Awaiting 13th gen laptop with 13980HX with 4000 Series GPU

Link to comment
Share on other sites

Link to post
Share on other sites

On 6/23/2017 at 9:27 AM, tom_w141 said:

Yes the reason why is in the first post.

 

Processor will live longer, power bills will be lower and less heat generated.

Are there any risks? Once I saw hex stuFF I was mortified.

Main PC:

CPU: Intel Core i9 13900KS (Awaiting release date)

CPU Voltage: N/A

Cooled by: Supercool Direct Die

Motherboard: Z790 ASUS Maximus Apex

RAM: GSkill TridentZ 2x16GB DDR5 8000Mhz CL38 or TeamGroup Delta 7600Mhz CL36

GPU: RTX MSI 4090 Suprim X with EKWB waterblock

Case: My own case fabricated out of aluminium and wood

Storage: 2x 2TB Sarbent Rocket Plus Gen 4.0 NVMe, 1x 1TB Samsung NVMe 4.0, 1x External 2TB Seagate Barracuda (Backup)

WiFi: AX211 WiFi 6 Tri-Band card module

PSU: Corsair AX1600i with custom black and red cables with Corsair 5V+ Load Balancer

Display: Samsung Oddysey G9 240Hz Ver. 5120x1440 with G-Sync and Freesync Premium Pro 1008 Firmware Ver, and 1x Electriq USB C 1080p 15'8 inch IPS portable display for temperature and stats, MSI 23'8 144Hz G-Sync

Fan Controllers: 6x AquaComputer Octo with 5 temperature sensors

Cooling: Three Custom Loops:

1st Loop: 5x 480mm XE CoolStream radiators with 1x Revo D5 RGB pump and 1x Rajintek Antila D5 Evo RGB pump for GPU only cooling with 2x Koolance QDC3, red coolant

2nd Loop: 5x 480mm XE CoolStream radiators with 1x Revo D5 RGB pump and 1x Rajintek Antila D5 Evo RGB pump for CPU only cooling with 2x Koolance QDC3, purple coolant

3rd Loop: 1x 240mm PE CoolStream radiator with 1x EKWB Revo D5 pump (RAM ONLY)

Total: 5x pumps and 13x radiators 50x 3000RPM Noctua Industrial fans

Keyboard: Razer BlackWidow V3 RGB - Green switches

Sound: Logitech Z680 5.1 THX Certified 505W Speakers

Mouse: Razer Basilisk Ultimate Wireless with charging dock

Piano: Yamaha P155

Phone: Oppo Find X5 Pro

Camera: Logitech Brio Pro 4K

VR: Oculus Rift S

External SSD: 256GB Overclocking OS

Laptop: Awaiting 13th gen laptop with 13980HX with 4000 Series GPU

Link to comment
Share on other sites

Link to post
Share on other sites

  • 1 month later...

I tried this and it works fine.. but im having the same issue as randomlamer! The core voltage doesn't drop with the core clock. Anyone figure out what the issue was ? 

Link to comment
Share on other sites

Link to post
Share on other sites

This is awesome. I was so disappointed when I found out that overclocking Ryzen forces a static state, but this completely fixed my problems.

 

On 5/20/2017 at 4:57 PM, randomlamer said:

Hi, so I went back and loaded optimized defaults, and changed all settings as per your guide with the exception of disabling core performance boost and leaving line load calibration to auto.

(and @Premchand)

If this is still an issue, I have a few things:

-Update your BIOS just to make sure, unless you've already done that since this post.

-Set "Core Performance Boost" in the tweaker to Auto. I believe this affects Precision Boost and XFR, I'm not sure, but I have it on Auto.

-Try using the Ryzen power plan from AMD, again just to make sure.

 

Those, at least as far as I can tell, are what I'm doing differently. I'm also using Level 2 LLC, but my voltage was behaving probably before I changed that, my system was just unstable.

 

EDIT: I also suggest trying the Windows 'Balanced' power plan, as that much more consistently lowers my CPU's voltage.

"Do as I say, not as I do."

-Because you actually care if it makes sense.

Link to comment
Share on other sites

Link to post
Share on other sites

Does the static state issues apply to all Ryzen CPU's or just for Ryzen 7?

Link to comment
Share on other sites

Link to post
Share on other sites

13 hours ago, K3VS said:

Does the static state issues apply to all Ryzen CPU's or just for Ryzen 7?

Are you referring to clock speed not varying when you do a multiplier overclock? That would be all Ryzen CPUs. They are all the same so if something affects 1 it affects the others.

Link to comment
Share on other sites

Link to post
Share on other sites

I'm using a Ryzen 1700X on the Crosshair VI Hero board, using BIOS 1403

Pstate 0 is set to 3.8GHz clock with voltage set to stock; 1.35V.

 

I've been a little annoyed with the way Ryzen runs a constant voltage. I've come across the P State option a time or two. Problem is... it's not down-clocking, but is down-volting. Reaching as low as 0.435V, and pinned to about 3.793GHz at the same time. I'm also running the CPU and VDSOC Load Lines at Level 2, setting both to Level 1 had the same results, but a little less sporadic voltage changes in Level 1.

 

I'm new to overclocking, so I'm not sure where to start looking for fixes. 

Screenshot 2017-08-10 01.05.07.png

Screenshot 2017-08-10 01.05.14.png

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, RedshiftTheFox said:

I'm using a Ryzen 1700X on the Crosshair VI Hero board, using BIOS 1403

Pstate 0 is set to 3.8GHz clock with voltage set to stock; 1.35V.

 

I've been a little annoyed with the way Ryzen runs a constant voltage. I've come across the P State option a time or two. Problem is... it's not down-clocking, but is down-volting. Reaching as low as 0.435V, and pinned to about 3.793GHz at the same time. I'm also running the CPU and VDSOC Load Lines at Level 2, setting both to Level 1 had the same results, but a little less sporadic voltage changes in Level 1.

 

I'm new to overclocking, so I'm not sure where to start looking for fixes. 

Screenshot 2017-08-10 01.05.07.png

Screenshot 2017-08-10 01.05.14.png

Unfortunately those screenshots are broken for me (could be because I'm using a work PC) but i'll try and help anyway.

 

Some important things to remember:

 

- You can only change the hex value in P0 if you change the voltage value it will not work.

 

- Voltage shouldn't be fixed it should vary with clocks make sure voltage is set to offset not manual (You choose the maximum voltage via offset).

 

- You need to use the high performance power plan or AMD balanced plan. To get the AMD plan you will need to manually update your chipset driver: http://support.amd.com/en-us/download/chipset?os=Windows 10 - 64

 

- Within the high performance or AMD plan you need to edit the minimum processor frequency. In my guide I use 20%.

 

Step 11 in my OP:

 

Quote

 edit the plan -> change advanced power settings -> expand "Processor Power Management" -> expand "Minimum Processor State" -> set this at 20%

Let me know if you are still having issues.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×