Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Monitor won't turn on when connected to surge protector

My brand new asus monitor that I opened out the box , I plugged it in my surge protector first and when I tried turning it on I heard a click, and it quickly turned off. It doesn't turn on when connected to the power surge but is fine when connected to regular wall outlet. Why is this happening?

Link to post
Share on other sites

Does the surge protector work with other things? did you try plugging the monitor into different ports? 

desktop

Spoiler

r5 3600 wip,3450@0.9v (0.875v get) 4.2ghz@1.25v (1.212 get) | custom loop cpu&gpu 1260mm nexxos xt45 | MSI b450i gaming ac | crucial ballistix 2x8 3000c15->3733c15@1.39v(1.376v get) |Zotac 2060 amp | 256GB Samsung 950 pro nvme | 1TB Adata su800 | 4TB HGST drive | Silverstone SX500-LG | Silverstone ML08

HTPC

Spoiler

HTPC i3 7300 | Gigabyte GA-B250M-DS3H | 16GB G Skill | Adata XPG SX8000 128GB M.2 | Many HDDs | Rosewill FBM-01 | Corsair CXM 450W

 

 

Link to post
Share on other sites

I would try to plug the monitor into a different outlet to single out the possibility that it is indeed, your surge protector causing it to act like that.

Link to post
Share on other sites
30 minutes ago, Cyracus said:

Does the surge protector work with other things? did you try plugging the monitor into different ports? 

My speakers and pc is connected to the power surge and they work fine and I tried different ports and it doesn't work.

Link to post
Share on other sites

This kind of makes me suspect a grounding issue, might be that the grounding on your monitor isn't working properly and it's triggering the surge protector.

Link to post
Share on other sites

Get a beefy surge protector, mine has 4 outlets and handles 3500 watts. 

They are abit pricey but well worth the quality.

|EVGA 850 P2| |1440p PG279Q| |X570 Aorus Extreme| |Ryzen 9 3950x WC| |FE 2080Ti WC|TridentZ Neo 64GB| |Samsung 970 EVO M.2 1TB x3

 |Logitech G900|K70 Cherry MX Speed|  |Logitech Z906 |  |HD650|  |CaseLabs SMA8 (one of the last ones made)

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×