Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

PC Shutsdown Under Load

So recently my PC has been shutting down under semi-heavy to heavy loads for example today i was playing Cities: Skylines and listening to spotify and it shutdown on its own. My PC isn't exactly the newest machine but i  have tried to keep it as up to date as possible. My Specs, along with the year it was installed, are as follows:

 

CPU: AMD FX 8350 (No OC) (2013)

Cooler: Cryorig H7 (2017)

GPU: ASUS GTX 970 STRIX (2015)

Mobo: ASUS M5A990FX (2015)

PSU: Corsair CX 500 (2013)

RAM: Mushkin Blackline 12GB DDR3 (2013)

Storage: Intel 128GB SSD (2015)

                WD Blue 1TB (2013)

                Seagate Enterprise 5TB (2015)

 

 

As you can see the most recent thing i changed was the CPU Cooler. Im thinking its the PSU since its the oldest and i know the average lifespan is around 5-10 years. If anyone could help me that would be greatly appreciated.

 

Link to post
Share on other sites
2 minutes ago, mtsprite said:

So recently my PC has been shutting down under semi-heavy to heavy loads for example today i was playing Cities: Skylines and listening to spotify and it shutdown on its own. My PC isn't exactly the newest machine but i  have tried to keep it as up to date as possible. My Specs, along with the year it was installed, are as follows:

 

CPU: AMD FX 8350 (No OC) (2013)

Cooler: Cryorig H7 (2017)

GPU: ASUS GTX 970 STRIX (2015)

Mobo: ASUS M5A990FX (2015)

PSU: Corsair CX 500 (2013)

RAM: Mushkin Blackline 12GB DDR3 (2013)

Storage: Intel 128GB SSD (2015)

                WD Blue 1TB (2013)

                Seagate Enterprise 5TB (2015)

 

 

As you can see the most recent thing i changed was the CPU Cooler. Im thinking its the PSU since its the oldest and i know the average lifespan is around 5-10 years. If anyone could help me that would be greatly appreciated.

 

 
 

the issue is probably the cx500 they are poor quality

6600K - ASUS Z270i Gaming ITX - 8GB Corsair  Vengence LPX DDR4 2400MHZ - EVGA 1070SC - 120GB HyperX Savage SSD - CX430 PSU:|

PSU tier list- 

 

Link to post
Share on other sites
11 minutes ago, Matt_98 said:

the issue is probably the cx500 they are poor quality

I'm thinking that's what it is as well. im looking into a new power supplies right now.

Link to post
Share on other sites
8 minutes ago, Matt_98 said:

the issue is probably the cx500 they are poor quality

Agree. Can't deliver enough power to the CPU and GPU.

Check out my laptop reviews here

 

My daily driver: Lenovo Legion Y530 [REVIEW]

Spoiler

Intel Core i5-8300H Nvidia GTX1050Ti 2GB LP156WFG-SPB2 144Hz IPS 16GB 2666MHz DDR4 RAM (2x8GB) Samsung PM981 256GB+Seagate 1TB 5400RPM

Check out my blog here

Laptop ODMsClevo, Tongfang, Quanta

 

My Phone: Xiaomi Mi 9 Lite [REVIEW] (Blue, with XUNDD hard case)

Spoiler

SDM710 6GB RAM 128GB ROM 6.39" AMOLED 48MP Sony IMX586 rear (AI triple camera)

Link to post
Share on other sites

When did you open your p  last time? I don't think that the psu is the problem. Even under full stress your pc should not draw more then 300w. Check if you cooler are all free if dust.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×