Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows 7 Installation not seeing SSD or HDD

Go to solution Solved by forthe48,
14 minutes ago, Nebby said:

The SSD is in AHCI right now, how do I get it to "IDE" (MSI BIOS)

You don't want it to be set to IDE, AHCI should be fine. If there's an 'ATA' option, you could try that as well. Sorry for my confusing wording, I was saying that it may be currently set to IDE, which would need to be changed.

 

Also check whether you have legacy boot enabled. Are you booting to the Windows installer through UEFI or no? If you were, it would say "UEFI: Your Device." on the boot options menu.

 

If your drives are formatted with GPT then legacy boot might not be able to see them. These are just ideas, I'm not sure.

 

Maybe if all else fails you could try to find a newer version of the Windows 7 installer, which may include more drivers and be able to see your drive(s).

So here I am, doing a clean install, new pc and such. I get into the windows installation, and it gives me the error: "No device drivers were found, Make sure the installation media contains the correct drivers, and then click OK". I've already done the disk part and clean the disk(SSD) buy that didn't work. Both the HDD and SSD are showing up in the BIOS.

 

I am installing this off of a USB.

 

So what do I have to do for it to see the SSD??

 

SSD model: Kingston Hyper X 120gb

 

Link to post
Share on other sites

I'd try switching the order the drivers are plugged into their Sata ports.
They should be numbered 1 to however many you have.
If the SSD is already ahead of the HDD, I'd remove the HDD until after the install.

[CPU: 4.7ghz I5 6600k] [MBAsus Z170 Pro G] [RAM: G.Skill 2400 16GB(2x8)]

[GPU: MSI Twin Frozr GTX 970] [PSU: XFX Pro 850W] [Cooler: Hyper 212 Evo]
[Storage: 500GB WD HDD / 128GB SanDisk SSD ] [Case: DeepCool Tessaract]

[Keyboard: AZIO MGK1] [Mouse: Logitech G303] [Monitor: 2 x Acer 23" 1080p IPS]

 

Link to post
Share on other sites
Just now, DioOmicida said:

I'd try switching the order the drivers are plugged into their Sata ports.
They should be numbered 1 to however many you have.
If the SSD is already ahead of the HDD, I remove the HDD until after the install.

I had the HDD unplugged before hand as well. I'll re-arrange the order, maybe it's a bad SATA port.? Not sure though considering the motherboard sees it

Link to post
Share on other sites
1 minute ago, Nebby said:

I had the HDD unplugged before hand as well. I'll re-arrange the order, maybe it's a bad SATA port.? Not sure though considering the motherboard sees it

I had a similar issue when setting up my first SSD and that's essentially how I solved the problem for me.
I removed the HDD and plugged the SSD into the first Sata slot. Windows was able to register the drive then.
You could try other slots as well, but I would still try to do them in numeric order.

[CPU: 4.7ghz I5 6600k] [MBAsus Z170 Pro G] [RAM: G.Skill 2400 16GB(2x8)]

[GPU: MSI Twin Frozr GTX 970] [PSU: XFX Pro 850W] [Cooler: Hyper 212 Evo]
[Storage: 500GB WD HDD / 128GB SanDisk SSD ] [Case: DeepCool Tessaract]

[Keyboard: AZIO MGK1] [Mouse: Logitech G303] [Monitor: 2 x Acer 23" 1080p IPS]

 

Link to post
Share on other sites
1 minute ago, DioOmicida said:

I had a similar issue when setting up my first SSD and that's essentially how I solved the problem for me.
I removed the HDD and plugged the SSD into the first Sata slot. Windows was able to register the drive then.
You could try other slots as well, but I would still try to do them in numeric order.

Alright let me try that, the SSD is in SATA 1 at the moment

Link to post
Share on other sites
8 minutes ago, Nebby said:

Alright let me try that, the SSD is in SATA 1 at the moment

Another thing to check would be to look at your BIOS and see what mode the drives are in. Are they set to 'RAID ON', or to 'AHCI', or 'ATA?' maybe even set to 'IDE' depending on your mobo?

 

Check the drive mode if rearranging SATA slots doesn't work, it could be another piece of the puzzle.

Link to post
Share on other sites
10 minutes ago, forthe48 said:

Another thing to check would be to look at your BIOS and see what mode the drives are in. Are they set to 'RAID ON', or to 'AHCI', or 'ATA?' maybe even set to 'IDE' depending on your mobo?

 

Check the drive mode if rearranging SATA slots doesn't work, it could be another piece of the puzzle.

The SSD is in AHCI right now, how do I get it to "IDE" (MSI BIOS)

Link to post
Share on other sites
14 minutes ago, Nebby said:

The SSD is in AHCI right now, how do I get it to "IDE" (MSI BIOS)

You don't want it to be set to IDE, AHCI should be fine. If there's an 'ATA' option, you could try that as well. Sorry for my confusing wording, I was saying that it may be currently set to IDE, which would need to be changed.

 

Also check whether you have legacy boot enabled. Are you booting to the Windows installer through UEFI or no? If you were, it would say "UEFI: Your Device." on the boot options menu.

 

If your drives are formatted with GPT then legacy boot might not be able to see them. These are just ideas, I'm not sure.

 

Maybe if all else fails you could try to find a newer version of the Windows 7 installer, which may include more drivers and be able to see your drive(s).

Link to post
Share on other sites
36 minutes ago, forthe48 said:

You don't want it to be set to IDE, AHCI should be fine. If there's an 'ATA' option, you could try that as well. Sorry for my confusing wording, I was saying that it may be currently set to IDE, which would need to be changed.

 

Also check whether you have legacy boot enabled. Are you booting to the Windows installer through UEFI or no? If you were, it would say "UEFI: Your Device." on the boot options menu.

 

If your drives are formatted with GPT then legacy boot might not be able to see them. These are just ideas, I'm not sure.

 

Maybe if all else fails you could try to find a newer version of the Windows 7 installer, which may include more drivers and be able to see your drive(s).

How can I tell if it's in legacy??

Link to post
Share on other sites
46 minutes ago, forthe48 said:

You don't want it to be set to IDE, AHCI should be fine. If there's an 'ATA' option, you could try that as well. Sorry for my confusing wording, I was saying that it may be currently set to IDE, which would need to be changed.

 

Also check whether you have legacy boot enabled. Are you booting to the Windows installer through UEFI or no? If you were, it would say "UEFI: Your Device." on the boot options menu.

 

If your drives are formatted with GPT then legacy boot might not be able to see them. These are just ideas, I'm not sure.

 

Maybe if all else fails you could try to find a newer version of the Windows 7 installer, which may include more drivers and be able to see your drive(s).

It worked, I guess it was an older version. But now it sees it. Thanks!!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×