Jump to content

MSI R9 380 4GB low fps

Jperkins85

Recently I have been having major issues with my R9 380 with FPS in numerous games.  I am only averaging an FPS of around 40 in GTA V and used to get a lot more than that.  On Tomb Raider only getting around 40 also.  I have removed AMD CCC thinking that was the issue,  but didn't really help out much.  I am also having major studding issues on GTA V,  any clue as to what may be wrong?

 

AMD 8320 OC at 4 GHZ

8 GB DDR3 Ram

MSI R9 380 4gb stock (getting same FPS when in overclocked mode also)

 

Resolution at 1440x900 FPS drops down to 30 and below often also

 

Any help would be greatly appreciated,  and thanks for your time. 

Link to comment
Share on other sites

Link to post
Share on other sites

I would say that the CPU aint the best thing in the world.

Link to comment
Share on other sites

Link to post
Share on other sites

did you removed all traces of the old driver?

 

use Display Driver Uninstall to wipe the PC of the old driver

 

and then update to 15.12 Crimson Driver

Budget? Uses? Currency? Location? Operating System? Peripherals? Monitor? Use PCPartPicker wherever possible. 

Quote whom you're replying to, and set option to follow your topics. Or Else we can't see your reply.

 

Link to comment
Share on other sites

Link to post
Share on other sites

Yes,  updated to the Crimson drivers but went back because it kept crashing while playing. 

Link to comment
Share on other sites

Link to post
Share on other sites

I would say that the CPU aint the best thing in the world.

 

I agree on that,  was going to upgrade when I get the chance,  but fps going from an average of 55 to 60 down to 40 and below shouldn't be cpu related should it?

Link to comment
Share on other sites

Link to post
Share on other sites

Those dips kind of look like throttling. I know that AMD CPU's aren't the best, but I run tomb raider 60fps on high settings 1080p. I too have an FX 8320 but have a GTX 660 ti.

Link to comment
Share on other sites

Link to post
Share on other sites

I agree on that,  was going to upgrade when I get the chance,  but fps going from an average of 55 to 60 down to 40 and below shouldn't be cpu related should it?

Technically it should not.

Issues like drivers is probably the problem as you retained the exact hardware.

Link to comment
Share on other sites

Link to post
Share on other sites

Those dips kind of look like throttling. I know that AMD CPU's aren't the best, but I run tomb raider 60fps on high settings 1080p. I too have an FX 8320 but have a GTX 660 ti.

+1 what temps are you getting with your cpu op

Link to comment
Share on other sites

Link to post
Share on other sites

+1 what temps are you getting with your cpu op

Umm, I have a hyper 212 evo, but I changed the fan and re-applied its thermal paste. I'd say about ~60-70C

Link to comment
Share on other sites

Link to post
Share on other sites

+1 what temps are you getting with your cpu op

I'm getting around 55c on CPU

Link to comment
Share on other sites

Link to post
Share on other sites

If you're using 15.12 then remove it and use 15.11.1 It's below the main Crimson driver and listed as a Beta driver.

If anyone asks you never saw me.

Link to comment
Share on other sites

Link to post
Share on other sites

If you're using 15.12 then remove it and use 15.11.1 It's below the main Crimson driver and listed as a Beta driver.

 

Yea I tried that also,  and now it keeps diverting back to 15.3 when I try running it with anything else.  Really getting on my nerves,  been trying to figure this out for a while now.  Was playing GTA V today and was only getting around 30 FPS and didn't change no matter what settings I had the game on.  Terrible,  especially considering I was getting close to 50 with this card. 

Link to comment
Share on other sites

Link to post
Share on other sites

Yea I tried that also,  and now it keeps diverting back to 15.3 when I try running it with anything else.  Really getting on my nerves,  been trying to figure this out for a while now.  Was playing GTA V today and was only getting around 30 FPS and didn't change no matter what settings I had the game on.  Terrible,  especially considering I was getting close to 50 with this card. 

If it's locked to 30 check the ingame options for any fps limiter. Check FRTC as well

Archangel (Desktop) CPU: i5 4590 GPU:Asus R9 280  3GB RAM:HyperX Beast 2x4GBPSU:SeaSonic S12G 750W Mobo:GA-H97m-HD3 Case:CM Silencio 650 Storage:1 TB WD Red
Celestial (Laptop 1) CPU:i7 4720HQ GPU:GTX 860M 4GB RAM:2x4GB SK Hynix DDR3Storage: 250GB 850 EVO Model:Lenovo Y50-70
Seraph (Laptop 2) CPU:i7 6700HQ GPU:GTX 970M 3GB RAM:2x8GB DDR4Storage: 256GB Samsung 951 + 1TB Toshiba HDD Model:Asus GL502VT

Windows 10 is now MSX! - http://linustechtips.com/main/topic/440190-can-we-start-calling-windows-10/page-6

Link to comment
Share on other sites

Link to post
Share on other sites

When I look towards the sky or if I am in a house, getting up to around 60

Link to comment
Share on other sites

Link to post
Share on other sites

Well for some reason I am now getting a solid fps of around 60,  not sure what fixed it but I'm glad its better.  Using driver 15.3 still and its going great now.  Thanks everyone for your help and suggestions,  gave me hope and kept me from tossing my computer out of the window lol.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×