Jump to content

Rainbow 6 Siege disply problem

Zentorno56

Whenever I get on Rainbow Six Siege and start playing, it makes the display super weird and distorted and if I go to a certain place I can see these flat trees, gravestones, and other objects. Please help. 

Link to comment
Share on other sites

Link to post
Share on other sites

Can you post a screen shot of the issue along with your pc's specs and current video card driver #.

Link to comment
Share on other sites

Link to post
Share on other sites

Can you post a screen shot of the issue along with your pc's specs and current video card driver #.

Yeah I'll be doing that right now. 

Link to comment
Share on other sites

Link to post
Share on other sites

What settings are you trying to play the game on?

That's artifacting btw. 

Link to comment
Share on other sites

Link to post
Share on other sites

http://imgur.com/gallery/cpf7YhE/new

 

Specs

FX 6300

R7 250X

8Gb RAM

Radeon Crimson Edition 15.12 

re-install drivers

 

set the speeds to stock.

"Sulit" (adj.) something that is worth it

i7 8700K 4.8Ghz delidded / Corsair H100i V2 / Asus Strix Z370-F / G.Skill Trident Z RGB 16GB 3200 / EVGA GTX 1080Ti FTW3 / ASUS ROG SWIFT PG279Q

Samsung 850 EVO 500GB & 250GB - Crucial MX300 M.2 525GB / Fractal Design Define S / Corsair K70 MX Reds / Logitech G502 / Beyerdynamic DT770 250Ohm

SMSL SD793II AMP/DAC - Schiit Magni 3 / PCPP

Old Rig

i5 2500k 4.5Ghz | Gigabyte Z68XP-UD3P | Zotac GTX 980 AMP! Extreme | Crucial Ballistix Tactical 16GB 1866MHz

Link to comment
Share on other sites

Link to post
Share on other sites

re-install drivers

 

set the speeds to stock.

This may help but usually when I see artifacts like this it's VRAM related. High voltage or high temps could be a factor.

Link to comment
Share on other sites

Link to post
Share on other sites

What settings are you trying to play the game on?

All low. 

Link to comment
Share on other sites

Link to post
Share on other sites

re-install drivers

 

set the speeds to stock.

I've never changed the speeds but Ill try reinstalling.

Link to comment
Share on other sites

Link to post
Share on other sites

This may help but usually when I see artifacts like this it's VRAM related. High voltage or high temps could be a factor.

Yeah I only have 2 gb of VRAM on my 250X.

Link to comment
Share on other sites

Link to post
Share on other sites

I've never changed the speeds but Ill try reinstalling.

yea reinstall your drivers mate

NEVER GIVE UP. NEVER STOP LEARNING. DONT LET THE PAST HURT YOU. YOU CAN DOOOOO IT

Link to comment
Share on other sites

Link to post
Share on other sites

Yeah I only have 2 gb of VRAM on my 250X.

2GB is the perfect. Mostly your drivers. Just reinstall them and see if your problem persists. Does it do this to any other games you have?

NEVER GIVE UP. NEVER STOP LEARNING. DONT LET THE PAST HURT YOU. YOU CAN DOOOOO IT

Link to comment
Share on other sites

Link to post
Share on other sites

I had this during beta i just updated my drivers and it worked fine after

Link to comment
Share on other sites

Link to post
Share on other sites

Alright

how much vram are you taking up?

"Sulit" (adj.) something that is worth it

i7 8700K 4.8Ghz delidded / Corsair H100i V2 / Asus Strix Z370-F / G.Skill Trident Z RGB 16GB 3200 / EVGA GTX 1080Ti FTW3 / ASUS ROG SWIFT PG279Q

Samsung 850 EVO 500GB & 250GB - Crucial MX300 M.2 525GB / Fractal Design Define S / Corsair K70 MX Reds / Logitech G502 / Beyerdynamic DT770 250Ohm

SMSL SD793II AMP/DAC - Schiit Magni 3 / PCPP

Old Rig

i5 2500k 4.5Ghz | Gigabyte Z68XP-UD3P | Zotac GTX 980 AMP! Extreme | Crucial Ballistix Tactical 16GB 1866MHz

Link to comment
Share on other sites

Link to post
Share on other sites

2GB is the perfect. Mostly your drivers. Just reinstall them and see if your problem persists. Does it do this to any other games you have?

No it's never happened but I think I have to update my drivers.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×