Jump to content

Star Wars Battlefront not launching

For some reason, my Star Wars Battlefront will no longer launch. I have tried repairing the game, reinstalling the game, doing a system restore to before the last windows update, running CCleaner on my registry, etc. I literally cannot think of anything else to do and neither can EA support. The game does not run on either Nvidia drivers 359.00 or 359.06. I have tried enabling and disabling SLI mode to no avail. If anyone can think of a way to fix this, or if you have been having the same problem, let me know. Thanks. 

CPU: AMD Ryzen 7 5800X (liquid cooled) GPU: EVGA RTX 3080 Ultra non-LHR MOBO: Asus ROG Crosshair VIII Hero Wi-Fi RAM: 32GB G.Skill TridentZ RGB 3600MHz DDR4 (2x16GB) PSU: Corsair HX1200i (overkill yes, but was free!) Storage: 1 TB XPG SX8200 Pro NVMe, 2TB XPG SX8100 NVMe, 4TB WD Blue SATA SSD, 2x 480GB SATA SSDs, 3TB Seagate Barracuda 7200rpm Case: Corsair Obsidian 750D Airflow (with upgraded USB-C front panel) Sound Card: EVGA Nu Audio Liquid Cooling parts: EK Supremacy Classic RGB AMD Nickel+Plexi, EK-XRES 140 Revo D5 RGB PWM (incl. pump), 2x EK 240mm PE radiator, EK Duraclear clear tubing

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×