Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Windows 10 causing Asus Rampage IV Extreme bluetooth adapter to stop working

Go to solution Solved by TheGamingBarrel,

You need to download this

eHtfgGL.png

From asus's website, here: http://www.asus.com/Motherboards/MAXIMUS_VI_EXTREME/HelpDesk_Download/

So I just did the whole upgrade process to windows 10, literally right before the upgrade I had my iphone connected to my computer via the bluetooth connection built into my Asus Rampage IV Extreme mobo.  When the upgrade process was completed it came up with a quick message saying something about bluetooth adapter not being supported.  I then went into the bluetooth connections menu and sure enough after a couple minutes of searching nothing came up...

 

Has anyone else ran into this issue yet? I downloaded and installed all the latest drivers off the Asus website, besides the bios drivers, to no avail.

 

Specs:

OS: Windows 10

mobo: Rampage IV Extreme

i7 3930K @ 4.5Ghz

2x 680 GTX in SLI

1x Samsung 840 Pro SSD

2x WD Caviar Black's in Raid 0

Link to comment
Share on other sites

Link to post
Share on other sites

That worked! Odd that that particular bluetooth driver does not show up under the Rampage IV Extreme drivers section though! Thanks for the help!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×