Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Any way to run my PS3 on PC monitor with sound and proper resolution

When connected with HDMI, the picture resolution is horrible. So I tried HDMI to DVI convertor. The resolution was normal and quality good but cant send sound to my monitor.
If I use the HDMI directly, the resolution is horrible but sound present.

Link to post
Share on other sites

change the settings in the ps3's config to 1080p for the hdmi connection..and probably the  aspect ratio to

If you need remote help fixing something on your computer

I can help over Teamviewer if you wish

just msg me on my profile

Link to post
Share on other sites

When connected with HDMI, the picture resolution is horrible. So I tried HDMI to DVI convertor. The resolution was normal and quality good but cant send sound to my monitor.

If I use the HDMI directly, the resolution is horrible but sound present.

Connect via HDMI and try going to Settings > Display settings > And I think from there you can select how the video goes out and after that the resolution it should have (tick 1080p only and otherwise 1080i only).

 

If that still doesn't work, you can try getting the audio via a different port. Your options are via the optical audio or the composite/component port to 3.5mm with something like this:

http://www.turtlebeach.com/product-detail/cables-parts/35mm-female-to-rca-stereo-splitter-cable/99

(That is what I use)

"We're all in this together, might as well be friends" Tom, Toonami.

Sorry if my post seemed rude, that is never my intention.

"Why do we suffer a lifetime for a moment of happiness?" - Anonymous

Link to post
Share on other sites

change the settings in the ps3's config to 1080p for the hdmi connection..and probably the  aspect ratio to

 

Connect via HDMI and try going to Settings > Display settings > And I think from there you can select how the video goes out and after that the resolution it should have (tick 1080p only and otherwise 1080i only).

 

If that still doesn't work, you can try getting the audio via a different port. Your options are via the optical audio or the composite/component port to 3.5mm with something like this:

http://www.turtlebeach.com/product-detail/cables-parts/35mm-female-to-rca-stereo-splitter-cable/99

(That is what I use)

It worked! :P

Thanks so much. I didn't even know PS3 had that settings.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×