Jump to content

Watch Dogs 30-32fps? seriously?

levsingh
 Share

Hey guys i have 2 r9 290x in crossfire, i7 4770k cpu, 8gb 2400mhz ddr3 still watchdogs at 30 fps ultra? i know the drivers are not optimized but cmon this is the latest version. 

Link to comment
Share on other sites

Link to post
Share on other sites

Everything is up to date? (AMD drivers)

"We're all in this together, might as well be friends" Tom, Toonami.

 

mini eLiXiVy: my open source 65% mechanical PCB, a build log, PCB anatomy and discussing open source licenses: https://linustechtips.com/topic/1366493-elixivy-a-65-mechanical-keyboard-build-log-pcb-anatomy-and-how-i-open-sourced-this-project/

 

mini_cardboard: a 4% keyboard build log and how keyboards workhttps://linustechtips.com/topic/1328547-mini_cardboard-a-4-keyboard-build-log-and-how-keyboards-work/

Link to comment
Share on other sites

Link to post
Share on other sites

Yep you got software issues somewhere no doubt.

 

My Single 290 does a lot better than that.

Maximums - Asus Z97-K /w i5 4690 Bclk @106.9Mhz * x39 = 4.17Ghz, 8GB of 2600Mhz DDR3,.. Gigabyte GTX970 G1-Gaming @ 1550Mhz

 

Link to comment
Share on other sites

Link to post
Share on other sites

watch dogs is a terrible port so your going to have to live with it for now

Spoiler

My system is the Dell Inspiron 15 5559 Microsoft Signature Edition

                         The Austrailian king of LTT said that I'm awesome and a funny guy. the greatest psu list known to man DDR3 ram guide

                                                                                                               i got 477 posts in my first 30 days on LinusTechTips.com

 

Link to comment
Share on other sites

Link to post
Share on other sites

Maybe components overheating causing downclocking?

“The value of a college education is not the learning of many facts but the training of the mind to think”

 

Link to comment
Share on other sites

Link to post
Share on other sites

Everything is up to date? (AMD drivers)

 

 

Yep you got software issues somewhere no doubt.

 

My Single 290 does a lot better than that.

nah everything is up to date, the drivers everything

Link to comment
Share on other sites

Link to post
Share on other sites

watch dogs is a terrible port so your going to have to live with it for now

Yet others have better performance... so its an actual ISSUE.

If it happened to everyone, games fault, but this is on HIS system while ours play it fine.

 

So its his system at fault somewhere, not the game.

 

High performance mode enabled in the power profiles within control panel?

Overclocked anything? If so go back to bios defaults.. you'd be surprised how often this fix's things.

ABSOLUTELY SURE that your Drivers are up to date?, what about the game pre-requisites like VCRedistx86/x64 and Directx (DXSetup.exe)?

Maximums - Asus Z97-K /w i5 4690 Bclk @106.9Mhz * x39 = 4.17Ghz, 8GB of 2600Mhz DDR3,.. Gigabyte GTX970 G1-Gaming @ 1550Mhz

 

Link to comment
Share on other sites

Link to post
Share on other sites

Maybe components overheating causing downclocking?

no both gpu's under 80 and cpu under 50

Link to comment
Share on other sites

Link to post
Share on other sites

Yet others have better performance... so its an actual ISSUE.

If it happened to everyone, games fault, but this is on HIS system while ours play it fine.

 

So its his system at fault somewhere, not the game.

ok 

Spoiler

My system is the Dell Inspiron 15 5559 Microsoft Signature Edition

                         The Austrailian king of LTT said that I'm awesome and a funny guy. the greatest psu list known to man DDR3 ram guide

                                                                                                               i got 477 posts in my first 30 days on LinusTechTips.com

 

Link to comment
Share on other sites

Link to post
Share on other sites

You can't see over 24fps anyways. /jk

 

 

What clock speeds do your gpu's go in game?

Gaming HTPC:

R7 1700X - Scythe Big Shuriken 3 - Asus ROG B350-i - Asus GTX 1080 Strix - 16gb G.Skill Ripjaws V 3333mhz - Silverstone SX500-LG - 500gb 960 EVO - Fractal Design Node 202 - Samsung 60KS7090 - Logitech G502 - Thrustmaster T500RS - Noblechairs Icon


Desktop PC:
R9 3900X - H100i GTX - Asus Prime X570 Pro - EVGA RTX2060KO - 32gb LPX 3200mhz - EVGA 750G2 - 250gb 970 Evo - 6TB WD My Book Duo (Reds) - Inwin 103 White - Dell U3415W - Qpad MK-85 Brown - Logitech MX518 Legendary - Blue Yeti Platinum - Noblechairs Icon 


Boss-NAS [Build Log]:
R5 2400G - Noctua NH-D14 - Asus Prime X370-Pro - 16gb G.Skill Aegis 3000mhz - Seasonic Focus Platinum 550W - Fractal Design R5 - 
250gb 970 Evo (OS) - 2x500gb 860 Evo (Raid0) - 6x4TB WD Red (RaidZ2)

 

Audio Gear:

Hifiman HE-400i - Kennerton Magister - Beyerdynamic DT880 250Ohm - AKG K7XX - Fostex TH-X00 - O2 Amp/DAC Combo - 
Klipsch RP280F - Klipsch RP160M - Klipsch RP440C - Yamaha RX-V479

 

Reviews and Stuff:

GTX 780 DCU2 // 8600GTS // Hifiman HE-400i // Kennerton Magister
Folding all the Proteins! // Boincerino

Useful Links:
Do you need an AMP/DAC? // Recommended Audio Gear // PSU Tier List 

Link to comment
Share on other sites

Link to post
Share on other sites

You can't see over 24fps anyways. /jk

 

 

What clock speeds do your gpu's go in game?

This. You can leave GPUZ open in background of game to keep tabs on it, or use MSI afterburner.

 

High performance mode enabled in the power profiles within control panel?

Overclocked anything? If so go back to bios defaults.. you'd be surprised how often this fix's things.

ABSOLUTELY SURE that your Drivers are up to date?, what about the game pre-requisites like VCRedistx86/x64 and Directx (DXSetup.exe)?

^Also this?

Maximums - Asus Z97-K /w i5 4690 Bclk @106.9Mhz * x39 = 4.17Ghz, 8GB of 2600Mhz DDR3,.. Gigabyte GTX970 G1-Gaming @ 1550Mhz

 

Link to comment
Share on other sites

Link to post
Share on other sites

could be crossfire issues, try turn it off? :)

GPU: MSI GTX 770 gaming || CPU: Intel 4670k @ 4.4Ghz || RAM: 4x4GB 1600mhz Corsair vengeance pro || MOBO: MSI Z87-GD65 Gaming || CPU cooler: Corsair H105 || PSU: Corsair RM650 || SSD: Samsung 840 EVO 120GB, Crucial M4 128GB || Case: Fractal Design Arc Midi R2 || Monitor: ASUS PA238Q

Link to comment
Share on other sites

Link to post
Share on other sites

Yet others have better performance... so its an actual ISSUE.

If it happened to everyone, games fault, but this is on HIS system while ours play it fine.

 

So its his system at fault somewhere, not the game.

 

High performance mode enabled in the power profiles within control panel?

Overclocked anything? If so go back to bios defaults.. you'd be surprised how often this fix's things.

ABSOLUTELY SURE that your Drivers are up to date?, what about the game pre-requisites like VCRedistx86/x64 and Directx (DXSetup.exe)?

no nothing with the power options in the control panel i left it as it was

and no they both run on stock clocks so no overclock

and for the drivers yes yesterday i downloaded the latest amd catalyst suite

but i don't have the beta version? should i download it?

Link to comment
Share on other sites

Link to post
Share on other sites

You can't see over 24fps anyways. /jk

 

 

What clock speeds do your gpu's go in game?

both go up to 1000 mhz cause i have disabled the vsync

Link to comment
Share on other sites

Link to post
Share on other sites

The latest 14.4 should do you right, thats what I'm using...

Only the one game WatchDogs?

Watch Dogs have a repair option within uplay?

Maybe its files on your machine have had something happen...

Maximums - Asus Z97-K /w i5 4690 Bclk @106.9Mhz * x39 = 4.17Ghz, 8GB of 2600Mhz DDR3,.. Gigabyte GTX970 G1-Gaming @ 1550Mhz

 

Link to comment
Share on other sites

Link to post
Share on other sites

Hey guys i have 2 r9 290x in crossfire, i7 4770k cpu, 8gb 2400mhz ddr3 still watchdogs at 30 fps ultra? i know the drivers are not optimized but cmon this is the latest version. 

Did u try to patch the GAME ITSELF????

Indus Monk = Indian+ Buddhist

Link to comment
Share on other sites

Link to post
Share on other sites

The latest 14.4 should do you right, thats what I'm using...

Only the one game WatchDogs?

Watch Dogs have a repair option within uplay?

Maybe its files on your machine have had something happen...

yeah it is 14.4 and yes i have repaired watchdogs but nothing changes

Link to comment
Share on other sites

Link to post
Share on other sites

no.

there should be some game patches available out there that may fix the problem.......these are official ubisoft patches, so check their website or some forums for these patches

Indus Monk = Indian+ Buddhist

Link to comment
Share on other sites

Link to post
Share on other sites

Make sure you have the latest patched version of the game, and make sure you have the latest beta drivers since those will have optimizations for watch_dogs, I believe the latest for AMD cards is catalyst version 14.7.

 

Another thing...

don't go above 3 max buffered frames and use temporal SMAA in the settings.  Unfortunately watch_dogs isn't a well optimized title and becomes very demanding at high resolutions, and/or with msaa cranked to 8x.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×