Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Logitech G230 - Microphone is extremely quiet. (Help?)

So my G230's have come in yesterday and they're awesome, so far.

The only problem I have is the microphone is really quiet. I can make them louder using microphone boost, although there would be an annoying background noise. (Uploaded the background noise as a file attachment.)

 

-I'm using the on-audio driver (Realtek HD Audio)

-Tried it on an Asus Xonar DGX sound card, same problem.

-Tried it on my laptop, same problem

-Tried the front port, same problem

-Tried 2 channel, 16 bit, 44100 Hz (CD Quality) all the way to 192000 Hz (Studio Quality)

-Contacted Logitech and no response as of yet

-All drivers are up-to-date

-Used Audacity, Skype, and 'Listen to this device', so it's not software.

-The background noise doesn't cut off when I talk

 

I don't want to return a second headset so hopefully one of you kind people know the solution.

background noise.wav

No images? Worst. Signature. Ever.

Link to post
Share on other sites

I had this problem with mine, this is what I did to make it a little better (but not turn it into a great mic):

  1. Go over to your sound settings and click on the recording devices section.
  2. Find your device and click on properties
  3. Go to the advanced section and change the quality to DVD quality and click OK
  4. Go back to properties and go to the enhancements section, enable acoustic echo cancellation, you may want to experiment with noise suppression
  5. Now go to levels and bring the volume all the way up, experiment with different microphone boost levels until you find a good volume
  6. When you're done changing these settings click OK, then once again return to properties
  7. Go over to advanced again and change the quality to the maximum (192000 Hz Studio Quality) and click OK

Now just keep in mind the G230 microphone is pretty terrible so don't expect excellent sound quality. I've decided to keep noise suppression off because it messes around with my voice and I feel the background noise isn't as bad as having my voice distorted.

i5-4670k @4.2GHz Sapphire Tri-X R9 290 @1135MHz 1600MHz G.Skill RipjawsX 8GB Samsung 840 EVO 120GB Samsung 850 EVO 250GB


Corsair K70 Logitech G502 Proteus Core Logitech G230 Blue Snowball SteelSeries QcK+


YouTube // Steam // Twitter // Facebook // Google+

Link to post
Share on other sites

I had this problem with mine, this is what I did to make it a little better (but not turn it into a great mic):

  1. Go over to your sound settings and click on the recording devices section.
  2. Find your device and click on properties
  3. Go to the advanced section and change the quality to DVD quality and click OK
  4. Go back to properties and go to the enhancements section, enable acoustic echo cancellation, you may want to experiment with noise suppression
  5. Now go to levels and bring the volume all the way up, experiment with different microphone boost levels until you find a good volume
  6. When you're done changing these settings click OK, then once again return to properties
  7. Go over to advanced again and change the quality to the maximum (192000 Hz Studio Quality) and click OK

Now just keep in mind the G230 microphone is pretty terrible so don't expect excellent sound quality. I've decided to keep noise suppression off because it messes around with my voice and I feel the background noise isn't as bad as having my voice distorted.

Hmm, that didn't help at all although it helped me learn some things.

For example, there's background noise only at 96000 Hz and up. Anything lower than that, my voice sounds like it's from a laptop microphone.

 

edit:

at 10 dB boost, there's very little background noise but I'm still too quiet for my liking. At 20 dB boost, my voice volume is perfect but the background noise got louder as well.

No images? Worst. Signature. Ever.

Link to post
Share on other sites

I'm not sure if this will help but try going to Realtek HD Audio Manager and click on your mic, then go to the advanced settings and check "Separate all input jacks as independent input devices"

i5-4670k @4.2GHz Sapphire Tri-X R9 290 @1135MHz 1600MHz G.Skill RipjawsX 8GB Samsung 840 EVO 120GB Samsung 850 EVO 250GB


Corsair K70 Logitech G502 Proteus Core Logitech G230 Blue Snowball SteelSeries QcK+


YouTube // Steam // Twitter // Facebook // Google+

Link to post
Share on other sites

I'm not sure if this will help but try going to Realtek HD Audio Manager and click on your mic, then go to the advanced settings and check "Separate all input jacks as independent input devices"

Yeah, I tried that before. It actually made it kind of worse.

I heard the 7.1 adapter fixes the problem, but if I wanted to shell out an extra $20-30, I would've gotten the G430s.

No images? Worst. Signature. Ever.

Link to post
Share on other sites
  • 2 years later...

1. Go over to your sound settings and click on the recording devices section.

2. Find your device and click on properties

3. Locate enhancements tab

4a. If you have a button that says "Disable All Sound Effects," press it.

4b. If you have a drop down or list of stuff, find noise cancellation and disable it.

Link to post
Share on other sites
  • 4 months later...

Not sure if this will help, but it worked for my mic pickup with the same set:

 

Using the 2 channel just set to DVD quality, you can go to:

 

1. Recording

2. Properties

3. Levels

 

Under which I was able to boost the mic pickup and that solved the problem for me!

 

Hope this helps.

Link to post
Share on other sites
  • 1 year later...

Hopefully this helps others, since this was the first result I found on Google.  Turn off the "DC Offset Cancellation" in the enhancements tab.  Click OK, then unplug and replug your mic to restart it.  It reduces the background static to almost nothing, then you can set the mic levels appropriately.  It's a nice mic after that. 

 

Edit:  There seams to be a bug in the Realtek audio setup.  If the DC offset on my machine is unchecked, it actually works (I can hear the static eventually drop if I increase the input level.).  Any case, experiment with that setting.  Remember to unplug and replug your mic to make it set. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×