Jump to content

Ways to get more display outputs?

Promethus

Hello all, I'm trying to find a way to plug in my third monitor again so let me explain why. I typically have a 3 monitor setup. I bought the ASUS PG27AQN, its 1440p 360hz with G-Sync. Because of that resolution and refresh rate it requires DSC over Displayport 1.4. If I max out the display, meaning full 1440p 360hz G-Sync all turned on, I will eventually get a black screen flicker or straight up permanent black screen when trying to play games. I could make it go away if I turned off DSC which maxed out at 1440p 240hz so I knew it was some combination of G-Sync, DSC, and the maxed out 360hz causing it. For a while I thought the monitor was the issue but I read somewhere about DSC disabling Displayport headers to work so I tried unplugging my third monitor which is the one also plugged into Displayport. After that I've had no issues with the 1440p 360hz one. Plug the third monitor back in to a Displayport on the GPU, issues come back. The second monitor is plugged in via HDMI and has no effect. So I've narrowed it down to even though I have 3 Displayport ports on my GPU; I cannot use more than one if I want to use the full settings on my PG27AQN because of DSC.

What are the best ways to get more connectivity? If there are any good ones. I've looked into a second, budget GPU just for the ports but I've read there are issues with that with how Windows manages it and it can cause weird things when playing games in windowed borderless or not exclusive fullscreen. My current GPU only has one HDMI port, so just using another HDMI for the third isn't an option. Ryzen 5000 doesn't have display capabilities so that is not an option. USB hub? Try the second GPU anyways? Any opinions or ideas? Thanks!

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, tkitch said:

can you give us anything about what you're running?

 

Sure thing. RTX 3080 with 1x HDMI and 3x DisplayPort ports. Ryzen 5900x so no internal graphics in a Gigabyte X570 Aorus Master motherboard. Three 1440p monitors: 144hz, 360hz (only one that needs DSC), 75hz.

Link to comment
Share on other sites

Link to post
Share on other sites

I currently don't have a monitor with DSC yet but I do have second GPU to display my "fifth" monitor (honestly using it more as a sound card to my AVR). My main GPU is AMD 6900XT and secondary GPU is Nvidia GT 710. 

 

In most situations when gaming it's working fine. Freesync is working well and there are no hiccups in performance and frametime. 

 

But then I said most situations, and had came across some issues I can think of. 

- Forza Horizon 3 prefers my GT 710 no matter what, even if the display is disabled. I had to disable on device manager or physically remove Nvidia card to force the game run on AMD card. 

- AIDA64 sensorpanel couldn't display full specs for my main GPU so I had to resort to alternative program called InfoPanel.

- Certain mod for certain game (prefer not to say which) causing huge lag when moving mouse around. Disabling the display fixes the issue. 

 

So depending what you do, if you choose to get second GPU, it may work for you but also may come across some niche issues eventually. 

PC spec: CPU: RYZEN 9 5950X | GPU: SAPPHIRE NITRO+ SE AMD RADEON 6900XT (Undervolt to 1045mV) | MB: MSI MAG TOMAHAWK x570 RAM: G.SKILL TRIDENT Z NEO 32GB (2x16GB) DDR4-3600 (OC to 3800 14-15-15-25) COOLING: NOCTUA NH-D15, BE QUIET! SILENT WINGS 120 & 140mm| CASE: IN-WIN 707 | 5.25" BAY: LG WH16NS60 INTERNAL BLU-RAY OPTICAL DRIVE | PSU: SEASONIC PRIME PLATINUM 1000WUPS: POWERSHIELD COMMANDER TOWER 1100VA

PERIPHERALS: KEYBOARD: CORSAIR K95 PLATINUM XT BROWN SWITCH | MOUSE: CORSAIR SABRE PRO WIRELESS | CONTROLLER: PDP AFTERGLOW WIRED CONTROLLER, DUALSENSE
DISPLAYS: LG 34GN8502x DELL S2721DGF | LG C1 48" 

HT & audio stuff:  AVR: MARANTZ SR7013 | STEREO AMPLIFIER: YAMAHA AS-501 | SPEAKERS: DALI OBERON 7 & DALI ZENSOR 1 & 2x SVS-SB2000 | HEADPHONE DAC+AMP: TOPPING L30+E30 | HEADPHONE: SENNHEISER HD6XX, BOSE QUIETCOMFORT 35 II | MICROPHONE: AUDIO-TECHNICA AT9934USB | BLU-RAY PLAYER: PANASONIC UB820

Link to comment
Share on other sites

Link to post
Share on other sites

17 hours ago, BuzzingBee said:

I currently don't have a monitor with DSC yet but I do have second GPU to display my "fifth" monitor (honestly using it more as a sound card to my AVR). My main GPU is AMD 6900XT and secondary GPU is Nvidia GT 710. 

 

In most situations when gaming it's working fine. Freesync is working well and there are no hiccups in performance and frametime. 

 

But then I said most situations, and had came across some issues I can think of. 

- Forza Horizon 3 prefers my GT 710 no matter what, even if the display is disabled. I had to disable on device manager or physically remove Nvidia card to force the game run on AMD card. 

- AIDA64 sensorpanel couldn't display full specs for my main GPU so I had to resort to alternative program called InfoPanel.

- Certain mod for certain game (prefer not to say which) causing huge lag when moving mouse around. Disabling the display fixes the issue. 

 

So depending what you do, if you choose to get second GPU, it may work for you but also may come across some niche issues eventually. 

I was trying to avoid the weirdness that comes with a second GPU but the more I look into this it might be the best option still. Do they still make cards like the 710? A modern, sub-100 card just for more displays for like office PCs?

Link to comment
Share on other sites

Link to post
Share on other sites

5 hours ago, Promethus said:

I was trying to avoid the weirdness that comes with a second GPU but the more I look into this it might be the best option still. Do they still make cards like the 710? A modern, sub-100 card just for more displays for like office PCs?

You should definitely get different GPU brand to avoid drivers conflict so you'll need to look at AMD side.

 

R7 240 is basically AMD's version of GT 710, but if you want something better then I suppose it's RX 550 or RX 6400 for more modern. 

PC spec: CPU: RYZEN 9 5950X | GPU: SAPPHIRE NITRO+ SE AMD RADEON 6900XT (Undervolt to 1045mV) | MB: MSI MAG TOMAHAWK x570 RAM: G.SKILL TRIDENT Z NEO 32GB (2x16GB) DDR4-3600 (OC to 3800 14-15-15-25) COOLING: NOCTUA NH-D15, BE QUIET! SILENT WINGS 120 & 140mm| CASE: IN-WIN 707 | 5.25" BAY: LG WH16NS60 INTERNAL BLU-RAY OPTICAL DRIVE | PSU: SEASONIC PRIME PLATINUM 1000WUPS: POWERSHIELD COMMANDER TOWER 1100VA

PERIPHERALS: KEYBOARD: CORSAIR K95 PLATINUM XT BROWN SWITCH | MOUSE: CORSAIR SABRE PRO WIRELESS | CONTROLLER: PDP AFTERGLOW WIRED CONTROLLER, DUALSENSE
DISPLAYS: LG 34GN8502x DELL S2721DGF | LG C1 48" 

HT & audio stuff:  AVR: MARANTZ SR7013 | STEREO AMPLIFIER: YAMAHA AS-501 | SPEAKERS: DALI OBERON 7 & DALI ZENSOR 1 & 2x SVS-SB2000 | HEADPHONE DAC+AMP: TOPPING L30+E30 | HEADPHONE: SENNHEISER HD6XX, BOSE QUIETCOMFORT 35 II | MICROPHONE: AUDIO-TECHNICA AT9934USB | BLU-RAY PLAYER: PANASONIC UB820

Link to comment
Share on other sites

Link to post
Share on other sites

Welp. Scratch everything in this thread and going back to square one. I just discovered that I my PG27AQN was set to 120hz, probably from the last time I moved the displayport plugs around reset its settings. So I haven't been at 360hz for the past two weeks where I thought I had "solved" the issue by removing one monitor. I set it back to 360hz and the black screens came back immediately.

Link to comment
Share on other sites

Link to post
Share on other sites

4 hours ago, Promethus said:

Welp. Scratch everything in this thread and going back to square one. I just discovered that I my PG27AQN was set to 120hz, probably from the last time I moved the displayport plugs around reset its settings. So I haven't been at 360hz for the past two weeks where I thought I had "solved" the issue by removing one monitor. I set it back to 360hz and the black screens came back immediately.

Might need to try another DP cable

PC spec: CPU: RYZEN 9 5950X | GPU: SAPPHIRE NITRO+ SE AMD RADEON 6900XT (Undervolt to 1045mV) | MB: MSI MAG TOMAHAWK x570 RAM: G.SKILL TRIDENT Z NEO 32GB (2x16GB) DDR4-3600 (OC to 3800 14-15-15-25) COOLING: NOCTUA NH-D15, BE QUIET! SILENT WINGS 120 & 140mm| CASE: IN-WIN 707 | 5.25" BAY: LG WH16NS60 INTERNAL BLU-RAY OPTICAL DRIVE | PSU: SEASONIC PRIME PLATINUM 1000WUPS: POWERSHIELD COMMANDER TOWER 1100VA

PERIPHERALS: KEYBOARD: CORSAIR K95 PLATINUM XT BROWN SWITCH | MOUSE: CORSAIR SABRE PRO WIRELESS | CONTROLLER: PDP AFTERGLOW WIRED CONTROLLER, DUALSENSE
DISPLAYS: LG 34GN8502x DELL S2721DGF | LG C1 48" 

HT & audio stuff:  AVR: MARANTZ SR7013 | STEREO AMPLIFIER: YAMAHA AS-501 | SPEAKERS: DALI OBERON 7 & DALI ZENSOR 1 & 2x SVS-SB2000 | HEADPHONE DAC+AMP: TOPPING L30+E30 | HEADPHONE: SENNHEISER HD6XX, BOSE QUIETCOMFORT 35 II | MICROPHONE: AUDIO-TECHNICA AT9934USB | BLU-RAY PLAYER: PANASONIC UB820

Link to comment
Share on other sites

Link to post
Share on other sites

8 hours ago, BuzzingBee said:

Might need to try another DP cable

I've been through 3 different ones, including Infinite Cables and a separate VESA certified DP2.1.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×