Jump to content

ASUS PRIME X570-P - integrated soundchip not working?

finn12

So, I bought this board as used and otherwise it seems to work fine but I can't get no sound from rear 3.5mm ports. I have tried installing official drivers from ASUS website and then some from Realtek's but nothing changes. The soundchip is not listed at all in Device Manager and Ubuntu cannot find any sound devices, when entering lspci it doesn't show anything Realtek sound related.

 

Is the chip simply damaged?

Link to comment
Share on other sites

Link to post
Share on other sites

Yeah it happens quite frequently. I even ordered 5x replacement codecs from aliexpress just because it has happened to me more than once. Sadly, its not a repair that can be done at home if you dont own an SMD hot air station and have experience.

mY sYsTeM iS Not pErfoRmInG aS gOOd As I sAW oN yOuTuBe. WhA t IS a GoOd FaN CuRVe??!!? wHat aRe tEh GoOd OvERclok SeTTinGS FoR My CaRd??  HoW CaN I foRcE my GpU to uSe 1o0%? BuT WiLL i HaVE Bo0tllEnEcKs? RyZEN dOeS NoT peRfORm BetTer wItH HiGhER sPEED RaM!!dId i WiN teH SiLiCON LotTerrYyOu ShoUlD dEsHrOuD uR GPUmy SYstEm iS UNDerPerforMiNg iN WarzONEcan mY Pc Run WiNdOwS 11 ?woUld BaKInG MY GRaPHics card fIX it? MultimETeR TeSTiNG!! aMd'S GpU DrIvErS aRe as goOD aS NviDia's YOU SHoUlD oVERCloCk yOUR ramS To 5000C18

Link to comment
Share on other sites

Link to post
Share on other sites

Seller has already promised to take this back and cancel the deal.

 

However this was not bought from eBay which has excellent buyer protection but from a much smaller auction site, they do promise buyer protection but I have only 24h to test after which seller gets money if I don't dispute deal...

 

I guess I'm about to test that buyer protection, never had to before.

Link to comment
Share on other sites

Link to post
Share on other sites

Today I did fresh install of Windows 10 to my spare SSD. After installation I downloaded and installed AMD Chipset drivers and Realtek Audio drivers. Windows installed drivers for my test Nvidia card itself.

 

After all this only Nvidia HDMI is shown under sound devices, plugging in headphones to speaker jack does nothing, no reaction. If I want to try sound troubleshooting Windows only offers me Nvidia HDMI as option to be troubleshooted.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×