Jump to content

Q-led d-ram always on | no post

My build:

  • Mobo: Asus Rog Strix B550-F Gaming WiFi II
  • CPU: Ryzen 7 5800X
  • RAM: Corsair Vengeance RGB Pro SL 32GB (2x16gb) 3600mHz C18
  • GPU: RTX 3070 Ventus 3x 
  • PSU:Corsair RM850

HI, I still don’t know what really happened, it seemed like a power surge or an outage. As the title of the post says, I’m encountering a problem with my build, the q-led for the d-ram (most of the times, when I power on my pc stays on without post, and sometimes it goes from orange (d-ram), red (cpu) and stays on white (vga) always without post [this happens only with one slot of ram].

Searching on the internet, I tried everything that I could try, here’s a list of what I did:

  • Removed and re-connected all the cables;
  • Removed and reconnected all the parts;
  • Removed the battery of the mobo;
  • Started without the battery;
  • Changed the battery;
  • Reset the CMOS;
  • Updated the bios through the bios flashback;
  • Started the pc with only one slot of ram (it I power it on and off continuously sometimes it pass the orange q-led, but still no post, going into the red q-led and then the white one, but still, again, no post.
  • It could also happen that sometime, when both rams are installed, it goes from orange to red and then all the q-leds turns off and doesn’t boot.

With all those things nothing gave me a screen boot, always no signal on the monitor.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×