Jump to content

Unstable Gpu Usage

tonv
Go to solution Solved by YoungBlade,

The fact that you're running 8GB of single channel memory is likely the main problem. You're already CPU limited, and piling single channel RAM on top of that is not helping. Additionally, Fortnite is very memory hungry - it really needs at least 16GB to run smoothly.

Hello, My gpu usage is not consistent, It keeps going up and down. It goes 99%-100% for 2-3sec then it goes back down to 30%-50% and sometimes It goes to 0%. It's casuing major fps drops and stutters.I already tried ddu and installed the Latest Amd Drivers but this is still happening. The tempreatures are not that high too. I'm not sure what's causing this issue. Does anyone know how to fix this?
Cpu : i3-9100
Gpu: Sapphire Nitro+ Rx 580 8gb
Ram: Crucial Basics 8gb 2666mhz(1x)
Mobo: Gigabyte H310m d2vx si 2.0
https://medal.tv/games/fortnite/clips/1I478XqPsv0pDR/d1337cuFrLlC?invite=cr-MSx5QlEsNjkzNjI0NTIs

Link to comment
Share on other sites

Link to post
Share on other sites

That's MSI Afterburner misreporting.

 

You need to enable unified GPU usage reporting in the MSI AB settings.

Radical Radeon: 5800X3D . 32GB CL14 3800 . Asrock Extreme 4 . RX 7900 XT . Silicon Power 4TB SATA + Crucial P5 2TB NVME . Enermax Revolution D.F 850W . Corsair Obsidian 1000D

Interface: Coolermaster CK-270 + XTRFY MZ1 . Astroo A40 + Mixamp Pro . Wharfdale Diamond 11.0 + SMSL A300

Displays: Zowie XL2746S 240hz Dyac+ (182hz 1350VT / perfect motion clarity) . Viewsonic XG270 165hz VA . LG 4K 60hz 27UL550P

Software: Windows 11 Pro . Kaspersky AV, Mullvad, Lightshot, LibreOffice, GIMP, Davinici Resolve  + Linux Fedora (Gaming)

 

 

Link to comment
Share on other sites

Link to post
Share on other sites

Done that. It's showing much stable now 40%-50% but fps drops are still happening, I am using low preset now but getting around almost the same fps as medium preset. The gpu usage is going down to 20% when fps drops. The gpu utilization is 50% while cpu utilization is 100%. I searched online and these two works great together. Not sure what's happening.
https://medal.tv/games/fortnite/clips/1I4ELMDfbcDCtr/d13377Jep7lD?invite=cr-MSxGRGYsNjkzNjI0NTIs

Link to comment
Share on other sites

Link to post
Share on other sites

The fact that you're running 8GB of single channel memory is likely the main problem. You're already CPU limited, and piling single channel RAM on top of that is not helping. Additionally, Fortnite is very memory hungry - it really needs at least 16GB to run smoothly.

Link to comment
Share on other sites

Link to post
Share on other sites

will dual channels work? I mean will I get above 70fps, 2x 8gb?

Link to comment
Share on other sites

Link to post
Share on other sites

8 minutes ago, tonv said:

will dual channels work? I mean will I get above 70fps, 2x 8gb?

Assuming clips like this are genuine, you should be able to get above 70fps, yes. You may also need to switch to Performance mode - I don't know if that also improves performance when CPU limited, but it might be required to get the performance shown there.

 

Link to comment
Share on other sites

Link to post
Share on other sites

alright, I really appreciate your help. Thank you the info

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×