Jump to content

Stuttering w/ Good Specs

ItsJusSean

So I recently upgraded my pc to Windows 11 and the hardware in it. I don’t know if this is the cause of the issue or what, but some games start stuttering badly when I am playing them like Fortnite, or Ghost Recon Breakpoint. In most games I haven’t had issues with frame stuttering but these 2 games are prevalent. I haven’t noticed any stutter in other games like Apex Legends, Batman Arkham Knight, Counter Strike 2, and Overwatch 2. I updated chipset and GPU drivers when I installed my new CPU and RAM. 
 

Here are my PC Specs:

GPU: RTX 3070

CPU: Ryzen 9 5900x

RAM: Corsair Vengeance 32GB 3600MHz (but running at 3200MHz because of motherboard limitations)

Motherboard: Gigabyte A320M-S2H (bios version F56f)

PSU: Corsair RM 750W 80+ Gold

OS: Windows 11 (updated 4 days ago)

 

Link to comment
Share on other sites

Link to post
Share on other sites

Try running your cpu at a lower clockspeed. That poor motherboard isn't made to handle stuff beyond a 6 core. A 5900x is most likely severly overheating that power delivery and causing power issues.

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, jaslion said:

Try running your cpu at a lower clockspeed. That poor motherboard isn't made to handle stuff beyond a 6 core. A 5900x is most likely severly overheating that power delivery and causing power issues.

What clockspeed do you recommend I should run my CPU at? 

Link to comment
Share on other sites

Link to post
Share on other sites

Instead of lowering your clock speed you could set a PPT limit, and you could also undervolt to regain some performance. It's pretty easy to do in Ryzen Master. The PPT is roughly the max power the CPU will run at, and I would probably set it to 85 first and see what happens.

 

 

image.thumb.png.9175b02442583736578c7544d98bc993.png

Link to comment
Share on other sites

Link to post
Share on other sites

36 minutes ago, jaslion said:

Try running your cpu at a lower clockspeed. That poor motherboard isn't made to handle stuff beyond a 6 core. A 5900x is most likely severly overheating that power delivery and causing power issues.

Can also try pointing a fan at the VRM first, that will often let shoddy VRM setups punch a bit above their weight class. I'd try that before reducing clocks. 

Intel HEDT and Server platform enthusiasts: Intel HEDT Xeon/i7 Megathread 

 

Main PC 

CPU: i9 7980XE @4.5GHz/1.22v/-2 AVX offset 

Cooler: EKWB Supremacy Block - custom loop w/360mm +280mm rads 

Motherboard: EVGA X299 Dark 

RAM:4x8GB HyperX Predator DDR4 @3200Mhz CL16 

GPU: Nvidia FE 2060 Super/Corsair HydroX 2070 FE block 

Storage:  1TB MP34 + 1TB 970 Evo + 500GB Atom30 + 250GB 960 Evo 

Optical Drives: LG WH14NS40 

PSU: EVGA 1600W T2 

Case & Fans: Corsair 750D Airflow - 3x Noctua iPPC NF-F12 + 4x Noctua iPPC NF-A14 PWM 

OS: Windows 11

 

Display: LG 27UK650-W (4K 60Hz IPS panel)

Mouse: EVGA X17

Keyboard: Corsair K55 RGB

 

Mobile/Work Devices: 2020 M1 MacBook Air (work computer) - iPhone 13 Pro Max - Apple Watch S3

 

Other Misc Devices: iPod Video (Gen 5.5E, 128GB SD card swap, running Rockbox), Nintendo Switch

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, NikolakiH said:

Instead of lowering your clock speed you could set a PPT limit, and you could also undervolt to regain some performance. It's pretty easy to do in Ryzen Master. The PPT is roughly the max power the CPU will run at, and I would probably set it to 85 first and see what happens.

 

 

image.thumb.png.9175b02442583736578c7544d98bc993.png

I don't think I can do this sadly, the A320 chipsets does not allow for overclocking which means I can't change any of these settings. So I guess its time to find a compatible motherboard.

RyzenMaster.png

A320Chipset.png

Link to comment
Share on other sites

Link to post
Share on other sites

Oh wow, talk about forbidden love, lol.

That CPU and motherboard were never meant to see each other.

 

Even if you can't install Ryzen Master, you can still control the clock speed through the BIOS, if I'm not mistaken. Although, frankly speaking, you are better off buying a better motherbord.

 

Qoute my reply if you want me to answer back. 

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×