Jump to content

One of my SSDs is not completely accessible to software unless in admin mode?

Haveri

Hey guys,

I have two external SSD drives. On the first one I installed a few plugins which I use inside Cubase (audio software), and the interaction with those plugins is being weird, in one of the plugin I constantly receive a message that I don't have the required permission to access that SSD drive. With another plugin it's all buggy. When I move those plugins into the other SSD, it all works fine. The other solution - to run Cubase as administrator (but that creates other unrelated problems so it's not really a solution).

 

The first problematic SSD is Samsung 870 EVO, originally internal but being used as external with a container and USB connector. The second (not problematic) is an external Samsung T7.


Does anyone know why those permission issues occur with the Samsung 870 EVO?

(I'm on Windows 11, both SSDs are formatted in NTFS)

P.S I see that every folder, in both SSDs, is checked with "read only". If I uncheck and apply, it remains the same, don't know if it's relevant
Thanks a lot in advance everyoen

 

Link to comment
Share on other sites

Link to post
Share on other sites

3 minutes ago, whispous said:

Was this problematic drive once a C: drive with a Windows installation on it?

No, never

Link to comment
Share on other sites

Link to post
Share on other sites

Does the issue persist in Cubase if you install the plugin (following installation instructions, not just moving the files) to the C drive instead?

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, whispous said:

Does the issue persist in Cubase if you install the plugin (following installation instructions, not just moving the files) to the C drive instead?

Yes, I didn't really expand on this to make it shorter, sorry if it caused any confusion, but the plugins are installed on drive C:. What I move from one SSD to another is the actual content the library/plugin is using (big sound files).
In the case of those plugins, you can just move that content folders to another location and then update the new path when launching the plugins.

So, when moving the content to the other SSD, the plugins will work just fine, and when the content is on the problematic drive, I must start Cubase as administrator to have the plugins work fine, otherwise one plugin will complain there's no permission to read the content, and another one will misbehave and become buggy...

Thanks

Link to comment
Share on other sites

Link to post
Share on other sites

I would back up all the data, format the drive, and copy the contents back one folder at a time - each time setting full read-write permissions for your user account

Link to comment
Share on other sites

Link to post
Share on other sites

9 minutes ago, whispous said:

I would back up all the data, format the drive, and copy the contents back one folder at a time - each time setting full read-write permissions for your user account

Thanks, how should I set full read-write permissions for my user account each time please? Do you think formatting is necessary compared to just to copying the content back (after deleting it), while setting full read-write permissions?

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Haveri said:

Thanks, how should I set full read-write permissions for my user account each time please? Do you think formatting is necessary compared to just to copying the content back (after deleting it), while setting full read-write permissions?

I do think it's neccessary to format it, yes.

 

image.thumb.png.89d911f79ad28d7f22890aa75195aa33.png

 

Here's me looking at properties > Security > Edit... of folder "edit from"

 

In this case, if I were you, i'd select group "Users" and tick ALL of the boxes beneath allow - typically the "full control" one will do this, then apply it.

Link to comment
Share on other sites

Link to post
Share on other sites

37 minutes ago, whispous said:

I do think it's neccessary to format it, yes.

 

image.thumb.png.89d911f79ad28d7f22890aa75195aa33.png

 

Here's me looking at properties > Security > Edit... of folder "edit from"

 

In this case, if I were you, i'd select group "Users" and tick ALL of the boxes beneath allow - typically the "full control" one will do this, then apply it.

I see ok will try that thanks a lot!

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×