Jump to content

Samsung G9 does not let windows enter standby


Hello there


After fiddling around for over a year I think you guys are my last hope to get this sorted.


I have a Samsung C49RG90SSUXEN Monitor connected via Displayport to my PC.

Whenever the PC tries to enter standby the monitor turns off and right back on, so does windows.

Effectively never entering Standby and slowly abusing my new Display.


I tried removing all USB Devices and turned off all usb powersaving in the device manager.


In the end I found out, that disconnecting the Samsung solves the problem.
I have two monitors connected, a touchpanel via DVI and the Samsung via DP.


If I just leave the DVI the Computer enters standby correctly. If I only connect the Samsung it does not work anymore.


System Info:
Asus GTX970 Strix
CPU Intel I7 4790k

Motherboard Asus Z97 Pro Wifi AC

I updated Windows as well as Nvidia Drivers.
Also the Monitor has the newest Firmware.

I do not use the USB Hub on the monitor.

I contacted Samsung Support but they couldn't help either.
Tried all DP Versions in the OSD, disabled Input Switching, tried DP2 on the Monitor, disable all ECO Timers etc...

I also updated the DP Firmware with the nvidia tool: https://www.nvidia.com/en-us/drivers/nv-uefi-update-x64/

I have attached a Video of the phenomen.


Maybe one of you guys has an idea... If I forgot something, let me know...
Thank you!

Link to comment
Share on other sites

Link to post
Share on other sites

I would try disabling Multiplane Overlay MPO.

  • Main PC: AMD Ryzen 9 5900X - EK AIO 360 D-RGB - Arctic Cooling MX-4 - Asus Prime X570-P - 4x8GB DDR4 3200 HyperX Fury CL16 - Sapphire AMD Radeon 6950XT Nitro+ - 1TB Kingston Fury Renegade - 1TB ADATA SX 6000pro  - 512GB ADATA SU800 - 1TB Seagate Momentus 5400rpm 2.5" - Seasonic PX-850 850W  - custom black ATX and EPS cables - Fractal Design Define R5 Blackout - Windows 11 x64 2022 - 3 Arctic Cooling P14 PWM PST - 5 Arctic Cooling P12 PWM PST
  • Peripherals: LG 32GK650F - Philips 226VL - Logitech G Pro X Superlight with Tiger Ice - White Shark Spartan X (TKL) - EndGame Gear MPC890 - Genius HF 1250B - Akliam PD4 - Sennheiser HD 560s - Truthear Zero - QKZ x HBB - 7Hz Salnotes Zero - Logitech C270 - Behringer PS400 - BM700  - Colormunki Smile - Speedlink Torid - Jysk Stenderup - LG 24x External DVD writer - Konig smart card reader
  • Laptop: Acer E5–575G-386R 15.6" 1080p (i3 6100U + 2x4GB DDR4 + GeForce 940MX + 256GB nVME) Win 10 Pro x64 22H2 - Logitech G305 + AAA Lithium battery
  • Networking: Asus RT-N18U - SpeedPort Plus - 35/7 Mbps vDSL - TP-Link TL-WA850RE - TP-Link 5-port 1Gbps switch
  • TV and gadgets: TCL 50EP680 50" 4K LED + Sharp HT-SB100 75W RMS - Samsung Galaxy Tab A8 10.1" - OnePlus 9 256GB - Olymous Cameda C-160 - GameBoy Color 
  • Streaming/Server/Storage PC: AMD Ryzen 5 3600 - LC-Power LC-CC-120 - MSI B450 Tomahawk Max - 2x4GB ADATA 2666 DDR4 - 120GB Kingston V300 - Toshiba DT01ACA100 1TB - Toshiba DT01ACA200 2TB - 2x WD Green 2TB - Sapphire Pulse AMD Radeon RX 5700XT - 550W EVGA G3 SuperNova - Chieftec Giga DF-01B - Logitech G710+ - Roccat Kone Pure Military Desert strike - Logitech S-220
Link to comment
Share on other sites

Link to post
Share on other sites

On 3/28/2023 at 10:46 AM, 191x7 said:

I would try disabling Multiplane Overlay MPO.

Tried it now.

Causes weird graphical glitches after startup and does not fix the standby problem, sadly.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now