Jump to content

Discord drops memory clock by 200MHz

SephiRock
Go to solution Solved by SephiRock,
1 hour ago, LloydLynx said:

See if disabling hardware acceleration in Discord fixes it. 

As i said, i already tried that. I appreciate the effort tho, thank you.

But it appears i found a fix ! This seems to be on discord side, and dependant on the build you have installed on your PC. First i contacted discord, they told me to try the PTB version, which didn't help.

So, following some instructions a person posted on discord, i managed to fix it ! Here's how :

 

You need to download nvidiaprofileinspector on github. In there, type "discord" in the search bar so you have access to the the app's drivers settings. There, you need to find the line CUDA - Force P2 State and set it to Off. Click on Apply changes on the top-right corner, close nvidia profile inspector, restart Discord and you should be good to go !!

Hello,

 

I have an RTX 3060 Ti (LHR) and i realized recently that, when discord is open, the memory clock on my GPU takes a flat -200Mhz. It's supposed to reach 7000MHz, and it does, as long as discord isn't open. When it is, it drops at 6800MHz.
It's quite annoying because i use discord a lot, and i don't want it to just eat performances while i'm not doing anything.
I tried disabling the hardware acceleration, uninstalled nvidia broadcast, tried unchecking every option in the voice settings one by one, also updated my nvidia drivers, nothing worked.
Anybody has an idea on how to solve this ?

 

Thanks a lot

Link to comment
Share on other sites

Link to post
Share on other sites

What happens if you open a game or some gpu benchmark at the same time as discord? 

Is it still locked at 200?

Link to comment
Share on other sites

Link to post
Share on other sites

not sure on a solution yet.  I've tested this on my 2070 Super and I'm getting the same thing.  Might be something discord specific in the driver that does it for stability reasons or something.

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Cupcakez said:

What happens if you open a game or some gpu benchmark at the same time as discord? 

Is it still locked at 200?

OP says, and I've tested, it drops to 6800MHz when discord is open.  Instead of the rated 7000

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

1 minute ago, Cupcakez said:

What happens if you open a game or some gpu benchmark at the same time as discord? 

Is it still locked at 200?

Yes, i opened Furmark and let it run while checking the clocks with discord open. Same thing sadly

Link to comment
Share on other sites

Link to post
Share on other sites

interesting find OP 

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

Try disabling the discord overlay. 

Notnsure how that could cause this problem, but a few years ago discord overlay would crash my games so... Maybe its gonna help somehow? 

Link to comment
Share on other sites

Link to post
Share on other sites

Just now, Cupcakez said:

Try disabling the discord overlay. 

Notnsure how that could cause this problem, but a few years ago discord overlay would crash my games so... Maybe its gonna help somehow? 

Sadly, discord overlay has been disabled from the beginning on my system.
Thank you for your suggestion tho

Link to comment
Share on other sites

Link to post
Share on other sites

When Discord is open it drops Vram speed, is that what you're saying? Or is it in voice chat etc?

 

Does not appear to happen on my 6900xt when it is open, so it does not appear to be how Discord is meant to behave. Maybe it's a Nvidia thing if more users experience this?

Link to comment
Share on other sites

Link to post
Share on other sites

12 minutes ago, aDoomGuy said:

When Discord is open it drops Vram speed, is that what you're saying? Or is it in voice chat etc?

 

Does not appear to happen on my 6900xt when it is open, so it does not appear to be how Discord is meant to behave. Maybe it's a Nvidia thing if more users experience this?

Yep, all it takes is for it to be open it seems. No need to be in voice chat.

Link to comment
Share on other sites

Link to post
Share on other sites

See if disabling hardware acceleration in Discord fixes it. 

Quote my reply or I won't see your reply. It's the single overturning left arrow under every message.

I didn't ask if it was worth fixing, I asked for help fixing it.

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, LloydLynx said:

See if disabling hardware acceleration in Discord fixes it. 

As i said, i already tried that. I appreciate the effort tho, thank you.

But it appears i found a fix ! This seems to be on discord side, and dependant on the build you have installed on your PC. First i contacted discord, they told me to try the PTB version, which didn't help.

So, following some instructions a person posted on discord, i managed to fix it ! Here's how :

 

You need to download nvidiaprofileinspector on github. In there, type "discord" in the search bar so you have access to the the app's drivers settings. There, you need to find the line CUDA - Force P2 State and set it to Off. Click on Apply changes on the top-right corner, close nvidia profile inspector, restart Discord and you should be good to go !!

Link to comment
Share on other sites

Link to post
Share on other sites

6 hours ago, SephiRock said:

As i said, i already tried that. I appreciate the effort tho, thank you.

But it appears i found a fix ! This seems to be on discord side, and dependant on the build you have installed on your PC. First i contacted discord, they told me to try the PTB version, which didn't help.

So, following some instructions a person posted on discord, i managed to fix it ! Here's how :

 

You need to download nvidiaprofileinspector on github. In there, type "discord" in the search bar so you have access to the the app's drivers settings. There, you need to find the line CUDA - Force P2 State and set it to Off. Click on Apply changes on the top-right corner, close nvidia profile inspector, restart Discord and you should be good to go !!

Nice one.  Can confirm it works 🙂 

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

Hey everyone, I have a current setup of RTX 2070 Super with R5 3600 and I'm getting the same issue. Without discord open my gpu memory clock is 7900mhz with overclock, with discord open it reduces to 6800mhz even with overclock configured. It only happens with the windows discord app open. I tried disabling hardware acceleration and other options involving gpu and discord.

Link to comment
Share on other sites

Link to post
Share on other sites

On 1/26/2023 at 7:28 PM, SephiRock said:

As i said, i already tried that. I appreciate the effort tho, thank you.

But it appears i found a fix ! This seems to be on discord side, and dependant on the build you have installed on your PC. First i contacted discord, they told me to try the PTB version, which didn't help.

So, following some instructions a person posted on discord, i managed to fix it ! Here's how :

 

You need to download nvidiaprofileinspector on github. In there, type "discord" in the search bar so you have access to the the app's drivers settings. There, you need to find the line CUDA - Force P2 State and set it to Off. Click on Apply changes on the top-right corner, close nvidia profile inspector, restart Discord and you should be good to go !!

It did work, thank you. If discord chooses to look into this and fix it, would it be recommended we turn Cuda - Force P2 State back on?

Ryzen 5600X | EVGA RTX 3070 FTW3 ULTRA | 32GB Corsair Vengeance RAM

Link to comment
Share on other sites

Link to post
Share on other sites

9 hours ago, JohnnyNightCity said:

Hey everyone, I have a current setup of RTX 2070 Super with R5 3600 and I'm getting the same issue. Without discord open my gpu memory clock is 7900mhz with overclock, with discord open it reduces to 6800mhz even with overclock configured. It only happens with the windows discord app open. I tried disabling hardware acceleration and other options involving gpu and discord.

Follow @SephiRock 's solution.  that's the post highlighted in green

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

On 27/01/2023 at 00:28, SephiRock said:

Como eu disse, eu já tentei isso. Agradeço o esforço, obrigado.

Mas parece que encontrei uma solução! Isso parece estar no lado da discórdia e depende da compilação que você instalou no seu PC. Primeiro entrei em contato com a discórdia, eles me disseram para tentar a versão PTB, o que não ajudou.

Então, seguindo algumas instruções que uma pessoa postou no discord, consegui consertar! Veja como :

 

Você precisa baixar nvidiaprofileinspector no github . Lá, digite "discord" na barra de pesquisa para ter acesso às configurações de drivers do aplicativo. Lá, você precisa encontrar a linha CUDA - Force P2 State e defini-la como Off . Clique em Aplicar alterações no canto superior direito, feche o inspetor de perfil nvidia, reinicie o Discord e você deve estar pronto !!

Isso funcionou aqui!

Mas, existe algum efeito negativo sobre a desativação desse item?

Link to comment
Share on other sites

Link to post
Share on other sites

5 horas atrás, Kaythree disse:

Funcionou, obrigado. Se a discórdia decidir investigar isso e corrigi-lo, seria recomendável ativar Cuda - Force P2 State novamente?

Acredito que sim, manter o padrão do programa.

Link to comment
Share on other sites

Link to post
Share on other sites

Im getting 502mhz decrease when i launch discord  and im using a 1080ti 

 

Before Discords launched  image.png.5b3036700f343fddf6044f444deaa316.png                 after launching Discord   image.png.a1278177bd7e89ab6d2086e6f29146f0.png

Link to comment
Share on other sites

Link to post
Share on other sites

16 minutes ago, FluffyBunneh said:

Im getting 502mhz decrease when i launch discord  and im using a 1080ti 

 

Before Discords launched  image.png.5b3036700f343fddf6044f444deaa316.png                 after launching Discord   image.png.a1278177bd7e89ab6d2086e6f29146f0.png

It's because the driver forces P2 power state while discord is open.  You need to follow OPs solution to fix it

 With all the Trolls, Try Hards, Noobs and Weirdos around here you'd think i'd find SOMEWHERE to fit in!

Link to comment
Share on other sites

Link to post
Share on other sites

I registered to mention that I am also seeing this with discord on my 3090, specifically a drop from 9751mhz to 9501mhz.
The reason I registered to put my nickel in is I am also seeing this from Logitech G-Hub software.

At least it isn't cumulative.
Stock, followed by G-hub open and then discord.

Stock.thumb.png.52529397ebce5abff00be9d15dfcc399.png
G-hub.thumb.png.77a79ce54e5f2c6ad7c40d693810bb20.pngDiscord.thumb.png.41f246d3fe4dc5f1edec079045968456.png

Link to comment
Share on other sites

Link to post
Share on other sites

My gpu clock also gets stuck at 1605mhz just running discord... and i have to restart for it to go back, a friend having the exact same issue.

 

Discord Bug.gif

Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...

The latest driver from NVIDIA (528.49) should fix this issue, probably something to do with Discord's recent update allowing RTX 40 series cards to video encode using the new format.

 

Patch notes say

  • Discord update causes GPU memory clocks to drop to P2 state [3960028]

Intel i7-3820

Corsair Vengeance 32GB 1866

GTX 680

 

Link to comment
Share on other sites

Link to post
Share on other sites

  • 2 weeks later...

528.49 still drops to P2 state, and clocks still drops from 9751 to 9501.

 

Not solved.

 

Forcing P2 state works for Logitech G hub, but does not bring back my clocks for Discord apparently 🤦‍♂️

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×