Jump to content

Frame skips in all games

niju
 Share

This started happening in CSGO when I built my PC about a year ago. On some maps in the first 5-10 minutes there would be seemingly random spots during play when all frames for a few hundred milliseconds would be lost.

 

I've deleted and reinstalled drivers, changed GPU power delivery, updated Windows and cleaned (but not reset) it.

 

Windows 11 64 Bit

Asus Z390-E Strix

BIOS Update 20191126

Intel i7-9700k

Asus RTX 3080O White

Corsair Vengeance LPX 2x16 3200

Samsung 860 Evo

Samsung 870 Evo

Corsair 850W PSU

 

The video below demonstrates what is going on. While it was originally not intrusive and didn't happen much, it's now occurring regardless of what game I play and increasingly often.

Link to comment
Share on other sites

Link to post
Share on other sites

Not sure if this would be helpful but I did have a crashing issue with a game before that was solved via GPU driver. Instead of just reinstalling the driver I instead installed a year old version of the drivers which was much more stable than the recent drivers. I found info on which driver version was most stable on reddit. If you haven't tried it yet see if you can find what the most stable driver is for your GPU and install it.

Link to comment
Share on other sites

Link to post
Share on other sites

Changing drivers hasn't helped unfortunately

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×