Jump to content

Need help with my Laptop! (Please poor Student needs help)

 Share

Hello today, I dropped my Lenovo Thinkpad L14 Gen 1 from around 20 cm on my wooden floor. It fell vertically down and hit the ground with the bottom first. It was on during the entire time. Now it won't turn on when I press the Power Button. The power button does light up when I plug in the charger.

Here is a video of my Laptop:

https://youtu.be/9Tg6MIiQQKs

Here is the inside:

https://imgur.com/a/zuhHg9o

 

The red light (the I on the front of the laptop) isn't working either.

It is an AMD version, and it has an SSD (So it isn't an HDD problem)

I already tried: - everything from this list

as far as I know the Ram wokrs, it is not the Battery, Powerbrick

I think I broke the Motherboard, is there a way to check? 

ps if this isn´t the right place to ask for this type of advise, where can I finde the help I need? 

Link to comment
Share on other sites

Link to post
Share on other sites

2 hours ago, Noobbuilder69 said:

It was on during the entire time.

And it stayed on after the fall?

 

2 hours ago, Noobbuilder69 said:

I think I broke the Motherboard

The way to think about it is "what could have happened inside, due to that kind of force?". The most obvious things are anything with a direct PCB based interface (Ram, NVME, wireless card etc), the next would be the flat connectors where the shock could have "released" the clip that keeps them in place.

 

My advise would be to take it apart as much as possible, check everything for physical damage, clean everything*, and reassemble, leaving out optional components (battery, wifi, etc)

*how often have you read "I re-seated the card and it work fine now"

image.png.b2bebf068a12b1de9f304c9492607b1d.png

Yellow circle look like the plug may be unseated. Red circle looks like loose washer? (both maybe just artefacts of the angle though)

Link to comment
Share on other sites

Link to post
Share on other sites

Try unplug the battery, press and hold power button for 30 secs and then plug in the power. 

| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×